LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-11-2005, 03:52 PM   #1
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 60
keyboard keys processed incorrect


just reinstalled ubuntu (preview version 5) today, and love it so far.. at least compared to v4 (btw, i encourage those who use or used ubuntu to try this one out )

im having problems with linux and my keyboard. well, my keyboard works fine and all.. its just that some keys are processed inappropriately. i noticed this when i first opened terminal window and tried cd'ing somewhere.
my slash key shows up as (when i type it anywhere)... double quote key shows up as .. other slash (windowz slash) shows up as .... shift + comma (less than sign) shows up as '.... etc etc

im thinking its just something wrong with my keyboard config (slash) language settings or something (question mark... lol.. sorry these keys arent working, is my question mark :S)

i have a logitech mx cordless duo.. wireless keyboard (slash) mouse.

anyone have a tip for me to solve this (question mark)

thanks for the input

Last edited by nadroj; 03-11-2005 at 03:54 PM.
 
Old 03-11-2005, 04:22 PM   #2
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 47
Hi.

I can't figure it out from your description, but I'll (1) ask you some probing questions; (2) give you some paths to go down, in case you haven't already:

* does the keyboard work in the `plain' console (the one you get to by hitting C-M-F[1-6]?
* does loadkeys work?
* does xev produce correct output? (have it run in a terminal, then hit a few keys)
* does gkb_xmmap and/or setxkbmap work?
* go to (control-panel-like-thing) -> ... -> keyboard; does your `physical' keyboard model match your `logical' model?
* (same place) is the layout sensible?
* does .Xdefaults look sensible?
* try this:
$ echo | xrdb -load -
** in case that produces a new look that you don't like, use this as a template for restoring your settings:
Xft.antialias: 1
Xft.dpi: 96.000000
Xft.hinting: 1
Xft.hintstyle: hintmedium
Xft.rgba: none
*Background: grey
*Foreground: black
xterm*Foreground: white
xterm*Background: black
xterm*Border: dark blue
xterm*ScrollBar: off
xterm*TitleBar: off
xterm*TextUnderIcon: off
xterm*AllowIconInput: off
xterm*AutoRaise: off
xterm*termtype: vt100
xterm*ttyModes: intr ^c susp ^@ dsusp ^@ kill ^u eof ^d

if all else fails: Don't panic

hope this helps,

Jonas Klker
 
Old 03-11-2005, 07:30 PM   #3
Nishtya
Member
 
Registered: Feb 2004
Location: Homeless
Distribution: PCLinuxOS
Posts: 170

Rep: Reputation: 30
Same exact problem here in Kanotix (also Debian) was solved (in KDE) by going into Control Center>regional & accessibility>keyboard layout> xkb options tab and unchecking enable xkb
 
Old 03-13-2005, 11:56 PM   #4
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Original Poster
Rep: Reputation: 60
thanks jonas for the input..
although i have no clue what 80% of it meant! :P im quite new.
anyhow, i was checking other settings and it all works now. i can go and mount my ntfs partitions and finally listen to music while exploring the world of linux!

this is what i did to solve it:
opend the config for my keyboard (system > preferences > keyboard)
under the 'layouts' tab i had already set the 'keyboard model' to the one i have, 'Logitech iTouch Cordless Keyboard (model Y-RB6)'. this didnt solve the problem... but i looked in the 'selected layouts' and added 'us english' as my layout, and it works now. it was setup to default use 'Canadian' which messed it all up. i AM Canadian and setup my system install that way, but for some reason ubuntu thinks Canadians dont have a slash key or many others! jk

thank you to you both for the time.
 
Old 03-14-2005, 02:28 AM   #5
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 47
np, congrats and enjoy linux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard is swapping keys jamiem Linux - Newbie 7 06-23-2005 08:50 PM
How to configure my keyboard keys. jrfly Linux - Newbie 7 12-16-2004 03:54 PM
some keys are not functinal on keyboard chongluo Linux - Newbie 3 10-10-2004 05:38 AM
Assigning keyboard shortcuts to keyboard keys the who Linux - Hardware 3 02-20-2004 09:36 PM
Keyboard Problems: Incorrect characters h1tman Slackware 1 09-03-2003 04:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration