LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-13-2004, 08:07 AM   #1
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Rep: Reputation: 15
key shortcut to start terminal?


hi there:

just a quick question. is there a way to make a keyboard shortcut keys to start up the terminal? i am running Fedora Core 2 with GNOME. i had a look at Menu->Preferences->Keyboard Shortcuts, but i don't know how to add my own "Action" the define a shortcut to it.

many thanks

yours

CHUN
 
Old 10-18-2004, 12:54 PM   #2
beebop
Member
 
Registered: Sep 2004
Location: Bend, Oregon
Distribution: Ubuntu Breezy and FC4
Posts: 43

Rep: Reputation: 15
This is the exact problem I've been searching for the solution to. If you find a way, would you post it here? I'll do the same...
 
Old 10-18-2004, 12:59 PM   #3
beebop
Member
 
Registered: Sep 2004
Location: Bend, Oregon
Distribution: Ubuntu Breezy and FC4
Posts: 43

Rep: Reputation: 15
I think I found it. Late for work now, so no time to test!


Ctrl-Shift-t --> aterm:

gconftool-2 -t string -s /apps/metacity/global_keybindings/run_command_4 "<Ctrl%gt;%lt;Shift>t"
gconftool-2 -t string -s /apps/metacity/keybinding_commands/command_4 "aterm"
 
Old 10-18-2004, 01:40 PM   #4
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
hi there:

after doing a bit of searching on the net, i found the solution which i think is the same as you described but using the Configuration Editor (gconf-editor) instead.

in addition, the place i found the info also got quite a few gnome tips and tricks, which are quite fun to check out. its at:

http://gnome-hacks.jodrell.net/all.html

thanks

CHUN
 
Old 10-23-2004, 10:45 AM   #5
lel800
Member
 
Registered: Aug 2003
Distribution: Red Hat RHEL WS 3, RHEL WS 4
Posts: 228

Rep: Reputation: 30
Quote:
Originally posted by beebop
I think I found it. Late for work now, so no time to test!


Ctrl-Shift-t --> aterm:

gconftool-2 -t string -s /apps/metacity/global_keybindings/run_command_4 "<Ctrl%gt;%lt;Shift>t"
gconftool-2 -t string -s /apps/metacity/keybinding_commands/command_4 "aterm"
I'm trying to launch a terminal window using the keyboard too. I'm not sure I understand what you meant from the above but I tried to hold down the ctrl and shft keys while pressing the letter t and that didn't work.

If anyone has ideas please share. Thanks.
 
Old 10-23-2004, 11:22 AM   #6
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
hi, you can use the gconf-editor.

see the below link, it tells you exactly how.

http://gnome-hacks.jodrell.net/hacks.html?id=14
 
Old 10-23-2004, 12:20 PM   #7
lel800
Member
 
Registered: Aug 2003
Distribution: Red Hat RHEL WS 3, RHEL WS 4
Posts: 228

Rep: Reputation: 30
Thanks for taking the time to respond...

The link contains interesting information but I can't make use of it. In order to act on the suggestions it contains I would need to be able to use my touchpad. I can't use my touchpad. I can only use the keyboard and my OS automatically runs X at start up.

So I need to edit a config file to try to set up my touchpad but I need to get to a terminal to do that...Only using the keyboard. While the link says ..

"* Go to "Apps->Metacity->Keybinding Commands"

I can't do that. I need to be able to type something and either get out of x altogether or open a terminal.
 
Old 10-23-2004, 12:49 PM   #8
beebop
Member
 
Registered: Sep 2004
Location: Bend, Oregon
Distribution: Ubuntu Breezy and FC4
Posts: 43

Rep: Reputation: 15
ah, i see your problem. Since you can't use your touchpad, you need some way to get to the terminal, right? Well, it seems the only way to set up a key to open a terminal is to edit your metacity configuration (metacity is the window manager running over gnome). Unless you can get to your shell. If booting with GRUB, it's easy to boot directly into your command-line shell. Just stop it from automatically booting up by hitting an arrow key before it chooses your Linux OS. Then you can hit 'e' to edit the GRUB commands. Once in there, you can scroll to the middle line and hit 'e' again to edit that line. Add one word: 'single' at the end of that line and grub will boot to the shell. Don't worry about making mistakes while editing, GRUB will not save any changes next time it boots up.

Once you get into your shell, use those two commands I listed above:

gconftool-2 -t string -s /apps/metacity/global_keybindings/run_command_4 "<Ctrl%gt;%lt;Shift>t"
gconftool-2 -t string -s /apps/metacity/keybinding_commands/command_4 "xterm"

Notice I changed 'gterm' to 'xterm' just because my system uses the xterm terminal program.

Test it by hitting Ctrl-Shift-t. It should work immediately with no resetting or anything.

These directions relate directly to my system (Fedora Core 2 with Gnome and Metacity) but Fedora is very similar to RedHat. If you get stuck anywhere, I can send more detailed instructions. At the moment, I'm leaving for work though.

Good luck!
 
Old 10-23-2004, 12:57 PM   #9
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
how about the Ctrl+Alt+F1->F7 short cuts?

on my systems, this switchs between a series of single user mode without X and F7 being the X+gnome.
 
Old 10-23-2004, 01:06 PM   #10
lel800
Member
 
Registered: Aug 2003
Distribution: Red Hat RHEL WS 3, RHEL WS 4
Posts: 228

Rep: Reputation: 30
Quote:
Originally posted by beebop
ah, i see your problem. Since you can't use your touchpad, you need some way to get to the terminal, right? .............

If booting with GRUB, it's easy to boot directly into your command-line shell. Just stop it from automatically booting up by hitting an arrow key before it chooses your Linux OS. Then you can hit 'e' to edit the GRUB commands.
Thank you for your response.

When GRUB is entered, I see that I can use the arrow keys to select the OS. Right now there is only one option - Red Hat 9 and only one kernel option. Other than that I don't see a way to avoid making the selection and entering X.. I tried pressing e but nothing happens. It says I can enter p then a password. I tried that and I got into a command line in GRUB but what then? And I don't want to modify the kernel here.

Thanks anyway. I'll do a bit of reading on GRUB.
 
Old 10-23-2004, 01:21 PM   #11
lel800
Member
 
Registered: Aug 2003
Distribution: Red Hat RHEL WS 3, RHEL WS 4
Posts: 228

Rep: Reputation: 30
I got it...

I can accomplish what I need to do by pressing "ctrl-alt-F2" simultaneously after I've logged into X. This allows me to login in again but this time in text mode.
 
Old 10-23-2004, 01:35 PM   #12
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
great! actaully, the ctrl+alt+F2 text mode saved my life a few times when i got stuck with X

have fun
 
Old 10-23-2004, 02:04 PM   #13
lel800
Member
 
Registered: Aug 2003
Distribution: Red Hat RHEL WS 3, RHEL WS 4
Posts: 228

Rep: Reputation: 30
Thanks for your suggestion chunlee
 
Old 10-23-2004, 03:08 PM   #14
beebop
Member
 
Registered: Sep 2004
Location: Bend, Oregon
Distribution: Ubuntu Breezy and FC4
Posts: 43

Rep: Reputation: 15
wow. I've never used that Ctr-Alt-F2 thing before. Whenever X got buggered with me, I would restart and use grub to enter single-user text mode to fix it. Good tip.

(and by the way, changing anything in the Grub startup screen is safe. You CAN add and subtract kernel options there, but if you do, it will automatically go back to normal on the next reboot. I usually just use it to change it's bootup mode, though. To change the grub options permanently, you would have to edit /etc/grub/grub.conf. )
 
Old 10-23-2004, 04:22 PM   #15
chunlee
Member
 
Registered: Jun 2004
Location: london
Distribution: gentoo
Posts: 114

Original Poster
Rep: Reputation: 15
great! glad i can help. can't remember where i read it first though.

peace

CHUN
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Emacs shortcut key for compiling Franziss Linux - Software 3 08-24-2005 10:12 PM
How to look up the shortcut key of my linux shell zyzyis Linux - Newbie 1 10-02-2004 07:51 AM
quick shortcut key to start xterm - how? theMonkeY Linux - Newbie 4 09-03-2004 05:42 PM
KDE shortcut key question redss Linux - General 1 05-16-2004 10:08 PM
shortcut key for rh ? toships Linux - Newbie 1 04-09-2004 03:17 AM


All times are GMT -5. The time now is 08:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration