LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Kernel upgradeing in SuSe 8.0 (https://www.linuxquestions.org/questions/linux-newbie-8/kernel-upgradeing-in-suse-8-0-a-73839/)

shizzo 07-18-2003 09:49 AM

Kernel upgradeing in SuSe 8.0...HELP MEEE
 
When i tried to upgrade to kernel 2.4.21 (now i'm using 2.4.18) i did all that is writen in all kind of "kernel compiling docs" starting from:
unpacking it in /usr/src;
linking new dir to linux;
make clean,
make xconfig (then configurating it the best i knew),
make dev (althou i did not use modules),
make bzImage,
editing lilo.conf so that on first place loads a new vmlinuz
restarting lilo
and finaly restarting my system....when it was booting it goes to some specific line where it says :
Kmod:failed to exec /sbin/modprobe -s -k nls_iso8859-1, errno =2
Kernel panic:VFS:Unable to mount root fs on 03:09
.........then after a few sec's........
spurious 8259A interrupt:IRQ7

i tried all i knew and all i get was a black screen (which is worse that problem before)...........please help meeeee

i am using suse 8.0

BigBadPenguin 07-18-2003 12:20 PM

I think without a "make install" the image is just made in /usr/src/linux. You need to mv it to /boot. That should sort you out.

shizzo 07-18-2003 12:29 PM

corect me if i'm wrong but i allready put the bzimage in the /boot dir renamed it vmlinuz-2.4.21 and put the path in lilo.conf

thnx

grym 07-18-2003 03:58 PM

Good that you copied it there but understandable that he didn't know it since your first message didn't let us know that. you say you didn't make modules and one of the error messages is from kmod (the kernel module loader) and it is looking for a module for native language support, specifically "nls_iso8859-1". i would look there maybe.
Also did you compile in support for you file system? was your old kernel using init.rd? check and make sure lilo isn't trying to use init.rd if it doesn't exist for this kernel. i would check these things for a start.

Good luck


All times are GMT -5. The time now is 12:38 PM.