-   Linux - Newbie (
-   -   (kernel) update(s) failing - swap space? (

Glaedr 01-20-2012 10:28 AM

(kernel) update(s) failing - swap space?
For a couple of days now my automatic security updates have been failing. So today, I tried updating through Yast, and got an error which said that a further 119mb were needed to install a particular update. I Googled the error and saw that it might be a CPU issue. I didn't have very much running - just Firefox and the file indexing thing that starts automatically when my laptop is booted. But I closed those just in case and retried. It didn't make any difference.

So I tried installing the other updates on their own to make sure it was that particular package that was causing the problem and it wasn't just a general error. Twice I got a message about rebooting / logging in again - which I did. But all of the same updates were still listed. So I Googled the problem again and found out how to update through Zypper.

This time, several packages were upgraded. But when it got to the kernel update again, it gave me a similar error to the one shown in Yast:

Installing: kernel-pae- [error]
Installation of kernel-pae- failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: installing package kernel-pae- needs 119MB on the / filesystem

I tried rpmdb --rebuilddb and then ran zypper update again. But no luck. I don't have anything else running - other than Firefox, just to post this. One page spoke about swap space possibly having to be expanded, but I can't find anything that specifies how to do this.

I use OpenSuse 11.4 and KDE. Can anyone please tell me how to do it, or suggest anything else to try?

Thanks in advance.

amani 01-20-2012 12:39 PM

Do you have enough diskspace for / ?

snowpine 01-20-2012 01:08 PM

Disk space and RAM/swap are separate resources. The page you read is not relevant to your problem. You need to free up disk space by deleting files, emptying the trash, etc. (Or get a bigger hard drive I suppose.)

Glaedr 01-20-2012 02:25 PM

My diskspace is fine. I have almost 200GB free. Which is why I thought it must be referring to RAM. Sigh. :( The other updates added up to about 350MB too and they installed fine when Zypper got to them first.

suicidaleggroll 01-20-2012 02:36 PM

Could you post the output of "df -h"?

Glaedr 01-20-2012 02:41 PM

Filesystem Size Used Avail Use% Mounted on
rootfs 20G 19G 0 100% /
devtmpfs 988M 196K 988M 1% /dev
tmpfs 994M 184K 994M 1% /dev/shm
/dev/sda2 20G 19G 0 100% /
/dev/sda3 272G 77G 194G 29% /home

Do kernel updates install to rootfs or sda2? :(

snowpine 01-20-2012 02:41 PM

You can use a Live CD and the Gparted partition editor to shrink /home and grow / (but make a backup first!!!).

Alternately you can delete some stuff in / that you don't need, like log files or package manager cache.

Are you comfortable with either of those ideas?

suicidaleggroll 01-20-2012 02:44 PM


Originally Posted by Glaedr (Post 4580088)
My diskspace is fine. I have almost 200GB free.

Not in / you don't


Originally Posted by Glaedr
/dev/sda2 20G 19G 0 100% /

You need to free up disk space

Glaedr 01-20-2012 02:53 PM

I'm sorry, I'm new to this and I'm a little confused. The error first came up before the other updates installed, and combined they were larger than this kernel update. Also, all my documents etc. are on the partition that does have almost 200GB of space. How do I get into the other files to make space, and how do I know what I can safely delete?

Sorry, missed the first reply first time around. Is it really necessary to use a Livecd to edit partitions? I don't mind deleting things as long as I know what I'm safely able to delete.

snowpine 01-20-2012 03:01 PM

You cannot resize a partition in use, just like you cannot change the tires while you are driving. :) So, you must use a Linux Live CD or USB with the Gparted partition editor (available in most distros). Do you still have the CD/USB you used to install Linux? If not, do you have a blank CD or spare USB thumb drive?

As to which files are safe to delete, I am not an OpenSUSE user, I don't want to give you bad advice, hopefully another member can assist you with that.

Glaedr 01-20-2012 03:08 PM

I do have a couple of Live CDs somewhere, including the OpenSuse CD I originally made. I was just hoping to get it fixed tonight and I have a file uploading for a friend. :p

Thanks for your help. :)

suicidaleggroll 01-20-2012 03:10 PM

I have OpenSUSE 11.4 on my home machine. I'm not sure what all you have installed to eat up that much space, my / partition is only using 6.7GB.

This command will take a while to run, but it will narrow down which directories are taking all of your disk space. You'll have to run it as root:

du -sh /*
Here is the output on my machine:

craig:/ # du -sh /*
8.6M    /bin
24M    /boot
224K    /dev
33M    /etc
819G    /home
168M    /lib
26M    /lib64
16K    /lost+found
8.0K    /media
8.0K    /mnt
110M    /opt
0      /proc
1.8M    /root
14M    /sbin
4.0K    /selinux
1.4M    /srv
0      /sys
0      /tmp
5.8G    /usr
328M    /var

Glaedr 01-20-2012 03:23 PM

Mine says:

9.5M /bin
70M /boot
380K /dev
50M /etc
77G /home
365M /lib
16K /lost+found
8.0K /media
4.0K /mnt
375M /opt
du: cannot access `/proc/13459/task/13459/fd/4': No such file or directory
du: cannot access `/proc/13459/task/13459/fdinfo/4': No such file or directory
du: cannot access `/proc/13459/fd/4': No such file or directory
du: cannot access `/proc/13459/fdinfo/4': No such file or directory
0 /proc
807M /root
13M /sbin
4.0K /selinux
2.6M /srv
0 /sys
670M /tmp
11G /usr
5.6G /var

I ran it as root, so I don't think the cannot access errors are a permissions thing. I don't remember installing anything through Yast/Zypper that was particularly big. I do have Photoshop installed with Wine, but I think Wine applications install on the same paritition as documents etc?

snowpine 01-20-2012 03:28 PM

Your /var is a lot bigger than suicidaleggroll's. You can keep working your way down the directory tree with:


du -sh /var/*

Glaedr 01-20-2012 03:33 PM

That brings up:

175M /var/adm
4.9G /var/cache
4.0K /var/crash
8.0K /var/games
146M /var/lib
28K /var/lock
41M /var/log
0 /var/mail
16K /var/mpi-selector
4.0K /var/opt
284K /var/run
128K /var/spool
364M /var/tmp
4.0K /var/X11R6
12K /var/yp

So the cache needs clearing, I'm guessing. I did the same for /usr and got:

du -sh /usr/*
636M /usr/bin
12K /usr/etc
4.0K /usr/games
16K /usr/i586-suse-linux
207M /usr/include
5.2G /usr/lib
297M /usr/local
57M /usr/sbin
3.8G /usr/share
716M /usr/src
0 /usr/tmp
12K /usr/X11R6

Can I access these files through Dolphin/Konqueror?

All times are GMT -5. The time now is 01:37 PM.