LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2003, 11:36 AM   #1
shadowhunter
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Slackware 10.2 + FRG + 2.6.15
Posts: 232

Rep: Reputation: 30
Exclamation kernel reboots on loading


hello all;

I just got one of those 2.6 kernels, test 5, for acpi on my notebook.

I compiled it exactly the same as a 2.4 (which worked) en the kernel now reboots on boot on, what am i doing wrong?

Or help me with this

I still have my old 2.4 kernel, and i have a problem with installing the cpufreq backport,
it gives a compile error, but I think it is already in the patch part (hunk x failed)
Yes, I have the right version number.

thanks for your replies and even for reading this.
 
Old 09-23-2003, 01:12 PM   #2
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Are there any error messages on the screen just before it reboots? - what are the last messages.
 
Old 09-23-2003, 02:16 PM   #3
shadowhunter
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Slackware 10.2 + FRG + 2.6.15
Posts: 232

Original Poster
Rep: Reputation: 30
the latest error message i was able to see was

Warning: Unable to find initial console

and then a reboot...
 
Old 09-23-2003, 07:31 PM   #4
joki
LQ Newbie
 
Registered: Sep 2003
Location: stralsund/germany
Distribution: gentoo
Posts: 14

Rep: Reputation: 0
i would start with an independent linux to view the log-file

maybe try this easy-to-use debian-clone (knoppix): http://www.knopper.net/knoppix/index-old-en.html
 
Old 09-24-2003, 07:17 AM   #5
shadowhunter
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Slackware 10.2 + FRG + 2.6.15
Posts: 232

Original Poster
Rep: Reputation: 30
that is not the problem, my 2.4 still boots ok (knoppix = 2.4, my latest download is).
But i am recompiling it right now, I think I forgot to compile the /dev filesystem support in it.

I shall let you know it worked or not

PS. is knoppix pronounced as "noppix" or "knoppix"
 
Old 09-24-2003, 03:13 PM   #6
joki
LQ Newbie
 
Registered: Sep 2003
Location: stralsund/germany
Distribution: gentoo
Posts: 14

Rep: Reputation: 0
i met the lead-programmer at the CeBit '03 and he pronounced it with a hard 'k' at the beginning
 
Old 09-24-2003, 03:27 PM   #7
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
Oh - man! Those kernels are more than a little different from 2.4 kernels.If you think you'll have to have it read some how-to's and do a search at the gentoo forums for 2.6 kernels.You don't even use the same commands for compiling it.
 
Old 09-24-2003, 03:44 PM   #8
shadowhunter
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Slackware 10.2 + FRG + 2.6.15
Posts: 232

Original Poster
Rep: Reputation: 30
I think i need some howto's...
I can't load and unload any modules

thank you all for your replies

P.S. when will the first 2.6 stable be out (I am newbie so takes it mostly months to years or a couple of weeks)
 
Old 09-24-2003, 05:05 PM   #9
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
You need 'module init tools' for that.If your 2.4 kernel works it might be a good idea to stay away from 2.6 for now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LiveCD just reboots pc after loading initrd phatrino Linux - General 1 10-02-2005 10:32 PM
Loading modules error after loading compiled kernel td0l2 Linux - Newbie 12 07-28-2004 12:10 PM
Installation FC2 reboots after loading img-files michelbouwhuis Fedora - Installation 2 06-10-2004 09:01 AM
Newly compiled kernel2.4.20 reboots after Loading Linux/BIOS check sucessfull. Demon333 Linux - Newbie 4 01-09-2004 03:38 PM
My Kernel Reboots the computer when it is loaded johnnyde Linux - General 3 06-18-2003 04:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration