-   Linux - Newbie (
-   -   Kernel Panic with P.H.L.A.K. (knoppix) (

nnicnac17 08-02-2009 07:52 PM

Kernel Panic with P.H.L.A.K. (knoppix)
I have my grub setup for Ubuntu, Backtrack 3, and P.H.L.A.K.. I Have them partitioned on a 60 gb hard drive with hda1:backtrack hda2:Ubuntu and hda3:PHLAK with hda4 as a swap space. They all installed fine. I have custom entries in menu.lst. I have the ubuntu entry which was autosetup by grub (ubuntu installed grub automatically). then I have backtrack 3 and PHLAK:

title Backtrack 3
root (hd0,0)
kernel /boot/vmlinuz ro root=/dev/hda1

title PHLAK
root (hd0,2)
kernel /boot/vmlinuz-2.6.9 ro root=/dev/hda3

Both Ubuntu and Backtrack boot fine but whenever I boot PHLAK it gives me

EXT2-fs: hda3: couldn't mount because of unsupported optional features (4)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,3)

I have looked for hours on google trying to find an answer and decided to post here. I really have no idea what is wrong so if you could throw out an answer or guess I can try them out or do research on the solution. I had a hard enough time getting the grub menu.lst setup and just started with linux a month ago. Thank you in advance

neonsignal 08-02-2009 09:32 PM

Does PHLAK use initrd, ie, do you need an initrd line after the kernel line in grub? I'm guessing something like:
You will need to have a look in the boot directory of the PHLAK partition to see.

Are you able to mount the PHLAK partition from Ubuntu?

nnicnac17 08-02-2009 09:55 PM

I don't see an initrd image file in the PHLAK boot file. I dont know if I need to compile one or not. I have heard you need one for grub but backtrack works fine without that line. And yes...I do believe I can mount and unmount the PHLAK partition from Ubuntu.

neonsignal 08-02-2009 10:40 PM


I dont know if I need to compile one or not.
I would have expected the install to have built or supplied the initrd.img if it was required. The initrd is an optional bootstrap stage to minimize the number of modules that have to be built into the kernel (so it is common to have it in newer distros). Is there a '/etc/mkinitrd' directory on the PHLAK partition?

It isn't necessarily called initrd.img; could be something like 'root.gz'. Perhaps if you could give a directory listing of /boot on the PHLAK partition it would give some help.

It looks like a fairly old distro, so I'm not sure how much help you can get from the original distributors.

Incidentally, did you actually install PHLAK or is it just a copy from the CD?

nnicnac17 08-02-2009 11:09 PM

Here is a directory listing of boot:

So not much and yes I have tried vmlinuz and the -2.6.9 one in the grub menu.lst. I dont see a root.gz anywhere. I dont have a mkinitrd in /ect/. I downloaded an ISO image and burned to a disk. booted off the cd and ran a program that installed PHLAK on the hard drive. Thanks for the replies.

nnicnac17 08-03-2009 10:47 AM

SOLVED I installed another Linux distro called JAD. Modified the grub menu.lst on that partition and everything works fine now :). Thanks for all the help

stjenkinsjr 02-19-2011 09:44 AM

Howto install BT4 on toshiba 3500 portege?
If you have the time I would greatly appreaciate your help?
Backtrack 4
Any other distro...

All times are GMT -5. The time now is 02:44 PM.