-   Linux - Newbie (
-   -   Kernel Panic - Unable to mount root FS (

Halospree13 08-10-2006 02:02 AM

Kernel Panic - Unable to mount root FS
Ok, so I tried being bold and not using Gentoo's graphical live CD and went with the minimal CD. When I rebooted after installing lilo I get this error:

Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block

I searched around and found that I could have made a typo in lilo.conf or didn't include support for ext3 in the kernel, so I triple-checked that and recompiled the kernel. It still didn't work. I've tried putting root=/dev/hdb3 in append instead of on its own as I've seen in a solution, and that still doesn't work.

I'm stumped.

Here is my lilo.conf -

Here is my .config -

Thanks for your help.

MasterC 08-11-2006 02:39 AM

What about your /etc/fstab, did you make a [correct] entry in there for your / partition?


pablob 08-11-2006 12:46 PM

So, you have two HD ?

On your lilo.conf, you say:

boot=/dev/hda (first HD)

and then your root FS is mounted on

/dev/hdb3 (third partition on second HD )

Are you sure this is ok ?

Isn't your root /dev/hda3 ?

Halospree13 08-12-2006 02:33 PM

I have all that already, and yes, my fstab is correct (I followed the install guide), but if you want me to post that as well then I will.

No, my root is /dev/hdb3. I have Windows on my first HD and Gentoo on my second.

hardly 01-21-2009 01:05 AM

Where's the follow up?
I'm not totally new to linux, but I'm new enough that I wish people would share the epilogue of their troubling stories so others could gather possibly helpful information that might aide them in their own open source endeavors.

How does it end? Was it a happy ending?
I wish old stuff like this that doesn't have a resolution, would get pruned so people do not waste their time reading search results that do not contain an outcome.

markush 01-21-2009 03:37 AM

Hello together,

I agree with hardly.


All times are GMT -5. The time now is 12:06 AM.