-   Linux - Newbie (
-   -   kernel panic unable to mount root file system (

corky383 11-21-2011 04:37 AM

kernel panic unable to mount root file system
Heres a little background info that might or might not be relevant:

Running Ubuntu 9.10 or 9.04

Recently I added some some software for dvd backups, and also changed my repositories allowing restricted extras using the medibuntu howto When I rebooted the following day I got to Grub diplaying on the screen and then a kernel panic.
SO as I understand it this means that the grub has done all its stage 1 and 2.

When I boot up using a Ubuntu 9.04 live cd I cannot get a full live ubuntu, only a command prompt. There are lots of errors:


[78.391716] SQUASHFS error: sb_bread failed reading block 0xa759c
[78.391716] SQUASHFS error: unable to read page , block 29d61838, size 57fb
AT the command prompt I tried to use the /usr/sbin/grub command but it returns a similar


SQUASHFS error zlib_inflate returned unexpected result

segmentation fault (core dumped)

I also tried booting using a 8.10 live cd and got a bunch of similar errors messages

ANY advice is welcome bear in mind I am a noob

raskin 11-21-2011 11:34 PM

Looks like physical damage to your LiveCD.

sb_bread failure means that kernel tried to read data from a block device (in this case, optical drive) and failed.

ukiuki 11-22-2011 12:44 AM

Tinycore live cd might boot there even if you have problems with the cd drive, Tinycore is really small only 10Mb what can make things easier for your drive, then you can access your system.


jmc1987 11-22-2011 12:56 AM

I agree its corrupted or unreadable data. I used to get error like that downloading these huge games and stuff with out a download manager or torrent.

corky383 11-30-2011 11:25 AM

tinycore boots! not multicore!
I managed to boot the laptop using Linux TinyCore which is only around 10mB. But with this I only have a very basic command prompt setup, I haven't managed installing firefox yet so no internet on that laptop.
My grasp of command line usage is pretty limited and I lack the time (family commits etc.) for scrolling through the netverse.
But I have figured out that the cd rom boots tinycore (10mB) but not able to boot multicore which is appprox 50mB.

Originally I couldn't boot my ubuntu install but as I understand that issue its something to do with the kernel.

What I would like to know is how would I install a new kernel from usb and how would I choose the right kernel??

Otherwise is there any files that I should try deleting to get back to previous/prior setup, before I added the dvd libdvdcss files??

I have also posted this message on lauchpad Question #179532

raskin 11-30-2011 12:46 PM

Do you boo these to the same rewritable optical disk?

Maybe you could get some USB-drive targeted image of some moderate-size distribution: if your problem is your CD drive, USB boot should solve the problem...

corky383 12-01-2011 04:27 AM

unfortunately, my laptop is about 7 years old and not usb bootable.
I also noticed that /boot directory is empty, there doesn't seem to be a grub file in there, I need to figure howto build a new grub file

raskin 12-01-2011 04:37 AM

Maybe you could download a minimal boot CD that uses GRUB and use it to boot from the USB?

Also, did you check the BIOS updates? It is not impossible that your notebook BIOS did recieve an update with USB boot.

All times are GMT -5. The time now is 03:08 PM.