-   Linux - Newbie (
-   -   kernel panic - not syncing: VFS unable to mount root fs on unknown-block(8,3) (

AllShk 11-21-2009 08:38 PM

kernel panic - not syncing: VFS unable to mount root fs on unknown-block(8,3)
Hey guys...
Some guys here reported this error message too
but i think it's another case because i'm using other distribution and i did not updated my kernel (the main cause for this error in the other cases)
I've got a similar problem with ubuntu 9
but the only thing i did was update some files using the update manager
i was also trying to make the wireless network works too and i've just activated a driver
then when i was closing the applications to restart the system it crashed.
the screen got black and i couldn't move the pointer
when i restart the pc i got that error message =/
does anybody knows what happened and what i have to do to fix it?
any help will be much appreciated


fotoguy 11-22-2009 04:30 AM

This kind of error is a really hard one to find, it can be many things. To me it sounds like a problem with the kernel itself, maybe the update manager downloaded another kernel update, and the package may have been corrupted.

This error can first appear when you boot the operating system, the kernel needs a ramdisk ('initrd' usually compiled into the kernel, or as a seperate file initrd.gz or initrd.img), to mount under itself (kernel filesystem) during boot up. If there is a problem with the initrd, then the kernel will not boot and will give this error.

It may be a possibility that there is a problem with the /dev directory, there are a few things in this directory that the operating system needs to boot, /dev/ramdisk /dev/console ...etc, it might be worth looking in here as well, the update manager may have updated soemthing it shouldn't have.

++nick++ 11-22-2009 05:14 AM

Hi All,

I go with fotoguy's suggestion , in such a case boot into rescue mode and alter the grub.conf to boot using the old kernel , once boot is successful , you can check with what really happened.

AllShk 11-28-2009 12:56 AM

Thank you, guys.
I thought it was something like this.
nick, if with rescue mode you mean the safe mode, i couldn't boot in this mode cause it returned the same error.
maybe i should have used the cd to access this files, but i solved the problem by reinstalling the OS.

All times are GMT -5. The time now is 05:02 AM.