-   Linux - Newbie (
-   -   kernel panic - not syncing: fatal exception in interrupt (

podsgrove 06-13-2008 07:53 AM

kernel panic - not syncing: fatal exception in interrupt
most answers to this problem that I have trawled through here at LQ or among the 18000 hits you get from Google generally fall into the catagories:
Distro-specific: where the reply refers only to one particular distro. - I have tried to load two versions of Ubuntu, Puppy, Suse and Parted Magic but all fail and give the same message.

CD problem: bad ISO image etc: - all of my CDs can't be corrupt and I have tried two different CD drives.

Hardware problem, bad memory, harddrive etc: I have tried different hard drives, cd drives, and memory in various combinations.

The worst thing about all of this is that I put an old Win98 disk in and it installed and ran without a hitch.


diwakars 06-14-2008 01:30 PM

Did u check ur hardware compatiblity for the distros which u've already tried.

debbie53 07-15-2008 11:25 PM

I have been getting the same message, but with a different situation. I had been running Ubuntu Edgy on my computer for over a year before my motherboard started having problems. I replaced the board with a new ASUS A8V-X, re-using my same memory and processor. It went through the POST fine, but now I can no longer boot the Ubuntu Linux that is installed on my hard drive, or any other, for that matter.

I have tried several different distributions, both installation and live CDs in addition to trying to boot what was already installed and previously working on an IDE hard drive from an old computer, in either regular or safe or recovery mode, but always get a kernel panic message. Depending on distribution, the message will be "not syncing - Fatal exception in interrupt", or sometimes "Attempted to kill init", or "no init found".

I have tried various boot options, either singly or all together: linux ide=nodma noacpi noapic nolapic irqpoll. I have disconnected everything except the memory, processor, video card and keyboard. I have set pnp to "no" and disabled everything I could in the BIOS. I am beginning to think the problem has something to do with the motherboard, because everything was working before I installed it. So I am curious as to what kind of motherboard you have.

I am sorry I cannot help with this other than to say what did not work for me. I hope someone can either point out what I have missed in trying to get this to work, or say definitively that the particular motherboard I have has some issues with Linux, and suggest how to get around them. Otherwise, I will have to give this board to someone who is using Windows and buy another one.

tithira 07-16-2008 02:22 AM

hi all,

I had the same problem but i checked my configuration. i tried to install i386 on intel core 2 duo cpu. then i tried X64_86 architecture. it installed fine.n worked fine too. try it this way

nslspot 07-16-2008 03:10 AM


I had been in that situation also when I installed Slackware.
If the previous OS is Linux and you are trying to reinstalled it, this will happen, you will see the Kernel panic bla bla bla....

Just make sure that all partition are clean from Linux partition before installing, then you can boot with your CD.

hasanatizaz 07-16-2008 03:53 AM

maybe you are passing a wrong switch from the bootloader. check if its hda or sda, it seems stupid but you should check.

All times are GMT -5. The time now is 01:14 PM.