LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Kernel panic: No init found. (https://www.linuxquestions.org/questions/linux-newbie-8/kernel-panic-no-init-found-82612/)

powerpc7640 08-16-2003 03:52 PM

Kernel panic: No init found.
 
I've been try to get linux up and running on a Macintosh Performa 6214 for a good week now. Being completly new at the linux thing hasnt helped much. So far I've managed to get the install kernel to load. After a little playing and a lot of reading stuff on the net i have it recognizing the install cd (YDL 2.3), i think. Now the last thing that comes up is

Kernel panic: No init found. Try passing init= option to kernel.
(last screen img www2.andrewproductions.com:5050/websites/stuff/performa2.jpg)

Then it restarts. I've tried messing around in the lilo.config file but nothing has worked that i've tried. Any help would be good.

The Goat.

system:
Performa 6214
Mac OS 9.1
40 meg ram
1gig ATA
-250 mac hsf
-128 swap
-50 A/UX root
-611 A/UX user
1gig SCSI external (mac boot disk)

MacKtheHacK 08-18-2003 01:55 PM

Let's see... It's mounting the CD as your root filesystem, then failing to remount your original root filesystemas /initrd, then unmounting and freeing it. Then it can't open an initial console, and can't run init.

Well, it's trying to run /sbin/init, which is the first program the kernel will run. Init is supposed to take care of getting all other user processes running, so if it's not there, nothing will happen. Is there a /sbin/init program on that CD?

Every distro does their boot process a bit different, and I don't know how Yellow Dog's works. Are you booting from a floppy, then the CD, or directly from the CD? Can you capture the entire boot sequence output, especially the part where it mounts your initial ramdisk and root filesystem?

powerpc7640 08-20-2003 07:52 PM

I don't have a way to capture all of the output, that was taken with a digital camera when it stopped to reboot. Every thing else goes past too fast for me to even read. I can't find that dir on the cd anywhere, is there a possibility that the YDL doesn't use this? There are some many kernals sitting on this computer that i may have put the wrong one in. I'll have to download another copy of the installer kernal ( is this different than a normal kernal? ) and see if i can get it to go any farther. Thanks for the input any more would be appreciated.

The Goat


All times are GMT -5. The time now is 01:16 AM.