-   Linux - Newbie (
-   -   Kernel Compile error (make bzImage) (

Nick_Stone 12-28-2006 08:18 AM

Kernel Compile error (make bzImage)
This is the first time I'm trying to compile a kernel and I've gotten so far as to the point where I'm supposed to "make bzImage"

After starting a make of bzImage everything looks fine, up until the point where I get the error;

mm/filemap.c:1863:16: warning: null character(s) ignored
mm/filemap.c:1863:15283: warning: no newline at end of file
mm/filemap.c: In function `__grab_cache_page':
mm/filemap.c:1863: error: syntax error at end of input
mm/filemap.c:45: warning: 'generic_file_direct_IO' used but never defined
make[1]: *** [mm/filemap.o] Error 1
make: *** [mm] Error 2

I've tried to reconfigure a couple of times (using gconfig and menuconfig)
I would appreciate any kind of help, tips, and/or hints.

I'm using Slackware 11 and the Kernel version which I'm trying to compile is: 2.6.19

stress_junkie 12-28-2006 08:45 AM

The kernel make process for the v2.6 kernel is much simpler than the one for the v2.4 kernel. Instead of doing make mrproper, make menuconfig, make clean, make dep, make, make install, ... you can just do make menuconfig followed by make. I haven't used make install on the v2.6 kernel yet so I don't know about that. The gentoo web site suggests doing this:

make && make modules_install
Go to the section named "Code Listing 14: Compiling the kernel"

I think that the next time I compile a kernel v2.6 kernel I will try this just to see what happens.

make menuconfig
make && echo Success; echo
make install && echo Success; echo
make modules_install && echo Success; echo

Gentoo documentation is excellent and most of it applies to any Linux distribution.

Nick_Stone 12-28-2006 01:30 PM

Hello again, I've now tried the above and when I ran just "make" I got the same message.

stress_junkie 12-28-2006 08:03 PM

I think that I would try reinstalling the kernel sources.

All times are GMT -5. The time now is 05:52 AM.