-   Linux - Newbie (
-   -   Kernel Compile Boot Loader? boot disk? (

SPMcRuube 12-03-2002 05:56 PM

Kernel Compile Boot Loader? boot disk?
I'm trying to reconfigure my kernel so that SCSI emulation for my CDRW is enabled (I think this may solve one of many problems) and I can use my usb printer and other things.

So I am doing all this from the KDE Kernel configurator. But what I don't understand is how I'm supposed to use this feature if I don't have a boot Loader. In my original install I opted not to install a boot loader to preserve the windows boot manager. SO I made a boot disk.
What I would like to know is how do I use the Kernel Configurator with a boot disk. So far I have run "make symlinks dep" and then "make bzImage" but when I reboot the "redhat network agent" is buzzin' and It tells me I'm running kernel 2.4.14.
However I saved changes to Linux-2.4 And as I understand (please tell me if I'm wrong) the "make symlink deps" makes a symbolic link to kernal 2.4.18

Or can I install a boot loader now or does that require re-installing Linux altogether.

Please get back to me on this I'm confused. :confused: :confused:

Thymox 12-03-2002 06:07 PM

You should not need to reconfigure and recompile your kernel just to have ide-scsi emulation. That comes as a part of the default kernel. What you should do, however, is add hdx=ide-scsi to the append section of your lilo.conf file (or the relevant part of your grub.conf file), where hdx is the device name for your ide cd burner, and reboot. When your system comes back up, your cd burner will be seen as a scsi device, and then you can continue as normal (cdrecord -scanbus, note down your scsi device numbers, then use your cd burning software).

You can install a bootloader at any time. If you're unhappy with using the Linux bootloaderin your MBR and having Windows as an option for it, you can use something called loadlin - it's a DOS program that allows you to boot Linux nicely.

As for the kernel specific make symlinks stuff... try what I suggest above first :D

SPMcRuube 12-03-2002 06:58 PM

What has been done so far...
Ok. to give you some background.

After installing RedHat 8.0 I couldn't mount cds. I would load one in and mount. Then, it would spin up and linux would freeze. I would have to do a hard reboot. So after some advice. I removed the "hdc=ide-scsi from the syslinux.cfg file on the floppy drive. That solved the mounting problem but I couldn't use a burning software. The software couldn't find the cdrom anywhere.

So I added back to the syslinux.cfg file the "hdc=ide-scsi" and I was back to square one. Then, I tried changing the /etc/fstab so that the cdrom would no longer be seen as /dev/hdc. I renamed it /dev/scd0 and made a symbolic link to mnt/cdrom (at least that's what I think I did) So far there hasn't been a change.

I still can't mount cds without linux freezing. So what else can I do?

Thymox 12-03-2002 07:02 PM

You could also try adding ignore=hdc...?

All times are GMT -5. The time now is 07:26 PM.