-   Linux - Newbie (
-   -   Kernel Compilation Probs (

MrSmee 09-16-2003 12:25 PM

Kernel Compilation Probs
Ok, newbie here, trying to compile a new kernel (2.4.22) mostly so I can support my wireless network card. Have comiled and (I think) sucessfully installed the new image, LILO sees it, and will boot to it, however, as soon as I boot to it, I get no display whatsoever. I know the kernel is booting (my hard drive is ticking away etc) but still have no video output. I've tried several different configs, including loading every video driver known to man as a module, just to see what works.
here's the setup, any advice will be greatly appreciated

SIS735 Chipset Based MB w/built in (wired) LAN (Mandrake sees this as an SIS900, and it works)

Nvidia TNT2 AGP Video Card (32MB Video Ram)

1024MB PC133 RAM

1300Mhz Athlon Processor

40Gb W/D Hard Drive

Floppy/CD-ROM/CD/RW (these are working correctly)

iblitzz pci wireless ethernet card (I don't know if this works or not, I can't get the kernel compiled correctly to find out)
Once again,

J.W. 09-16-2003 12:40 PM

This happened to me before, and the problem in my case was that the video resolution settings in XF86Config were set too high. If you haven't already tried it, you might bump down both the amount of VRAM and the default resolution. In your case, even though you've got 32M, you might try setting it to 16M, with a default color depth of 16 and a resolution of 1024X768. If that works you can incrementally step it up.

I can't promise this will solve the isssue for you, but that's what worked for me. -- J.W.

unSpawn 09-16-2003 12:41 PM

Nvidia TNT2 AGP Video Card (32MB Video Ram)
Did you compile and install the Nvidia module with your new kernel?
If unsure, check with "lsmod".

Also, if you didn't use your old kernel config as base, check it and your new one to see if you're missing any more features you should have enabled or disabled like AGP:
"diff -urN </path/to/oldconfig> </path/to/newconfig>".

_intrepidhero 09-16-2003 12:50 PM

kernel recompile
I recall having a similar error when I tried to recompile on my SuSE machine. The trick for me was that I was forgetting to run lilo after copying the new image to /boot
But I also have a wireless network card (USB not PCI though) and I didn't have to recompile the kernel, have you tried just installing the wlan-ng drivers? They work very nicely for me and I know they have a version for PCI cards. I would recommend downloading the sources since I never had any luck with the RPMs.
Hope this helps.

MrSmee 09-17-2003 03:19 PM

Thanks for the replies...... finally got the kernel compiled and running.... don't ask how..... took me about 17 compiles to get it running "just" the way I wanted (no extra modules or drivers, etc.)

All times are GMT -5. The time now is 11:50 AM.