LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2004, 03:52 PM   #1
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Rep: Reputation: 15
Kernel 2.6.2 - i810_audio lost


Got another problem :-) (learning from it)

since i've installed kernel 2.6.2 my sound is gone in KDE. at start it says smth like /dev/dsp not found.

ive checked "Intel i8x0/MX440" within kernel/ALSA configuration as module.

this driver doesnt seem to be the right one. i am missing the i810_audio module from 2.4.24 kernel :-(

when i modprobe this new module it seems to work but i still do not get sound.

any ideas?

Code:
$ lsmod
snd_intel8x0           32260  0
snd_ac97_codec         54788  1 snd_intel8x0
snd_pcm                88352  1 snd_intel8x0
snd_timer              24964  1 snd_pcm
snd_page_alloc         13060  2 snd_intel8x0,snd_pcm
snd_mpu401_uart         9984  1 snd_intel8x0
snd_rawmidi            23840  1 snd_mpu401_uart
snd_seq_device         10504  1 snd_rawmidi
snd                    46948  7 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,sn
d_mpu401_uart,snd_rawmidi,snd_seq_device
ipv6                  243904  8
appletalk              37840  2
ipx                    32292  2
soundcore              11232  1 snd
parport_pc             41004  1
lp                     13864  0
parport                40424  2 parport_pc,lp
autofs4                17152  0
af_packet              21128  0
agpgart                29996  0
nls_iso8859_1           7936  0
ntfs                   99564  0
msdos                  12800  0
via_rhine              22792  0
mii                     8192  1 via_rhine
crc32                   8064  1 via_rhine
usb_storage            66880  0
usbcore                98524  1 usb_storage
apm                    20716  0
rtc                    14664  0
ext3                  105128  0
jbd                    59544  1 ext3
alsa_init will fail when trying to set aumix...
 
Old 02-12-2004, 05:39 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
I had better luck using the old OSS drivers/modules instead of Alsa with 2.6.x to tell you the truth. I compiled my kernel with it built in.. worked like a charm.

Regards.
 
Old 02-13-2004, 01:53 AM   #3
sirphoenix
Member
 
Registered: Aug 2003
Location: Old Europe
Distribution: Debian Sid/Sarge
Posts: 37

Original Poster
Rep: Reputation: 15
hey trickykid, is there something within this forum like a collection of Q/A for Problems with 2.6? if there isnt, wouldnt it be an idea to collect those questions and (hopefully) answers?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lost ip when using a new kernel h_lina_k Linux - General 6 02-13-2004 03:53 AM
i810_audio.. not nvaudio? MizuChi Linux - Newbie 4 12-16-2003 10:18 PM
ip lost after kernel 2.4.22 luzi82 Debian 3 11-27-2003 10:10 PM
Mandrake 9.0 and i810_audio cmckay Linux - Software 1 01-03-2003 01:10 PM
I lost rmed my kernel config file. Anyway to create one from the kernel? severedhead Linux - Software 3 07-12-2002 08:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration