LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-27-2004, 07:37 AM   #1
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
KDE upgrade


I just downloaded all the FEDORA Core 1 rpms to upgrade to the latest KDE version and this is my dependency list.

Code:
error: Failed dependencies:
        libmad.so.0 is needed by arts-1.2.3-1.0.1.kde
        qt >= 1:3.3 is needed by arts-1.2.3-1.0.1.kde
        libFLAC++.so.2 is needed by k3b-0.11.12-0.fdr.0.1
        libFLAC.so.4 is needed by k3b-0.11.12-0.fdr.0.1
        libid3-3.8.so.3 is needed by k3b-0.11.12-0.fdr.0.1
        libmad.so.0 is needed by k3b-0.11.12-0.fdr.0.1
        qt >= 1:3.3 is needed by k3b-0.11.12-0.fdr.0.1
        qt-styles is needed by kdeartwork-3.2.3-1.1.1.kde
        libXm.so.3 is needed by kdebase-3.2.3-1.0.1.kde
        libmad.so.0 is needed by kdebase-3.2.3-1.0.1.kde
        openmotif >= 2.2 is needed by kdebase-3.2.3-1.0.1.kde
        qt >= 1:3.3 is needed by kdebase-3.2.3-1.0.1.kde
        themer >= 0:1.50 is needed by kdebase-3.2.3-1.0.1.kde
        libmad.so.0 is needed by kdegames-3.2.3-1.0.1.kde
        libfribidi.so.0 is needed by kdegraphics-3.2.3-1.0.1.kde
        liblcms.so.1 is needed by kdegraphics-3.2.3-1.0.1.kde
        xpdf is needed by kdegraphics-3.2.3-1.0.1.kde
        /etc/xdg/menus/applications.menu is needed by kdelibs-3.2.3-1.0.1.kde
        hicolor-icon-theme is needed by kdelibs-3.2.3-1.0.1.kde
        libjasper-1.701.so.1 is needed by kdelibs-3.2.3-1.0.1.kde
        libmad.so.0 is needed by kdelibs-3.2.3-1.0.1.kde
        qt >= 1:3.3 is needed by kdelibs-3.2.3-1.0.1.kde
        redhat-menus >= 1.4 is needed by kdelibs-3.2.3-1.0.1.kde
        openoffice.org < 0:1.1.0-16 conflicts with kdelibs-3.2.3-1.0.1.kde
        libmad.so.0 is needed by kdemultimedia-3.2.3-1.0.1.kde
        libmusicbrainz.so.4 is needed by kdemultimedia-3.2.3-1.0.1.kde
        libtag.so.1 is needed by kdemultimedia-3.2.3-1.0.1.kde
        libxine.so.1 is needed by kdemultimedia-3.2.3-1.0.1.kde
        trm is needed by kdemultimedia-3.2.3-1.0.1.kde
        xine-lib >= 0:1.0 is needed by kdemultimedia-3.2.3-1.0.1.kde
        libmad.so.0 is needed by kdenetwork-3.2.3-1.0.1.kde
        libslp.so.1 is needed by kdenetwork-3.2.3-1.0.1.kde

I think you would agree that this is rather extensive. I usually just download the dependencies from rpmfind or something but this is rediculous What should I do?

yum does not have the latest KDE version.
 
Old 07-27-2004, 07:46 AM   #2
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
it's a question of order
install qt, then base, them the surrounding stuff
 
Old 07-27-2004, 09:57 AM   #3
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Original Poster
Rep: Reputation: 31
I tried just the base package and got



Code:
error: Failed dependencies:
        kdelibs >= 6:3.2.3 is needed by kdebase-3.2.3-1.0.1.kde
        libXm.so.3 is needed by kdebase-3.2.3-1.0.1.kde
        libkmdi.so.1 is needed by kdebase-3.2.3-1.0.1.kde
        libkresources.so.1 is needed by kdebase-3.2.3-1.0.1.kde
        libkwalletclient.so.1 is needed by kdebase-3.2.3-1.0.1.kde
        libmad.so.0 is needed by kdebase-3.2.3-1.0.1.kde
        openmotif >= 2.2 is needed by kdebase-3.2.3-1.0.1.kde
        qt >= 1:3.3 is needed by kdebase-3.2.3-1.0.1.kde
        themer >= 0:1.50 is needed by kdebase-3.2.3-1.0.1.kde
        lisa < 7:3.1 conflicts with kdebase-3.2.3-1.0.1.kde
        kxmlrpcd < 7:3.1 conflicts with kdebase-3.2.3-1.0.1.kde
        libkateinterfaces.so is needed by (installed) kdeaddons-3.1.4-2
        libkmultitabbar.so.0 is needed by (installed) kdeaddons-3.1.4-2
        libkonqsidebarplugin.so.0 is needed by (installed) kdeaddons-3.1.4-2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE 3.2 Upgrade to KDE 3.3 Problems! Boyer Linux - Software 0 10-18-2004 03:47 AM
How to upgrade from KDE 3.2 to KDE 3.3 on SuSE 9.1 skydart Linux - General 26 10-16-2004 11:33 PM
kde 3.2 upgrade mokojin Slackware 9 05-13-2004 04:46 PM
Error trying to dist-upgrade or upgrade KDE prophet621 Linux - Newbie 0 09-10-2003 05:17 PM
KDE Upgrade kdmiller45 Linux - Software 3 06-05-2003 03:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration