LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Kde Log Viewer 0.91 (https://www.linuxquestions.org/questions/linux-newbie-8/kde-log-viewer-0-91-a-441962/)

C-Lo 05-05-2006 01:33 PM

Kde Log Viewer 0.91
 
http://sourceforge.net/projects/kdelogviewer/

I am trying to figure out on how to run the (kde)logviewer once it has finished installing but I think the installation failed because of errors it reported during the make and make install. I couldn't find the ./logviewer script anywhere (/usr/bin;/usr/local/..). Or does the compiling just create a job (at or cron)and it is up to me make the job display on my desktop? Has anyone seen errors like this before and if so what is the fix?

Quote:

cc1plus: warning: command line option "-Wmissing-prototypes" is valid for Ada/C/ObjC but not for C++
/usr/lib/qt3/include/qtooltip.h:86: warning: 'class QToolTip' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:69: warning: 'struct QUBuffer' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:77: warning: 'struct QUType' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:104: warning: 'struct QUType_Null' has virtual functions but non-virtual destructor
/usr/lib/qt3/include/private/qucom_p.h:287: warning: 'struct QUType_enum' has virtual functions but non-virtual destructor


I am currently running:
KDE Suse 10
2.6.13-15.8-default

Thanks for any assistance you can give.

:newbie:

C

bigjohn 05-05-2006 02:45 PM

That link to the sourceforge page you posted, mentions that kdelogviewer was designed for kde 3.2.x - yet you mention that you're using SuSE 10.0 - which has got to be using kde 3.4.3 or possibly kde 3.5.x so is it worth having a look at the SuSE software repository to see if it's available as an RPM for your SuSE version ???

Otherwise, just use VI or emacs or something to view whatever logs you wanted to view ???

regards

John

p.s. and yes, I'm just guessing about whether the kdelogviewer package linked has been updated for current kde versions or not - hell, I can't be bothered, and just use an editor to view my logs. Sorry if thats of no help.

C-Lo 05-05-2006 03:05 PM

Quote:

Originally Posted by bigjohn
.... mentions that kdelogviewer was designed for kde 3.2.x - yet you mention that you're using SuSE 10.0 - which has got to be using kde 3.4.3 or possibly kde 3.5.x ....


You know what John? I did miss that :study: and you are probably (99.9%) right with why I am encountering these errors with this install. I think I'll give up on it and look for a rpm as suggested. Thanks for the help.

C


All times are GMT -5. The time now is 07:49 PM.