LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-11-2003, 08:35 AM   #1
silv3rgun
LQ Newbie
 
Registered: May 2003
Location: UK
Posts: 4

Rep: Reputation: 0
Kde / Gnome


Hi all

I am new to Linux and decided to finally ditch and burn Windoz! I have installed Redhat 9 and was wondering if anyone can help me out with a couple of things.

I use KDE as my desktop but when I want to log out it goes back to the login screen and from there I have to choose Shutdown. This is the initial login screen that allows you to choose Gnome/KDE etc. Do I always have to do this?

Also. My network card is not recognised on boot up. When running through the boot proccess it says "Failed" but it works fine. How can I get rid of this message?

My last question is: are there any drivers for the 3com Airconnect 3CRWE737968 wireless card? Or even a Xircom CWE1100 wireless card? I have been searching but I dont think there is any.

Well, hope someone can help me out.

Thanks in advance

Silv3r
 
Old 05-11-2003, 08:53 AM   #2
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
Re: Kde / Gnome

Quote:
Originally posted by silv3rgun
I use KDE as my desktop but when I want to log out it goes back to the login screen and from there I have to choose Shutdown. This is the initial login screen that allows you to choose Gnome/KDE etc. Do I always have to do this?
Yes i think you have to do that in KDE, but it Gnome you can shutdown without loging out first....
 
Old 05-11-2003, 02:02 PM   #3
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
it is during the installation process that u can choose ur network card to not to activate duing boot process.well, afterwards u can try "setup" command from root
and go and setup networking once again and set the options
 
Old 05-12-2003, 04:10 AM   #4
SADANA
LQ Newbie
 
Registered: Nov 2001
Location: Amman - Jordan
Distribution: Slackware
Posts: 25

Rep: Reputation: 15
the [Failed] message might be because it's looking for a DHCP and "failing" to find one!
just go to the redhat network device settings and assign a static IP to your device! i.e desselect the DHCP option!
 
Old 05-12-2003, 04:42 AM   #5
iclies
LQ Newbie
 
Registered: May 2003
Location: saudi arabia
Posts: 3

Rep: Reputation: 0
you can go to network device control , choose your card if its listed there and press configure.. .. similarly in the next box press edit and here you can see a check box for activating the device on system boot.
but if you want to use it .. you should assign it a static ip.
 
Old 05-12-2003, 12:39 PM   #6
silv3rgun
LQ Newbie
 
Registered: May 2003
Location: UK
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks guys. I will try the DHCP thing as at the moment it gets an IP from my router!

Any ideas on the Logout thing?

Thanks again

Silv3r
 
Old 05-13-2003, 01:59 PM   #7
silv3rgun
LQ Newbie
 
Registered: May 2003
Location: UK
Posts: 4

Original Poster
Rep: Reputation: 0
Still dont work. Still says "Loading eth0 etc etc failed"

Spoke to Redhat and the guy reckoned I should leave it. Hmmmm

Still cant figure out the logout thing grrrrrrrr!

Thx

Silv3r
 
Old 05-14-2003, 10:18 AM   #8
jspenguin
Member
 
Registered: Feb 2003
Location: Wichita, KS
Distribution: Heavily modified Redhat
Posts: 194

Rep: Reputation: 30
Intejection on kde shutdown: KDE will only offer shutdown if you use kdm. Edit /etc/inittab and change gdm to kdm.
 
Old 05-14-2003, 03:06 PM   #9
silv3rgun
LQ Newbie
 
Registered: May 2003
Location: UK
Posts: 4

Original Poster
Rep: Reputation: 0
Thx for that!

Ashamed to say that I am not sure where to put it
this is what I have in etc/inittab

# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left. Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf:owerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345owerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:5:respawn:/etc/X11/prefdm -nodaemon



Where should I put it? Cant see a GDM

Thx for your help

Silv3r
 
Old 05-16-2003, 09:10 AM   #10
jspenguin
Member
 
Registered: Feb 2003
Location: Wichita, KS
Distribution: Heavily modified Redhat
Posts: 194

Rep: Reputation: 30
Oh. I see...
It's the line that says

x:5:respawn:/etc/X11/prefdm -nodaemon

I've never heard of prefdm before. Change it to

x:5:respawn:/usr/bin/kdm -nodaemon

You might not have kdm stored there, so try 'which kdm' to find out.
 
Old 05-17-2003, 05:36 AM   #11
kernel()
LQ Newbie
 
Registered: Jan 2003
Posts: 15

Rep: Reputation: 0
i agree your box is looking for a dhcp server to get its ip from, dhcp is enabled in the router right?, have you changed the number of addresses the router can assign at once? is your cable good? are you plugging your box into port one, or the shared port on the router?
 
Old 05-17-2003, 07:02 AM   #12
johnfader
LQ Newbie
 
Registered: May 2003
Posts: 1

Rep: Reputation: 0
silv3r,

I checked my logout, and RH9 sends me back to the same screen as initial logout, so I can click Sessions and change to whatever GUIs I have installed.

I'm a Linux newbie as well.

Cheers/The Fader
 
Old 04-16-2004, 12:07 PM   #13
alexmeske
LQ Newbie
 
Registered: Apr 2004
Distribution: Redhat 9
Posts: 1

Rep: Reputation: 0
Shutdown

To shut down the system from the command line, you need to be logged in as root.

If you are logged in as root and you want to shutdown the system immediately run:
> shutdown -h 0

The -h is for "halt". The "0" is the number of seconds for the system to wait before the shutdown begins.

If you are logged in as a user other than root, you can run
> su -
and enter your root password to switch user to root. Then run the shutdown command above.

Alex
 
Old 04-16-2004, 01:31 PM   #14
Mahony
Member
 
Registered: Jan 2004
Location: Glasgow
Distribution: Gentoo 2004.0, Debain 3.0r2, Mandrake 10.0 and Slackware 9.1
Posts: 173

Rep: Reputation: 30
Or you could set up sudo
 
Old 04-16-2004, 01:51 PM   #15
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
put this in /etc/sysconfig/desktop (or desktops .. i dont remember properly)

DISPLAYMANAGER = "kde"
or
DISPLAY_MANAGER = "kde"

(*sorry i cant remember much of redhat stuff as i dont use redhat anymore)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I have a Igel that comes with kde and gnome. gnome can not view the network thefedexguy Linux - Networking 5 01-21-2017 04:35 PM
KDE/GNOME switching? And how to connect to the internet in GNOME SuSE 10.0 Cards_STL SUSE / openSUSE 14 10-29-2005 08:21 PM
Gnome error - now I cant get xterm,kde,gnome covertops Linux - Newbie 3 02-24-2005 08:58 AM
couple of qs, gnome ftp, removing kde or improving speed of kde, startup modprobe darkleaf Linux - Software 2 07-20-2004 10:54 AM
kde destroyed my gnome! i hate kde! drigz Linux - Software 3 06-04-2004 07:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration