LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2004, 03:17 AM   #1
chriscallans
LQ Newbie
 
Registered: Sep 2004
Location: denver co
Distribution: mandrake
Posts: 4

Rep: Reputation: 0
kde desktop pop up prompt won't go away!


Hello..
i opened up a install file for flash player install, that i had on a cd, and it contained a 'read me' file that i opened and read...
when i exited the read me file, and removed the cd, from that point forward, everytime i boot linux mandrake kde desktop, i receive this pop up prompt...

The file file:/mnt/cdrom2/install_flash_player_7_linux/Readme.txt could not been loaded, as it was not possible to read from it!
Check if you have read access to this file.

Does anyone know how to get rid of this pop up prompt?
Thanks much...

chriscallans@yahoo.com
 
Old 09-23-2004, 07:46 AM   #2
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
I sound's to me, like your system is still expecting to see the file available from the CD rom.

Mandrake normally uses "Supermount" with data cd's and it would appear that for some reason hasn't unmounted the disc automatically.

One thing you could try would be to open a terminal/konsole and try to unmount it yourself.
Code:
$ umount /mnt/cdrom2
that might work, or if it won't let you do it as user, then
Code:
$ su
then enter that, input your root password and then try the umount command (oh and don't forget the $ bit in the code quotes is just the user prompt that should already be there - unless you managed to change it to something else).

After that do a reboot and see what happens - if it's got rid of the prompt, fine but you'd have to work out if you can then just put a data cd in as normal and search it via konqueror (or nautilus if you use gnome) and then take it out (again normally) to see if the prompt has re appeared or not.

If you can't search the disc, you may find that you have to manually mount data cd's - instead of umount, you'd just use mount /mnt/cdrom2.

You may also find that instead of calling the device cdrom2 your system may call it something else - for instance various linux versions I've tried, some have called it /dev/hdb or /dev/scd0 (which is a throw back to the day's when cdrw's needed scsi emulation to do the disc writing) or it could be called /dev/cdrom2 (notice the difference of the first bit /dev instead of /mnt).

Unfortunately it depends on how you machine is configured/wired up etc I only have to remember because i have a dvdrom and a cdrw - my system is wired so that I can only play audio disc's from the cdrw (only one audio lead to the sound card), but if I use a data cd the dvdrom is called either /dev/cdrom or /dev/hdb and the cdrw is either /dev/cdrom2 or /dev/scd0

Sorry if that all sound's a little confusing. It is, to start with, but once you know a bit more about how your machine is set up/configure/wired up it becomes clearer.

regards

John

p.s. The supermount facility, when first brought in, was know to cause minor problems with some systems - if you searched LQ for supermount it'd probably tell you how to go about disabling it - that if it appears to be the root of the problem - but then you would have to manually mount and unmount data disc's (a bit like you have to do in some other distro's)
 
Old 09-23-2004, 07:58 AM   #3
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
If I may, I'd say WAIT!, before you try BigJohn's advice, check you haven't got the autosave sessions enabled for KDE. If you have or you saved your session when you had a text editor open browsing that readme, KDE would have saved a note to tell itself to try and restore that window, and attempts to load the file where it previously was. Try turning off the autosave, or start a new session and then save that to overwrite the old one.
 
Old 09-23-2004, 08:10 AM   #4
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
Ooo! well done Proud, I didn't think of that one

regards

John
 
Old 09-23-2004, 12:29 PM   #5
chriscallans
LQ Newbie
 
Registered: Sep 2004
Location: denver co
Distribution: mandrake
Posts: 4

Original Poster
Rep: Reputation: 0
thankyou for the help

thankyou for your response to my delima...
i will try both suggestions...
the unmount does not work from the desktop using the cd icon...
and it will not eject from the icon on the desktop...
so i will try the su and the terminal , and also try to disable the auto save, although i didn't save the read me file that was opened with k write...
thankyou much...
cc
 
Old 09-23-2004, 02:37 PM   #6
chriscallans
LQ Newbie
 
Registered: Sep 2004
Location: denver co
Distribution: mandrake
Posts: 4

Original Poster
Rep: Reputation: 0
it fixed the problem

the problem is fixed...
thanks for all of your kind advice...
cc...
 
Old 09-23-2004, 02:47 PM   #7
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Could you please post how someone correctly answered your question so that others may find the solutions faster.
 
Old 09-24-2004, 08:53 PM   #8
chriscallans
LQ Newbie
 
Registered: Sep 2004
Location: denver co
Distribution: mandrake
Posts: 4

Original Poster
Rep: Reputation: 0
pop up prompt

oh, how good of you to point that out proud...
thankyou for asking...
i dual boot my system, and right after i had this prompt problem, my xp program which had been giving me a few headaches in the past, decided to bring forth another small problem, so i took the 'shot gun' approach, and re installed...
actually in my thankyou reply, the subject matter stated 'it fixed', which was a 'type error', which i so humbly and graceciously apoligize for, where as actually it should have stated 'i fixed'...
and i will in the future as requested, reply with the ut most attention to stating the solution and the step by step process in the journey through the repair of my system when and if that should arise...
thankyou so much for responding to my submission....and for pointing that out...
respectfully yours...
cc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Run a .desktop as root without password prompt subquantum Mandriva 3 08-01-2005 12:38 AM
KDE startup pop up problem Lasker Linux - Newbie 2 05-05-2005 09:21 AM
those little kde pop-up warnings tardigrade Linux - Newbie 3 05-05-2005 02:57 AM
desktop shortcut for a terminal prompt mannoulla Linux - Software 9 06-07-2004 02:05 PM
desktop shortcut for a terminal prompt mannoulla Fedora 1 06-04-2004 10:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration