-   Linux - Newbie (
-   -   KDE - copying to root folders. (

stf92 07-19-2010 07:11 AM

KDE - copying to root folders.
Linux kernel 2.6, slackware 12.0
KDE 3.5.7

I have some directories whose owner is root. When I enter the GUI (KDE) I always do it as normal user john. But then, when I want to copy a file to some of root's dirs, I get an "Access denied" notification. To be sincere, these dirs are in a window$ vfat partition and I can neither change the ownership nor the permissions.

So what I do is to switch to a root console and painstakingly type the whole path of both source and destination, with the help, of course, of tab completion. To su to root, copy the file and exit to john would be much more comfortable. But I don't know how to do it. If I do K Menu>Run Command and type 'su root' nothing happens. I would appreciate any suggestion. Regards.

David the H. 07-19-2010 07:21 AM

You have two basic options.

1) Remount the device to give you the appropriate permissions. FAT and NTFS don't support unix permissions natively, so they are simulated during mount with the options umask, dmask, uid, and gid. See "man mount" for details, or search google.

2) Set up sudo to allow you to perform the actions you want. That's what it was made for, to give a user the temporary permission to perform some action as another user, particularly root. Again, see "man sudo" or google it.

stf92 07-19-2010 07:30 AM

Thanks. I think I'll use the first option, because I want to be able to use Edit>Copy/Paste in KDE's file manager. Regards.

brianL 07-19-2010 07:41 AM

Try this:

kdesu konqueror

stf92 07-19-2010 08:05 AM

Thanks. It does not work. Still Konqueror refuses to write root's dirs. Furthermore, when I go to the FAT partition, the window appears empty. Regards.

MTK358 07-19-2010 09:00 AM

Try mounting the partition within the GUI file manager. It should mount it as accessible by you.

stf92 07-19-2010 12:00 PM

@BrianL: I had unmounted the partition and had forgotten to remount it.

I tried David the H.'s solution 1) and it worked. The other solutions have the advantage that the umask and uid are managed by the soft which, sure enough, will be wiser than me. Either way, I have plenty of time to decide in favor of this or the other solution.

@MTK358: I never could mount the partitions from within the GUI, except by opening a terminal within it.

Thanks and regards.

All times are GMT -5. The time now is 09:02 PM.