-   Linux - Newbie (
-   -   kde 3.2 logout/lock screen (

trollman 01-16-2004 10:44 PM

kde 3.2 logout/lock screen
Hello, i recent installed kde3.2 beat on my suse 8.2 system.
As i was editing with kmenu, i managed to remove the logout and lockscreen buttons. Would anyone know how to add these back? I was able to put back the place holders with the original icons, but i dont know the commands for either button, so right now they do nothing when clicked. Thanks for the help


misfit-x 01-17-2004 07:38 AM

In the KDE menu editor, go to the Settings menu and click "Show Hidden Items". Then click on the log out and click on the Re-Add icon at the top (under the menu bar). Same with the lock button. However if you can't see it at all after unhiding, you'd need to make new ones. Here are the command lines:

Log Out:

dcop kdesktop KDesktopIface logout


dcop kdesktop KScreensaverIface lock

Those go in the Command box in the Menu Editor. The Icons you might have to hunt for them, as I'm not sure where they are, exactly. I think it's in the Actions Icons, under "Exit" (for log out) and "Lock" (for lock screen).

Of course, if you left click on the kicker, and go to Add-Applet, you will find the Logout/Lock which can be put in your kicker bar. Both are also accessible by right clicking on your desktop.

trollman 01-17-2004 08:43 AM

hey, thanks. That did the trick :O)

misfit-x 01-17-2004 10:13 AM

Glad to have helped. :)

fortezza 11-14-2004 10:29 PM

I am not finding 'Settings' under the menu editor except for a pull-down menu with that name, but it only has "configure shortcuts" option underneath it. There is a "System Settings" submenu, but even that does not mention "show hidden items". Can you clarify the path to get to the settings you are talking about? Thank You.

fortezza 11-14-2004 10:43 PM

To have options for 'shutdown' and 'restart' added to the KDE logout menu=, follow these instructions-> .

2004-02-06 Fedora Tips 37:
This is a followup to Fedora Tips 1.

If you use kde in fedora, you lose the ability to shutdown/reboot the computer without fist logging out and then shutting down from the gdm displaymanager. To change displaymanagers add the following to /etc/sysconfig/desktop


or simply type

bash# echo 'DESKTOP="KDE"'> /etc/sysconfig/desktop && echo
'DISPLAYMANAGER="KDE"' >> /etc/sysconfig/desktop

- submitted by Jimmy Oliver

And there you have it....

All times are GMT -5. The time now is 06:45 AM.