-   Linux - Newbie (
-   -   kacpid eats cpu, XP and ubuntu dual boot problem (

pratyushrathore 01-21-2008 11:25 AM

kacpid eats cpu, XP and ubuntu dual boot problem
Hi all,
This is a problem which I could not yet find solution for.
Few days ago, I checked my system monitor to find that the process kacpid eats around 40% of my CPU. I googled for its solution but in vain. 2 posts on ubuntuforums and 1 on linux questions, thats it. All ultimately blaming module thermal and suggesting to reinstall(which is a taunting task!, one week to get my ubuntu in its shape as it is now! :) ). I worked out some things myself and have got some sound but weird observations.
I would request the geeks to kindly note down an interesting observation which I tried.

After banging my head with the problem for 2 days, I started the kernel in recovery mode. After that, the kacpid problem was over.
(Hey, it is a must read for those who had posted about kacpid eating 98% cpu and hard disk. Recovery mode does solve the problem, if it is the same in both the cases. :) ). For days, no problems at all. Eth goes fine.
Now I have got dual boot desky with me, and I boot into XP once in a while.
WHEN I SHUTDOWN XP, THE KACPID STARTS EATING CPU AGAIN. I have to got the recovery mode again to free my cpu usage.
I still can't make out much out of it as to why our dear ubuntu will have a problem with XPs shutdown. (I don't know whether the problem is of XP shutdown or ubuntu kacpid or that of grub(sounds weird but I gave it a thought too!). I have been checking this for more than 2 weeks. The story repeats itself every time.
Please help.
Thanks in advance.
Pratyush Rathore.

BASHCuresCancer 01-21-2008 11:44 AM

Try turning off acpid. You can do that via:


System -> Administration -> Services
Or you can edit your /etc/rc[3-5].d/S*acpid symlinks. See /etc/rc3.d/README

pratyushrathore 01-22-2008 01:44 AM

I did try it.
Of no use.
Kacpid still remains there so does kacpid_notify. Sometimes the system hangs and won't shutdown.
Its not controlled by acpi, me thinks. Otherwise it could have atleast been killed by root. It can't be. I changed its priority to very low in order to get my stuff done, but can't kill it.
Thanks for the reply!

dineshdharme 02-22-2008 09:18 AM

a solution to try for the kacpid problem
I also had the same problem as described by pratyushrathore.

Sometime before,I had come across a probem in windows in which windows took long time to boot and it did not detect usb ports.Finally i reconnected all the wires in the comp (like usb hdd led,power and etc...) and after disconneting them. This problem was solved by this.

I tried the same thing for this problem .Disconnected all the internal wires and reconnected them and then kacpid didnot gave any problem .Its working fine but the problem resurfaces if i boot into windows and then try to boot into ubuntu.

manoj_isi 05-29-2008 05:37 AM

a Solution to kacpid
Solution to kacpid which works fine for me :
After booting windows when boot linux kacpid starts, to stop it just cut the power supply to your PC including UPS if any , without shutting down (obviously after saving data) when linux desktop is active. yes i am saying that take the power cord out.

Now switch on the power of ur machine & boot linux, kacpid will not appear.(hopefully)

Remember acpi=off will not work on dual core machines , if you use this only one core will get active.

Happy Linuxing,

pratyushrathore 05-30-2008 03:10 AM

Can you also suggest whats the reason for it?

All times are GMT -5. The time now is 11:50 AM.