-   Linux - Newbie (
-   -   k3b won't burn cd's (

obstinatesod 02-18-2006 05:55 AM

k3b won't burn cd's
Hi,I have SuSE 10 and can not get K3b to burn a cd. I have 2 drives a DVD rom and a CD burner. on starting I get a message saying: Disable automounting and replace /etc/fstab entries with old fashioned ones. I tried a live cd of Linspire and it burned no bother so the hardware is ok. can someone tell me how to go about replacing the /etc/fstab entries and how exactly to add burn privileges. I logged in as root and still could not burn. I have uninstalled the version that came on the Installation cd as set-up was missing and downloaded the latest version. after attempting to burn a cd you can not close the program down it locks up and stays until I restart the PC, It says "writing" or "preparing to write" but does neither. thanks Adrian

linmix 02-18-2006 10:09 AM

Is the temp folder it is set to use big enough?
Maybe it runs out of space and locks up.

bathory 02-18-2006 11:27 AM

I guess you have to stop your autofs daemon from running (i.e. stop automount), so your burner can be used by K3b.

obstinatesod 02-18-2006 02:31 PM

Hi, I checked the system services runlevel and its set to "no" I unchecked the boxes 3,5 in expert mode (not sure if that was right?) tried to burn again but just the same, below is the debug output. how do I check if the temp folder is big enough? the file I tried to burn was only 380k.

K3b Version: 0.12.11

KDE Version: 3.4.2 Level "b"
QT Version: 3.3.4
Kernel: 2.6.13-15.8-default
OPTORITE CD-RW CW4002 100E (/dev/hdc, ) at /media/cdrecorder2 [CD-R; CD-RW; CD-ROM] [CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R]

SAMSUNG DVD-ROM SD-616E F505 (/dev/hdd, ) at /media/dvd [CD-ROM; DVD-ROM] [DVD-ROM; CD-ROM] [None]
Size of filesystem calculated: 376

Used versions
cdrecord: 2.1

/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Warning: not running as root user, fs= option ignored.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version ( '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512

cdrecord command:
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=12 -tao driveropts=burnfree -eject -multi -xa -tsize=376s -

INFO: UTF-8 character encoding detected by locale settings.
Assuming UTF-8 encoded filenames on source filesystem,
use -input-charset to override.

mkisofs command:
/usr/bin/mkisofs -gui -graft-points -volid K3b data project -volset -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-adrian/k3b15wJNb.tmp -rational-rock -hide-list /tmp/kde-adrian/k3b4S8YGb.tmp -joliet -hide-joliet-list /tmp/kde-adrian/k3bcmumHb.tmp -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-adrian/k3bc8v8ga.tmp

jon_flanders 02-25-2006 09:05 PM

Download the source for the latest version of cdrdao and compile it. Make sure your permissions for your burner are enabling a user to burn.

Then use cdrdao with k3b. I use Mandriva 2006 and this worked for me. I can't get cdrecord to work though.

obstinatesod 02-26-2006 03:02 AM

thanks Jon, having tried and failed to get the burner working for weeks I have just replaced suse with pclinuxOS as I need the cd burner, hope it works there. It actually worked ok with a Linspire live cd. will let you know what happens. Adrian

jon_flanders 02-26-2006 03:20 PM

I think the problem is with the kernel, not the distro. Sebastien Trueg pointed me to the new version of cdrdao.

All times are GMT -5. The time now is 03:41 AM.