LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2009, 05:32 AM   #1
V0D
LQ Newbie
 
Registered: Dec 2003
Location: Modena, Italy
Posts: 6

Rep: Reputation: 1
JVM crash on Debian Lenny with Eclipse


Hi!

I was using Eclipse 3.2, when it just crashed. I got the following message:

JVM terminated. Exit code=127
/usr/lib/jvm/java-6-openjdk/bin/java
-Djava.library.path=/usr/lib/jni
-Dgnu.gcj.precompiled.db.path=/var/lib/gcj-4.2/classmap.db
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dosgi.locking=none
-jar /usr/lib/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/lib/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 2e0012
-install /usr/lib/eclipse
-vm /usr/lib/jvm/java-6-openjdk/bin/java
-vmargs
-Djava.library.path=/usr/lib/jni
-Dgnu.gcj.precompiled.db.path=/var/lib/gcj-4.2/classmap.db
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dosgi.locking=none
-jar /usr/lib/eclipse/startup.jar

Also, each time I open Eclipse I get: "This Eclipse build doesn't have support for the integrated browser".

I've tried to launch Eclipse from the shell, and this is the result:

alby@debian:~$ eclipse
searching for compatible vm...
testing /usr/lib/jvm/java-6-openjdk...found
/usr/lib/jvm/java-6-openjdk/bin/java: symbol lookup error: /home/alby/.eclipse/org.eclipse.platform_3.2.0/configuration/org.eclipse.osgi/bundles/107/1/.cp/libswt-mozilla-gtk-3236.so: undefined symbol: _ZN4nsID5ParseEPKc
alby@debian:~$

I've seen other people with my same problem, but I've found no valid solution. This problem forbids me to use Eclipse, but I need that IDE. How can I solve this?

Last edited by V0D; 02-10-2009 at 05:34 AM.
 
Old 02-10-2009, 10:09 PM   #2
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Try;
Code:
apt-get install xulrunner
 
1 members found this post helpful.
Old 02-11-2009, 10:42 AM   #3
V0D
LQ Newbie
 
Registered: Dec 2003
Location: Modena, Italy
Posts: 6

Original Poster
Rep: Reputation: 1
Thanks!

I've resolved by installing a newer version (3.4 Ganymede), downloading it from the Eclipse repository.

The broken version (3.2) is an official Debian package... Have I been unlucky?
 
Old 02-11-2009, 12:18 PM   #4
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
The bugs have been discussed,but I don't know if they've been reported.There are some workarounds on the net,installing xulrunner is one of them.
 
Old 04-28-2010, 11:55 PM   #5
jestinjoy
Member
 
Registered: May 2004
Location: India
Distribution: Ubuntu 9.04, Debian Lenny
Posts: 121

Rep: Reputation: 22
Thumbs up

I also had the same problem. I installed xulrunner and it works fine. Thanks
 
Old 04-29-2010, 04:55 AM   #6
plus2plus
LQ Newbie
 
Registered: Apr 2010
Posts: 8

Rep: Reputation: 0
Smile

Hello! I'm new here, I had the same problem. By follow this topic, try to solve myself and it works fine. Thanks and regards,
 
Old 06-21-2010, 11:20 AM   #7
QvasiModo
LQ Newbie
 
Registered: Jun 2010
Posts: 1

Rep: Reputation: 0
The fix doesn't work for me

Quote:
$ sudo apt-get install xulrunner
[sudo] password for root:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package xulrunner is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package xulrunner has no installation candidate
There is a xulrunner-1.9 package however. I had it installed already, tried reinstalling anyway. Didn't work either.

I'm running Debian Lenny on x86_64.
 
Old 06-23-2010, 10:55 AM   #8
Racius
LQ Newbie
 
Registered: Jun 2010
Posts: 1

Rep: Reputation: Disabled
I have absolutely the same problem as QvasiModo, also the same distribution of linux... Has anybody idea how to fix it?
 
Old 11-21-2010, 09:19 AM   #9
jestinjoy
Member
 
Registered: May 2004
Location: India
Distribution: Ubuntu 9.04, Debian Lenny
Posts: 121

Rep: Reputation: 22
Seems like you didnt gave the name correclty. Use the command
Code:
 apt-cache search xulrunner
to find the exact name of the package. Otherwise your sources list doesnot have repo for this package.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eclipse doesn't run : JVM terminated. Exit code=1 arsham Linux - Software 1 05-07-2007 07:19 PM
JVM error when I run eclipse tareqth Linux - Software 4 07-22-2005 03:53 AM
eclipse JVM terminated. Exit code=1 Falco Linux - Software 2 03-18-2005 05:29 AM
where to install eclipse/jvm/java linux_ub Linux - Newbie 3 09-25-2004 04:30 PM
error running eclipse with stock jvm! c24chan Slackware 2 05-09-2004 04:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration