Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 08-15-2004, 07:32 PM   #1
LQ Newbie
Registered: Aug 2004
Posts: 4

Rep: Reputation: 0
just installed slackware 10 and no kde

hi, i apologise in advance if this has been mentioned so please don't grill me as there are litterally 100,000's of messages here so after trying to search for a while for a possible answer I am resorting to this message.

I have just installed slackware 10 on my system, set lilo up for dual boot and after setting kde as my default environment I rebooted to my new slackware system.

However when I booted I was presented with a console login and after logging in it merely returns me to a commandline prompt instead of the kde environment I was expecting.

I am a newbie and do not know how to start up into kde.

I once tried linux and a friend who has run linux for a number of years showed me that typing in kd? something would bring up the kde environment, i tried that with several letters in place of the "?" and when hitting one it came back with a message that x-server was not running.

please help as I am trying to make the transition from windoze to linux but this has me stumped.

thankyou for your patience

PS that friend now lives 6000 miles away now so it is impractical to ask him what is happening.

Last edited by aelthric; 08-15-2004 at 07:38 PM.
Old 08-15-2004, 07:40 PM   #2
Registered: Aug 2004
Location: Canada
Distribution: SUSE 9.1 Pro and Debian Testing on Server
Posts: 469

Rep: Reputation: 30
Try typing in startx at the prompt....I had the same problem when I briefly tried Slackware and I believe this is the same solution I used. Oh, a little hint, in that situation you could have hit kd<TAB> (as in the tab button) (I think you have to hit tab twice, I just do it without thinking about it so I can't remember right now) and it will show all possible completions

Anyways, as a newbie have you thought about something along the lines of Mandrake/Fedora/SuSE? I personally use Fedora and even my mom and little brother use it too and they don't have a problem (I do all the admin tasks tho). And, most of the admin tasks are done through graphical windows in your main menu, whereas I have heard (could be wrong) that Slackware involves a lot of admin work through the command line.

Anyways, just some advice. If you are the type of person that likes to jump right into the deep end and learn that way, Slackware is probably a good choice for you tho. Anyways, hope I've been of some help.

Last edited by rm6990; 08-15-2004 at 07:41 PM.
Old 08-15-2004, 07:45 PM   #3
LQ Newbie
Registered: Aug 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks rm6990 i will try that when I boot back in...

If I remember right as soon as I am in KDE I can reset the boot options from inside there can't I so that it will boot into KDE from that point on ....

BTW thanks for the headsup on fedora I have had a look at SuSE and Mandrake but never thought to download fedora

Old 08-15-2004, 07:46 PM   #4
LQ Newbie
Registered: Aug 2004
Location: Somewhere Near
Distribution: Slackware-Current, Debian 3.1rc, Gentoo 2005, Mandriva 2006, Ubuntu Fiesty 2007
Posts: 15

Rep: Reputation: 0
Assign your default to KDE

if the startx command didn't reach your KDE . issue this command:

assign your default WM. then issue this command:

Old 08-15-2004, 07:55 PM   #5
LQ Newbie
Registered: Aug 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks Pronco I will jot that down too on my learn how to use linux notepad..

Old 08-16-2004, 03:33 AM   #6
Senior Member
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
and check this site out , it will help you alot setting up slack

"crank up your favorite text editor and open /etc/inittab . Now see that line that says:

# Default runlevel. (Do not set to 0 or 6)

Change it to:

# Default runlevel. (Do not set to 0 or 6)

Now you'll be greeted by your shiney new graphical login manger when you boot up"

Last edited by heema; 08-16-2004 at 03:35 AM.
Old 08-17-2004, 02:33 AM   #7
LQ Newbie
Registered: Aug 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Thankyou heema i will take a look at that ....

Unfortunately the lilo got mangled somewhere along the line and I tried to reinstall slackware back on again, now from the same disks I get errors when installing packages so I think I need to burn some fresh disks.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Installed kde 3392 rpms keyboard dead inside kde, working in shell hansschmucker SUSE / openSUSE 1 02-13-2005 08:01 PM
checking for KDE... configure: error:, no KDE headers installed mythief Mandriva 4 10-23-2004 08:20 AM
checking for KDE... configure: error:, no KDE headers installed mythief Linux - Software 2 10-23-2004 05:20 AM
i just installed kde 3.2.3 on slackware 9.1 and.... artistik Linux - Software 2 06-17-2004 07:20 AM
Installed Slackware, but no KDE? Ice Dragon Slackware 3 08-31-2002 09:05 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:02 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration