LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-26-2016, 09:11 PM   #1
klazarski
LQ Newbie
 
Registered: May 2016
Posts: 1

Rep: Reputation: Disabled
Just installed Linux Mint 17.3 - No audio. Sound Settings says "play sound through HDMI/Display port 2" but no option for speakers


Hi, I'm really new to linux. I just installed mint 17.3 on my PC and everything seems to have gone fine but there is no audio. I've run update manager and looked for new drivers and that hasn't helped. When I open the sound settings, the output only has an option for "HDMI/DisplayPort 2". Thing is, my monitor has no speakers built into it. Additionally, when I plug my headphones in, I don't get any audio there either. Any ideas would be greatly appreciated.

Thanks!
 
Old 05-28-2016, 12:30 PM   #2
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian Stable and Unstable
Posts: 1,943

Rep: Reputation: 541Reputation: 541Reputation: 541Reputation: 541Reputation: 541Reputation: 541
Change the output from HDMI to the headphone jack. You'll probably need to install the pulseaudio volume control. With that you can configure the input and outputs, and set the volume. Or you can buy a passthhrough converter which has analog audio output and allows the video to pass through to the monitor, or you can buy a USB DAC which connects to a USB port and has audio output via RCA jacks, 3.5mm stereo jack, or both. The cheapest is obviously to set the output to the built-in 3.5mm jack, but there are multiple options. If you have built-in speakers, you can set the output to those.

Last edited by sgosnell; 05-28-2016 at 12:37 PM.
 
Old 05-28-2016, 12:35 PM   #3
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Hi & Welcome to Linux Questions.

Congrads on you LM installation.-

The sound might be muted in the alsamixer. Open your terminal and type:
Code:
alsamixer
When you do you'll see multiple columns. Use your arrow keys to go to each column and raise up the master, pcm and etc. At the bottom of each column you should have what looks like this:

Code:
[00] <or> [mm]
If at the bottom of the column you see [mm] that means it's muted.
To un-mute each column just type the 'm'.

When done close the terminal.

Hope that helps.

If you still don't have sound you may want to post what sound card you have so someone can help you with it.
To find out what sound card is on your mobo run this command:
Code:
aplay -l
 
Old 05-28-2016, 12:37 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Here's a video by Frostbite if you have trouble with alsamixer.
https://www.youtube.com/watch?v=wWmXG-e6yzI
 
Old 05-29-2016, 01:43 AM   #5
floppy_stuttgart
Senior Member
 
Registered: Nov 2010
Location: EU mainland
Distribution: Debian like
Posts: 1,055
Blog Entries: 5

Rep: Reputation: 96
see topic and the solution in post #12 of http://www.linuxquestions.org/questi...ve-4175534057/ ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] HDMI - do all video cards support sound through the HDMI port? taylorkh Linux - Hardware 4 01-24-2016 01:35 AM
Sound in Ubuntu 13.10 both outputs HDMI and built in speakers solution. ivtec Ubuntu 1 02-03-2014 06:28 AM
unable to play hdmi sound thru speakers schneidz Linux - Hardware 0 12-20-2010 06:52 PM
No sound for my 2.1 speakers (Linux Mint Gnome) ameyjah Linux - Hardware 1 04-22-2008 11:55 PM
Low sound from speakers/ No sound from headphone jack with Intel ICH8 Family Audio troydclayton Linux - Hardware 2 03-28-2008 10:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration