LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-09-2005, 10:08 PM   #1
Zadatak
LQ Newbie
 
Registered: Apr 2005
Location: Melbourne, Australia
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Just installed debain testing and iv'e got some problems


I'm fairly new to Linux and i've just installed debian testing, but i've got a few problems.
I need to edit my /etc/resolv.conf, so i open it in gedit as root and change it (not sure if this is the correct / easiest way to do it) but after about 5 mins, it will change back to what it was before.

I'm trying to mount my Windows ntfs partition so i use
Code:
mount /dev/hda1 /mnt/win
It works but only root has read permissions. So i used
Code:
chmod o+r win
but it doesn't seem to do anything.

When i try to change my screen resolution the highest it will let me go is 800x600. Is there any way to get it to 1024x768? My graphics card is a ATI Radeon 9200SE so i chose "ati" when the istaller asked what display drivers to use.

Thanks.
 
Old 04-09-2005, 11:00 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Re: Just installed debain testing and iv'e got some problems

Welcome to LQ.org Zadatak!

Quote:
I need to edit my /etc/resolv.conf, so i open it in gedit as root and change it (not sure if this is the correct / easiest way to do it) but after about 5 mins, it will change back to what it was before.
What are you trying to do? /etc/resolv.conf holds your nameservers. If you connect through a DHCP server, it should be overwritten by the DHCP server.

Quote:
I'm trying to mount my Windows ntfs partition so i use
Code:
mount /dev/hda1 /mnt/win
It works but only root has read permissions. So i used
Code:
chmod o+r win
but it doesn't seem to do anything.
You won't be able to do that. Writing to a NTFS partition is, AFAIK, a 2.6.x kernel feature only and with unstable support. Reading, as you already know, is not a problem, but writing to a NTFS may cause some loss of data. If you need to write to a NTFS partition, you will need to re-compile your kernel in order to add NTFS support. The very best way, however, is to create a FAT32 partition so both Linux and Windows can read/write without a hassle.

Quote:
When i try to change my screen resolution the highest it will let me go is 800x600. Is there any way to get it to 1024x768? My graphics card is a ATI Radeon 9200SE so i chose "ati" when the istaller asked what display drivers to use.
You will need to edit your /etc/X11/xorg.conf or /etc/X11/XF86Conf depending if you use xorg or xfree.

Regards!

Last edited by Mega Man X; 04-09-2005 at 11:01 PM.
 
Old 04-10-2005, 12:07 AM   #3
Zadatak
LQ Newbie
 
Registered: Apr 2005
Location: Melbourne, Australia
Distribution: Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
What are you trying to do? /etc/resolv.conf holds your nameservers. If you connect through a DHCP server, it should be overwritten by the DHCP server.
I'm on a LAN where the gateway is a Windows XP box with ICS (don't ask), but the DNS doesn't seem to work properly with it. In Windows under TCP/IP properties i have "Obtain an IP address automaticly" and "Use the following DNS server addresses" and i have the address beneath. Would i have to use a static IP in Linux? If so, how?


Quote:
You won't be able to do that. Writing to a NTFS partition is, AFAIK, a 2.6.x kernel feature only and with unstable support. Reading, as you already know, is not a problem, but writing to a NTFS may cause some loss of data. If you need to write to a NTFS partition, you will need to re-compile your kernel in order to add NTFS support. The very best way, however, is to create a FAT32 partition so both Linux and Windows can read/write without a hassle.

I know Linux can't write to NTFS partitions, the problem is i don't know how to give my normal user read permissions. When i use "chmod o+r win" (that would give others read permission wouldn't it?) it says "chmod:changing permissions of 'win': Read-only file system"


Quote:
You will need to edit your /etc/X11/xorg.conf or /etc/X11/XF86Conf depending if you use xorg or xfree.
It worked, thanks.
 
Old 04-10-2005, 01:19 AM   #4
audibel
Member
 
Registered: Oct 2004
Distribution: Debian Sarge
Posts: 177

Rep: Reputation: 30
Quote:






I know Linux can't write to NTFS partitions, the problem is i don't know how to give my normal user read permissions. When i use "chmod o+r win" (that would give others read permission wouldn't it?) it says "chmod:changing permissions of 'win': Read-only file system"

actually that gives owner read permission... a+r is the flag I think you're looking for...
 
Old 04-10-2005, 01:37 AM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
To modify permissions on an NTFS file system you'll have to change the mount options in /etc/fstab, since AFAIK chmod and friends don't work on NTFS (and they certainly don't work with FAT32 since the filesystem lacks the concept of permissions).

In your /etc/fstab entry for the filesystem add umask=000 to the options the filesystem is mounted with, and then remount. WARNING! This gives all users on your Linux system complete access to the NTFS filesystem. Look into the user and umask options in man mount for more info about this.
 
Old 04-10-2005, 02:07 AM   #6
Zadatak
LQ Newbie
 
Registered: Apr 2005
Location: Melbourne, Australia
Distribution: Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by btmiller
In your /etc/fstab entry for the filesystem add umask=000 to the options the filesystem is mounted with, and then remount. WARNING! This gives all users on your Linux system complete access to the NTFS filesystem. Look into the user and umask options in man mount for more info about this.
Thanks, that worked.

EDIT: I fixed the other problem by changing some stuff in /etc/dhclient.conf. Thanks for your help everyone.

Last edited by Zadatak; 04-10-2005 at 02:49 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed Debain Sarge, Xserver resolution rossjman1 Debian 10 06-18-2005 01:53 AM
installed testing - dev mounts odd jmeads Debian 2 01-02-2005 08:19 AM
Oh no ... network adapter problems in debain net install orange400 Debian 2 06-10-2004 10:04 AM
USR 2210 on Sony laptoprunning Debain testing alaoea Linux - Hardware 0 07-14-2003 03:39 PM
Confirming and testing Nvidia drivers are installed LinuxBAH Linux - General 5 06-30-2003 01:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration