-   Linux - Newbie (
-   -   Java problems with Linux Mint Debian (

nbob 06-07-2011 02:20 PM

Java problems with Linux Mint Debian
Hi. For the past year or so, I have long been living with "buggy" linux and it doesn't matter which distro I choose. The problems crop up when I try to run a java application. Specifically, card games.
The way the game works is that you choose a room to play in. Then a small room window comes up after about 30 sec. Then you choose a table, and wait another 30 sec or so. After that, you're at the table and ready to start the game with your opponents.

After playing it this way 2-3 times, that last window before playing the game will freeze up. After that, I had to close out both game windows and reboot.

I soon discovered, however, that I can get the game to re-load quicker than doing a reboot. If I clear the firefox cache and then reload the room window, I can enter the game without it hanging up.

But this fix only works temporarily; and I've tried increasing my cache size but this didn't help the situation.

Is this a problem with sun-java-6, the linux os, firefox, or pogo?

Is there any way to revert to an earlier version of java or linux or firefox that might fix the problem?
I never had the problem until about a year ago. The problem only occurs in linux, my windows OS (windows 7) has no such issues.

Thanks for the help.

evo2 06-07-2011 07:53 PM

Have you tried using openjdk instead of sun java? All my java problems went away after making the switch.


nbob 06-08-2011 12:00 PM

Hello. How do I enable openJDK? The only firefox plugin I have installed is sun java. I guess I need the openJDK plugin somehow.

evo2 06-08-2011 06:35 PM


Originally Posted by nbob (Post 4380028)
How do I enable openJDK?

You need to install it first.


nbob 06-08-2011 11:41 PM

It's already installed but there's no plugin anywhere to be found.

Here's what synaptic said I have installed now:


evo2 06-08-2011 11:57 PM


$ apt-cache search openjdk browser plugin
icedtea-plugin - web browser plugin based on OpenJDK and IcedTea to execute Java applets
libreoffice - office productivity suite
$ sudo aptitude install icedtea-plugin

Then restart your browser.


nbob 06-09-2011 12:13 AM

Still no luck here. When I try to install I get the following output:
sudo apt-get install icedtea-plugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package icedtea-plugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'icedtea-plugin' has no installation candidate

Also, I was able to add to my sources.list file so that icedtea plugin is now visible in synaptic. But when I try to install from synaptic I get this:

The following packages have unresolvable dependencies. Please make sure that all required repositories are added and enabled in the preferences.
Depends: openjdk-6-jre (=6b18-1.8.7-2~squeeze1) but 6b18-1.8.7-5 is to be installed

thanks for the help.

evo2 06-09-2011 12:19 AM

Ok, sorry I'm working on a real Debian system... seems packages are missing in LMDE. You should probably file a bug report to LMDE.


craigevil 06-09-2011 10:52 AM

icedtea6-plugin isn't in Wheezy/Testing repo it is in sid

nbob 06-09-2011 03:24 PM

Can i somehow add the sid repo to my /etc/apt/sources.list ?

craigevil 06-09-2011 03:42 PM


Originally Posted by nbob (Post 4381254)
Can i somehow add the sid repo to my /etc/apt/sources.list ?

Sure just copy the Testing line and change testing/wheezy to sid, run apt-get update, then you should be able to do apt-get install icedtea6-plugin.

Although the problem sounds more like a cookie issue than a java problem, openjdk and sun/oracle-java work exactly the same.

nbob 12-08-2011 01:36 AM

Found the Culprit
Hello. Thanks for the help.

It seems the various Firefox add-ons were consuming my memory. So I disabled 3 of them and now things are running super. So I guess the lesson is to be careful with installing more than a couple of addons. I had about 5: LastPass, AdBlock Plus, StumbleUpon, TabUtilities Lite, and XMarks. I have now disabled all of them except for LastPass and XMarks, and no more pogo crashes!

All times are GMT -5. The time now is 06:46 PM.