LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Java plugin on Mozilla 1.5 (https://www.linuxquestions.org/questions/linux-newbie-8/java-plugin-on-mozilla-1-5-a-113824/)

mrmojo 11-08-2003 01:52 PM

Java plugin on Mozilla 1.5
 
I have installed the java plugin on Mozilla 1.5, 've made the symbolic link in plugins directory to libjavaplugin_oji.so and it seems to give me no problem when i start mozilla, but when i engage a web site with some java applet it shows me the message that tells me to download java plugin, as i didn't have it.
What could be the motivaytion?
THANKS A LOT

Blinker_Fluid 11-08-2003 04:53 PM

Not positive on this...
I think it is because of the gcc it was compiled with...
The file I am using is j2re-1.4.1-01-linux-i586-gcc3.2.bin
Link to download it:
http://ftp.linux.org.uk/pub/linux/ja...586-gcc3.2.bin

mrmojo 11-08-2003 06:06 PM

Nothing to do
 
I have tried to use that version of java plugin too, but nothing to do.

To load plugin i create a symbolic link to libjavaplugin_jni.so in mozilla plugin directory as written on installation guide, but applet doesn't work. When i make an hard link or i copy that file it gives me this message:

LoadPlugin: failed to initialize shared library /home/mrmojo/sof/mozilla/plugins/libjava.so [libjvm.so: cannot open shared object file: No such file or directory]

I FIND LINUX VERY HARD TO USE BUT I KNOW THAT THE FOULT IS JUST OF THAT SLAYER CALLED WINDOW


HAPPY TO BECOME A PENGUIN

lhm0155 11-12-2003 03:54 PM

1.4.2 must be used due to gcc 3.2
 
sorry guys but in order to run java with mozilla 1.5, because it uses the gcc3.2 compiler, you must use 1.4.2

mrmojo 11-12-2003 05:28 PM

Absolutely nothing
 
1.4.2 and nothing to do, i believe that i've made some foolish during installation of mozilla or during installation of java plugins and now i'm out, it doesn't matter, i am learning a lot of things and i am happy of this......

lhm0155 11-12-2003 07:08 PM

ok which one did you link too??
 
the one that i use is the libjavaplugin in the ns610-gcc32 directory and it works great, also in your preferences under advanced is java enabled?? just checking

megaspaz 11-12-2003 07:15 PM

check which version of mozilla you're actually using. i've seen this so many times with people opening mozilla using the mozilla command thinking that when they installed moz 1.5 that it opens using the same command. moz 1.5 defaults to install in /usr/local/mozilla/ and to run it you need to run the command /usr/local/mozilla/mozilla. my bet is that you've installed mozilla 1.5 but when you run mozilla, you're still using an older version of mozilla. also make a symbolic link into /usr/local/mozilla/plugins and not into your $HOME/.mozilla/plugins.

Partisan 11-22-2003 05:02 PM

Java plug-in problem in mozilla 1.5
 
May be I had the similar problem :p
After installation of j2sdk1.4.2 and creating all the necessary links in "~/.mozilla/plugins" Mozilla actually doesn't show that it has java-plugin.
In my case the problem was that mozilla could not find a file "libgcc_s.so.1".
Fortunately this library was already somewhere in my system (use "locate libgcc_s.so" to find in yours).
Solution was simple - I just put this file into a folder where mozilla was installed (in my case it is "/opt/mozilla/". There are also files "run-mozilla.sh" etc.). After that I went in menu "Help->About Plug-ins" and enjoyed the view :) Java plug-ins are found :D and usable.

Hope that my solution will help anybody. :p

mrmojo 11-22-2003 05:58 PM

thanks
 
thanks a lot i don't know if it works becouse i've installed slackware 9.1, but thanks anyway in the name of community

Owen LaGarde 12-22-2003 02:56 PM

Java-no-workee, oy vey
 
Running Mozilla 1.5 and J2RE 1.4.2_03-b02 on a RedHat 2.4.20-24.8smp kernel. After the JRE install I had to "chmod -R og+rX <mozilla root>/lib <mozilla root>/plugins" to allow all users access (root umask of 037). Once that was done, the plugin appeared in the "About Plugins" page for all users. Problem is the plugin doesn't work uniformly even for root. High level functions such as openwindow (look at www.mbna.com at the "GO" button for services logins) work for root only; no action and no logs are evident for this action with all non-root users. Functions requiring lower level library calls don't work at all (j2re clock demo from Sun, specific to the J2RE 1.4.2 release), even for root (Mozilla states that the plugin is required. I've verified that the release tag in the java applet(s) do match the installed JRE, and that userland mozilla configuration and java plugin associations are identical between root and at least one non-root test user. Anybody have an idea what else I should check?

Owen LaGarde 12-22-2003 03:27 PM

Re: Java-no-workee, oy vey
 
Got a solution for part of the problem. Hypothetically (not that I would be so bone-headed as to forget about this, nosireebob) it *might* (see previous comment) have been ... cache. Clear it and restart mozilla, and java tests (two follow) start working:

http://www.java.com/en/download/help/testvm.jsp
http://www.clan.lib.ri.us/clan/old_javatest.html

Also good to see is that hostile applets are blocked correctly by local security policy with the new (1.4.1+) JRE:

http://www.cigital.com/hostile-apple...ickpocket.html

There are still failures -- jumpMenu(), for example, only works as root -- but that's a different problem.

Owen LaGarde 12-22-2003 04:06 PM

Re: Java-no-workee
 
The last part of the puzzle appears to have been this entry:

/usr/java/j2re1.4.2_03/plugin/i386/ns610-gcc32/libjavaplugin_oji.so:$

present in /root/.mozilla/pluginreg.dat but missing from all other accounts. Oddly enough, the other 31 entries associated with java and the JRE in /root/.mozilla/pluginreg.dat didn't seem to have an effect on high-level java functions such as jumpMenu() and the like (the sort of things you expect to find in HTML host-side redirects). I didn't see any java associations in root's pluginreg.dat that shouldn't be global, so I just added all of them to all user account pluginreg.dat files. Works fine now.

All of you that sent emails on this, thanks! Cleaned the problem up very nicely.

onionlee 03-22-2004 01:47 AM

got it to work!!!!!
 
ok, i have mozilla and jdk 1.4.2. both have to be installed. i did it in the gui(gnome), to make it simple. ok. theres jre inside the install of jdk. its in a folder labeled jre. there, there is a folder called plugins. i forgot what it was called and im too lazy too open another browser, but theres 3 folders. theres one that ends on gcc32, open that. theres a .so there. right click it and select make link to. then open a new browser, and go into your netscape folder. go then into plugins folder. move the link of the java .so(this is not the name of the plugin), to the plugin folder of netscape. take off the link to in the name of the plugin. there you go.

if ur confused, just tryit, and ull figure it out.:D


All times are GMT -5. The time now is 06:52 AM.