LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-27-2004, 09:03 PM   #1
ikiceman
LQ Newbie
 
Registered: Nov 2003
Posts: 3

Rep: Reputation: 0
Question Japanese Text in Red Hat 9?


Hi,

I'm running Red Hat Linux 9 (2.4.20-8). When I installed linux i made sure to install Japanese language support. From the systems settings menu I can click on languages and select Japanese. This runs Linux with Japanese fonts in program tool bars and icons. However, I am still unable to type in Japanese. Is there any way that I can type japanese text (hiragana, katakana and kanji) in the text editor or programs like Open Office?
 
Old 01-28-2004, 04:33 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
There's several softwares that you can use to input Japanese, for gtk apps(gedit, gnome-terminal, gaim xchat etc) try im-ja http://im-ja.sourceforge.net/
For others(such as Open Office) try kinput2
you'll need to either have Canna or FreeWnn running, at least one of them should be loaded on boot if you chose to install Japanese support, if not you can start them by
Code:
/sbin/service canna start
/sbin/service FreeWnn start
You only need one of them, for the purpose of this example i'll use canna.
In order to use im-ja install the RPM whch you can find on the website mentioned above, then run 'im-ja-conf', set the Conversion Engine to Canna, restart your gtk app, then right click, select Input Methods then Japanese. Press F6 and you should be able to start entering Japanese, provided that you are using a proper font under a proper locale setting, which you should if you've selected the language setting in the login screen.

As for kinput2 it should come with Redhat, and might even already be installed (rpm -qa | grep kinput2) if not you should be able to find the RPM in one of the CDs.
In order to use it open up a terminal, type "kinput2 -canna&", open up openoffice and you should be able to use it by pressing "ctrl + o", again provided that you are using a right font and encoding.
One problem with kinput2 is that although it should work in most X apps, the default key combination "ctrl + o" is also used in many gtk apps for open file dialogue, but check the man page for more details on its configuration.

Last edited by Demonbane; 01-28-2004 at 10:34 PM.
 
Old 01-28-2004, 01:47 PM   #3
ikiceman
LQ Newbie
 
Registered: Nov 2003
Posts: 3

Original Poster
Rep: Reputation: 0
wow, thanks for the quick respone. i already had kinput2 installed. when i run kinput2 -canna& with japanese as the language setting, i am able to type in japanese in open office. but there is a problem, even though i'm able to type in japanese, i don't have the right font. the basic fonts for asian documents is set as HG Mincho Light J, which is absent from my list of fonts.
 
Old 01-28-2004, 10:58 PM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
You should be able to add your fonts using
/usr/lib/openoffice/program/spadmin

In case you need it you can find more free Japanese fonts on this website:
http://wiki.fdiary.net/font/

Try mikachan font if you havent already :-) it's under FreeButNotFree section on the page above.
 
Old 01-28-2004, 11:32 PM   #5
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
Hi,

Maybe you'd like to take a look at this too:

http://www.linuxquestions.org/questi...hreadid=109189

You may also want to import windows truetype fonts from windows/fonts folder then use this "/usr/lib/openoffice/program/spadmin" thing to add the fonts.

If you've installed japanese fonts support in redhat, I think you can find the truetype japanese fonts somewhere in /usr/share directories (I forgot where exactly). Just keep exploring
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat - Text to Speach Converter - Command Line Tool cgtueno Linux - Software 5 08-19-2008 08:18 AM
What is the default text base web browser installed with Red Hat 9 Philter Linux - Newbie 9 11-25-2004 09:27 PM
[Red Hat] installing X in text mode!??!?! djkoe Linux - Software 1 06-24-2004 01:06 AM
Red Hat 9.0 Boot Text Problem cyclump Linux - Newbie 2 05-14-2003 09:40 AM
pico text editor missing from Red Hat 8.0 Distro? abell Linux - Distributions 2 11-08-2002 12:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration