Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-29-2007, 05:04 PM   #1
Registered: Jan 2007
Distribution: Debian Etch
Posts: 193

Rep: Reputation: 30
Issues with libxml2 (cant install php due to this)

My system has Libxml2 on it. It's needed to install PHP5.

Configuring extensions
checking whether to enable LIBXML support... yes
checking libxml2 install dir... no
checking for xml2-config path...
configure: error: xml2-config not found. Please check your libxml2 installation.
I know I have libxml2 installed... so-

[root@localhost php-5.2.2]# rpm -e libxml2
error: Failed dependencies: is needed by (installed) libbonobo-2.16.0-1.fc6.i386 is needed by (installed) libsoup-2.2.96-4.fc6.i386 is needed by (installed) libxslt-1.1.17-1.1.i386 is needed by (installed) shared-mime-info-0.19-1.i386 is needed by (installed) libcroco-0.6.1-2.1.i386 is needed by (installed) GConf2-2.14.0-2.1.i386 is needed by (installed) libglade2-2.6.0-2.i386 is needed by (installed) libgnomecanvas-2.14.0-4.1.i386 is needed by (installed) bluez-pin-0.30-5.i386 is needed by (installed) gtk-sharp2-2.10.0-3.fc6.i386 is needed by (installed) yum-metadata-parser-1.0-8.fc6.i386 is needed by (installed) pygtk2-libglade-2.10.1-4.fc6.i386 is needed by (installed) usermode-gtk-1.87-3.i386 is needed by (installed) foomatic-3.0.2-38.i386 is needed by (installed) scrollkeeper-0.3.14-8.fc6.i386 is needed by (installed) autofs-5.0.1-0.rc2.10.i386 is needed by (installed) gnome-vfs2-2.16.0-4.fc6.i386 is needed by (installed) libbonoboui-2.16.0-1.fc6.i386 is needed by (installed) libgnomeui-2.16.0-4.fc6.i386 is needed by (installed) gnome-python2-2.16.0-1.fc6.i386 is needed by (installed) evolution-data-server-1.8.0-11.fc6.i386 is needed by (installed) libgnomeprint22-2.12.1-8.i386 is needed by (installed) libgnomeprintui22-2.12.1-6.i386 is needed by (installed) gnome-desktop-2.16.0-1.fc6.i386 is needed by (installed) gnome-panel-2.16.0-4.fc6.i386 is needed by (installed) gnome-sharp-2.16.0-1.fc6.i386 is needed by (installed) gnome-mount-0.5-2.fc6.i386 is needed by (installed) libgsf-1.14.1-6.i386 is needed by (installed) librsvg2-2.16.0-2.fc6.i386 is needed by (installed) eel2-2.16.0-1.fc6.i386 is needed by (installed) nautilus-cd-burner-2.16.0-3.fc6.i386 is needed by (installed) gsf-sharp-0.8.1-2.fc6.i386 is needed by (installed) gnome-pilot-2.0.13-16.i386 is needed by (installed) gtkhtml3-3.12.0-1.fc6.i386 is needed by (installed) firefox- is needed by (installed) gnome-bluetooth-libs-0.7.0-10.1.i386 is needed by (installed) gnome-spell-1.0.7-3.1.i386 is needed by (installed) evolution-2.8.0-7.fc6.i386 is needed by (installed) gnome-bluetooth-0.7.0-10.1.i386 is needed by (installed) gnome-python2-libegg-2.14.2-4.fc6.i386 is needed by (installed) evince-0.6.0-3.fc6.i386 is needed by (installed) gthumb-2.7.8-3.fc6.i386 is needed by (installed) file-roller-2.16.0-2.fc6.i386 is needed by (installed) ekiga-2.0.2-7.i386 is needed by (installed) gnome-python2-bonobo-2.16.0-1.fc6.i386 is needed by (installed) gucharmap-1.8.0-1.fc6.i386 is needed by (installed) gstreamer-plugins-base-0.10.9-4.i386 is needed by (installed) gstreamer-0.10.9-2.i386 is needed by (installed) gstreamer-plugins-good-0.10.4-1.fc6.i386 is needed by (installed) gnome-media-2.16.1-2.fc6.i386 is needed by (installed) libxklavier-3.0-1.fc6.i386 is needed by (installed) libbeagle-0.2.10-3.fc6.i386 is needed by (installed) php-cli-5.1.6-3.i386 is needed by (installed) zenity-2.16.0-1.fc6.i386 is needed by (installed) gtksourceview-1.8.0-1.fc6.i386 is needed by (installed) nautilus-sendto-0.7-5.fc6.i386 is needed by (installed) gnome-netstatus-2.12.0-5.1.i386 is needed by (installed) libgail-gnome-1.1.3-1.2.1.i386 is needed by (installed) evolution-sharp-0.11.1-10.fc6.i386 is needed by (installed) gcalctool-5.8.24-2.fc6.i386 is needed by (installed) gnome-utils-2.16.0-1.fc6.i386 is needed by (installed) gdm-2.16.0-10.fc6.i386 is needed by (installed) yelp-2.16.0-4.fc6.i386 is needed by (installed) tomboy-0.4.1-1.fc6.i386 is needed by (installed) eog- is needed by (installed) NetworkManager-gnome-0.6.4-5.fc6.i386 is needed by (installed) evolution-webcal-2.7.1-6.i386 is needed by (installed) gaim-2.0.0-0.15.beta3.fc6.i386 is needed by (installed) gnome-terminal-2.16.0-2.fc6.i386 is needed by (installed) vino-2.13.5-4.1.i386 is needed by (installed) gnome-power-manager-2.16.0-3.fc6.i386 is needed by (installed) gnome-system-monitor-2.16.0-1.fc6.i386 is needed by (installed) gok-1.2.0-1.fc6.i386 is needed by (installed) im-chooser-0.3.3-2.fc6.i386 is needed by (installed) gnome-screensaver-2.16.0-7.fc6.i386 is needed by (installed) krb5-auth-dialog-0.7-1.i386 is needed by (installed) control-center-2.16.0-9.fc6.i386 is needed by (installed) gnome-python2-applet-2.16.0-1.fc6.i386 is needed by (installed) gnome-python2-gnomeprint-2.16.0-1.fc6.i386 is needed by (installed) gnome-python2-gtksourceview-2.16.0-1.fc6.i386 is needed by (installed) gnome-volume-manager-2.15.0-2.fc6.i386 is needed by (installed) gnome-session-2.16.0-3.fc6.i386 is needed by (installed) gnome-applets- is needed by (installed) gedit-2.15.9-1.fc6.i386 is needed by (installed) compiz-0.0.13-0.32.20060817git.fc6.i386 is needed by (installed) desktop-printing-0.19-21.fc6.i386 is needed by (installed) kdelibs-3.5.6-0.3.fc6.i386 is needed by (installed) kdenetwork-3.5.6-0.1.fc6.i386 is needed by (installed) libwmf- is needed by (installed) ImageMagick- is needed by (installed) q-7.6-1.fc6.i386 is needed by (installed) libxml2-python-2.6.28-1.fc6.i386
libxml2 is needed by (installed) libsoup-2.2.96-4.fc6.i386
libxml2 >= 2.6.25 is needed by (installed) libxslt-1.1.17-1.1.i386
libxml2 is needed by (installed) shared-mime-info-0.19-1.i386
libxml2 >= 2.4.23 is needed by (installed) libcroco-0.6.1-2.1.i386
libxml2 >= 2.4.12-0.7 is needed by (installed) libglade2-2.6.0-2.i386
libxml2 >= 2.4.8 is needed by (installed) docbook-dtds-1.0-30.1.noarch
libxml2 >= 2.4.19 is needed by (installed) scrollkeeper-0.3.14-8.fc6.i386
libxml2 >= 2.5 is needed by (installed) libgnome-2.16.0-4.fc6.i386
libxml2 >= 2.5 is needed by (installed) libbonoboui-2.16.0-1.fc6.i386
libxml2 >= 2.5 is needed by (installed) libgnomeui-2.16.0-4.fc6.i386
libxml2 >= 2.4.12 is needed by (installed) librsvg2-2.16.0-2.fc6.i386
libxml2 >= 2.4.20 is needed by (installed) eel2-2.16.0-1.fc6.i386
libxml2 >= 2.6.12 is needed by (installed) gnome-doc-utils-0.8.0-2.fc6.noarch
libxml2 >= 0:2.4.21 is needed by (installed) gdm-2.16.0-10.fc6.i386
libxml2 >= 2.6.5 is needed by (installed) yelp-2.16.0-4.fc6.i386
libxml2 >= 2.6.0 is needed by (installed) gnome-screensaver-2.16.0-7.fc6.i386
libxml2 >= 2.6.5 is needed by (installed) kdebase-3.5.6-0.1.fc6.i386
libxml2 >= 2.6.8 is needed by (installed) libwmf-
libxml2 = 2.6.28 is needed by (installed) libxml2-python-2.6.28-1.fc6.i386
So I ran yum update libxml2 and got:

[root@localhost php-5.2.2]# yum update libxml2
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Could not find update match for libxml2
No Packages marked for Update/Obsoletion
How do I fix this? I need PHP5.
Old 05-30-2007, 07:54 AM   #2
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
You need to install the libxml2-devel rpm package with the same version as the one already on your machine.
Old 06-05-2007, 04:11 PM   #3
Registered: Jun 2002
Location: London
Distribution: Slackware
Posts: 201

Rep: Reputation: 30
easy fix for this

Originally Posted by berbae
You need to install the libxml2-devel rpm package with the same version as the one already on your machine.
Just to chip in here, I had this same problem and fiddled around for a while trying to get it sorted. Most php install docs don't mention that you need to sort out this libxml dependency before proceeding with the php installation. I sorted the process the other day into a simple doc: PHP and libxml installation, so hopefully that will save people some time..



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP 5 cannot find xml2-config for libxml2 support ridertech Linux - Software 21 02-08-2013 09:00 PM
Kernel Deleted due to Upgrade, Cannot Reinstall Kernel due to Dependency Issues Kenji Miyamoto Debian 2 02-17-2007 09:44 AM
libxml2 double install PB0711 SUSE / openSUSE 2 01-15-2007 01:06 PM
PHP libxml2 error viperkt400 Linux - Software 1 03-02-2005 02:06 PM
php configuration erro libxml2 version 2.5.10 or higher required raninix Linux - Newbie 2 10-28-2004 10:59 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:55 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration