LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2010, 12:09 PM   #1
csukid86
LQ Newbie
 
Registered: Feb 2010
Posts: 5

Rep: Reputation: 0
Issues with Knoppix on Thinkpad


ok so ill try to keep this simple even though I myself am confused as to whats going on. I just did a full install of knoppix adriane (on an old IBM thinkpad) and everything seems to have went smoothly... however, when i went to boot it up this morning it said ERROR: Driver 'pata_platform is already registered, aborting...

Im confused by this and i was hoping there might be a way to get around it? ?? I have tried several times to rerun setup and still the same error comes up. If you have an answer please walk me through step by step cause im very new to this...

thanks,

Michael

Last edited by pixellany; 02-01-2010 at 04:32 PM.
 
Old 02-01-2010, 04:33 PM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Welcome---I edited your title to be more descriptive...
 
Old 02-01-2010, 09:56 PM   #3
jefro
Moderator
 
Registered: Mar 2008
Posts: 17,195

Rep: Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562
My guess would be dma. Try to boot with option to disable dma.

See http://www.linuxquestions.org/questi...le-it.-734489/
 
Old 02-02-2010, 01:07 AM   #4
csukid86
LQ Newbie
 
Registered: Feb 2010
Posts: 5

Original Poster
Rep: Reputation: 0
still confused though

i saw that post... but im confused on how to even write script in linux -

again thanks for your help
 
Old 02-02-2010, 01:49 AM   #5
mesiol
Member
 
Registered: Nov 2008
Location: Lower Saxony, Germany
Distribution: CentOS, RHEL, Solaris 10, AIX, HP-UX
Posts: 731

Rep: Reputation: 137Reputation: 137
Hi,

you do not need any script. On boot prompt add ide=nodma as parameter to disable DMA.
 
Old 02-02-2010, 02:04 AM   #6
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
http://www.linuxquestions.org/questi...le-it.-734489/

Hi csukid86,

since you asked in the other thread (linked here above) how to provide a reference link to that thread, in your NEW thread (this one right here), I have provided the link for you.

Basically, if you want to reference another thread (like an old one that may shed light on your current problem) just copy the browser URL of the thread, and paste it in like I did here.

Cheers!
Sasha
 
Old 02-02-2010, 06:18 AM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,657
Blog Entries: 56

Rep: Reputation: Disabled
I remember reading ages ago that it wasn't recommended to install Knoppix to a hard drive.
 
Old 02-02-2010, 04:21 PM   #8
jefro
Moderator
 
Registered: Mar 2008
Posts: 17,195

Rep: Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562Reputation: 2562
It is not exactly newbie to install Knoppix to a disk but many do and there are pages on how to.

I should have been more clear on how to boot with options.


Search for knoppix cheat codes. Should be on disk and on web. The list displays syntax for all boot time command options.
 
Old 02-03-2010, 12:37 AM   #9
csukid86
LQ Newbie
 
Registered: Feb 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by mesiol View Post
Hi,

you do not need any script. On boot prompt add ide=nodma as parameter to disable DMA.
what do you mean on boot prompt? and how do i go about adding that as a parameter??
 
Old 02-03-2010, 08:09 AM   #10
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Depends which bootloader you are using, I'll assume GRUB or LILO (and not GRUB2, just regular grub)

Step one: turn on the computer and wait till your boot menu appears.
Now, do one of:

LILO: When at the lilo boot menu, highlight your kernel that you plan to boot; press TAB; on the "boot line", add the parameter to the end of the line, and hit ENTER.

GRUB: Someone correct me where I'm wrong here, since I don't use GRUB; as far as I recall, you press "E" after highlighting the kernel you want to boot (instead of TAB) and add the parameter to the boot line. Now, I'm not sure if it's just "Press ENTER" or if you have to do something else in here. Need a GRUB user to clarify this for you.

Sasha
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration