LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Issues when installing Wine... (https://www.linuxquestions.org/questions/linux-newbie-8/issues-when-installing-wine-573462/)

uneasyrider 07-30-2007 03:09 PM

Issues when installing Wine...
 
I'm trying to get wine installed on my VPS box through SSH. Getting the following error message...

Please scroll down to the bottom and view the issues with Missing Dependencies. What am I missing here??

Running CentOS 4
Code:

[root@xxxxxxxx ~]# yum -y install wine
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package wine.i386 0:0.9.41-1.el5 set to be updated
--> Running transaction check
--> Processing Dependency: wine-twain = 0.9.41-1.el5 for package: wine
--> Processing Dependency: wine-ldap = 0.9.41-1.el5 for package: wine
--> Processing Dependency: wine-capi = 0.9.41-1.el5 for package: wine
--> Processing Dependency: wine-nas = 0.9.41-1.el5 for package: wine
--> Processing Dependency: wine-esd = 0.9.41-1.el5 for package: wine
--> Processing Dependency: wine-tools = 0.9.41-1.el5 for package: wine
--> Processing Dependency: wine-core = 0.9.41-1.el5 for package: wine
--> Processing Dependency: wine-cms = 0.9.41-1.el5 for package: wine
--> Processing Dependency: wine-jack = 0.9.41-1.el5 for package: wine
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package wine-esd.i386 0:0.9.41-1.el5 set to be updated
---> Package wine-ldap.i386 0:0.9.41-1.el5 set to be updated
---> Package wine-twain.i386 0:0.9.41-1.el5 set to be updated
---> Package wine-jack.i386 0:0.9.41-1.el5 set to be updated
---> Package wine-tools.i386 0:0.9.41-1.el5 set to be updated
---> Package wine-capi.i386 0:0.9.41-1.el5 set to be updated
---> Package wine-nas.i386 0:0.9.41-1.el5 set to be updated
---> Package wine-core.i386 0:0.9.41-1.el5 set to be updated
---> Package wine-cms.i386 0:0.9.41-1.el5 set to be updated
--> Running transaction check
--> Processing Dependency: liblber-2.3.so.0 for package: wine-ldap
--> Processing Dependency: rtld(GNU_HASH) for package: wine-nas
--> Processing Dependency: rtld(GNU_HASH) for package: wine-cms
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: wine-core
--> Processing Dependency: rtld(GNU_HASH) for package: wine-twain
--> Processing Dependency: /usr/bin/xmessage for package: wine-core
--> Processing Dependency: rtld(GNU_HASH) for package: wine-tools
--> Processing Dependency: rtld(GNU_HASH) for package: wine-esd
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-twain
--> Processing Dependency: libgphoto2_port.so.0 for package: wine-core
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-core
--> Processing Dependency: rtld(GNU_HASH) for package: wine-jack
--> Processing Dependency: libesd.so.0 for package: wine-esd
--> Processing Dependency: libldap_r-2.3.so.0 for package: wine-ldap
--> Processing Dependency: libasound.so.2 for package: wine-core
--> Processing Dependency: desktop-file-utils >= 0.8 for package: wine-core
--> Processing Dependency: rtld(GNU_HASH) for package: wine-core
--> Processing Dependency: liblcms.so.1 for package: wine-cms
--> Processing Dependency: rtld(GNU_HASH) for package: wine-capi
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-cms
--> Processing Dependency: libaudiofile.so.0 for package: wine-esd
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-tools
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-ldap
--> Processing Dependency: rtld(GNU_HASH) for package: wine-ldap
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-capi
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: wine-core
--> Processing Dependency: libgphoto2.so.2 for package: wine-core
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package audiofile.i386 1:0.2.6-1.el4.1 set to be updated
---> Package desktop-file-utils.i386 0:0.9-3.el4 set to be updated
---> Package esound.i386 1:0.2.35-2 set to be updated
---> Package alsa-lib.i386 0:1.0.6-5.RHEL4 set to be updated
---> Package gphoto2.i386 0:2.1.4-7 set to be updated
--> Running transaction check
--> Processing Dependency: libusb-0.1.so.4 for package: gphoto2
--> Processing Dependency: liblber-2.3.so.0 for package: wine-ldap
--> Processing Dependency: libexif.so.9 for package: gphoto2
--> Processing Dependency: rtld(GNU_HASH) for package: wine-cms
--> Processing Dependency: rtld(GNU_HASH) for package: wine-twain
--> Processing Dependency: /usr/bin/xmessage for package: wine-core
--> Processing Dependency: rtld(GNU_HASH) for package: wine-nas
--> Processing Dependency: rtld(GNU_HASH) for package: wine-tools
--> Processing Dependency: rtld(GNU_HASH) for package: wine-esd
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-twain
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-core
--> Processing Dependency: rtld(GNU_HASH) for package: wine-jack
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-tools
--> Processing Dependency: libldap_r-2.3.so.0 for package: wine-ldap
--> Processing Dependency: lockdev for package: gphoto2
--> Processing Dependency: rtld(GNU_HASH) for package: wine-core
--> Processing Dependency: liblcms.so.1 for package: wine-cms
--> Processing Dependency: rtld(GNU_HASH) for package: wine-capi
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-cms
--> Processing Dependency: rtld(GNU_HASH) for package: wine-ldap
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-capi
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-ldap
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package lockdev.i386 0:1.0.1-6.2 set to be updated
---> Package libexif.i386 0:0.5.12-5.1.0.2 set to be updated
---> Package libusb.i386 0:0.1.8-3 set to be updated
--> Running transaction check
--> Processing Dependency: rtld(GNU_HASH) for package: wine-capi
--> Processing Dependency: libldap_r-2.3.so.0 for package: wine-ldap
--> Processing Dependency: liblber-2.3.so.0 for package: wine-ldap
--> Processing Dependency: rtld(GNU_HASH) for package: wine-tools
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-core
--> Processing Dependency: rtld(GNU_HASH) for package: wine-ldap
--> Processing Dependency: rtld(GNU_HASH) for package: wine-cms
--> Processing Dependency: rtld(GNU_HASH) for package: wine-esd
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-capi
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-twain
--> Processing Dependency: liblcms.so.1 for package: wine-cms
--> Processing Dependency: rtld(GNU_HASH) for package: wine-twain
--> Processing Dependency: rtld(GNU_HASH) for package: wine-jack
--> Processing Dependency: rtld(GNU_HASH) for package: wine-core
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-cms
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-tools
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: wine-ldap
--> Processing Dependency: /usr/bin/xmessage for package: wine-core
--> Processing Dependency: rtld(GNU_HASH) for package: wine-nas
--> Finished Dependency Resolution
Error: Missing Dependency: liblber-2.3.so.0 is needed by package wine-ldap
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-nas
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-cms
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-twain
Error: Missing Dependency: /usr/bin/xmessage is needed by package wine-core
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-tools
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-esd
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package wine-twain
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package wine-core
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-jack
Error: Missing Dependency: libldap_r-2.3.so.0 is needed by package wine-ldap
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-core
Error: Missing Dependency: liblcms.so.1 is needed by package wine-cms
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-capi
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package wine-cms
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package wine-tools
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package wine-ldap
Error: Missing Dependency: rtld(GNU_HASH) is needed by package wine-ldap
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package wine-capi


dracolich 07-30-2007 03:14 PM

You might want to try downloading and building the source tar.gz file from winehq.org. It's often easier than tracking down a bunch of dependencies.


All times are GMT -5. The time now is 09:36 AM.