LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-06-2011, 09:53 AM   #1
metalfiiish
LQ Newbie
 
Registered: Jul 2008
Posts: 13

Rep: Reputation: 0
Issue adding printer to Debian


Hello all! I was hoping to get some help with a problem I am having. I just recently tried Debian. I am having issue's with setting up a printer on it and after looking for days on information and trying what I found I have yet to get this working.

What I want is to get my PIXMA Mx310 canon printer working on linux. Then share it on my network for my windows boxes. I am running the newest version of debian and only command-line, which has been really hard to use with the http://localhost:631/ to setup the printer.
 
Old 10-06-2011, 11:30 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
The first thing: do you have cups installed? If you do then just point your browser at this url: http://localhost:631/. Check out the documentation about Cups. If you have no gui installed then you'd need something like lynx. Type in your terminal:
Code:
lynx http://localhost:631
You may have to use sudo or run the command as root. First worry about setting up the printer on your machine and then deal with networking it next. I guess you'll need Samba to do that but I have zero experience with windows.
ciao,
jdk

Last edited by jdkaye; 10-06-2011 at 11:32 AM.
 
Old 10-06-2011, 09:40 PM   #3
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 12,781
Blog Entries: 17

Rep: Reputation: 3313Reputation: 3313Reputation: 3313Reputation: 3313Reputation: 3313Reputation: 3313Reputation: 3313Reputation: 3313Reputation: 3313Reputation: 3313Reputation: 3313
OpenPrinting dot org is still down, but this might help:

http://mp610.blogspot.com/

Edit: If CUPS has trouble printing to the Canon, that is. I gather from what I've read here that Canons can sometimes be uncooperative with Linux.

Last edited by frankbell; 10-06-2011 at 09:57 PM.
 
Old 10-06-2011, 09:49 PM   #4
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 4,706

Rep: Reputation: 741Reputation: 741Reputation: 741Reputation: 741Reputation: 741Reputation: 741Reputation: 741
Because you only have command line on that box, make it easier for yourself to see what you do.

On the server box, open /etc/cups/cupsd.conf as root and check these lines, change so they become this:

Code:
<Location />
  # Allow shared printing and remote administration...
  Order allow,deny
  Allow @LOCAL
</Location>
<Location /admin>
  # Allow remote administration...
  Order allow,deny
  Allow @LOCAL
</Location>
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  # Allow remote access to the configuration files...
  Order allow,deny
  Allow @LOCAL
</Location>
Restart cups: sudo /etc/init.d/cups restart

Now at least you should be able to access you server with a web browser not on the server itself: http://name.your.server:631

jlinkels
 
Old 10-07-2011, 12:46 AM   #5
metalfiiish
LQ Newbie
 
Registered: Jul 2008
Posts: 13

Original Poster
Rep: Reputation: 0
thnx!

@jdkaye
Yes I had installed cups and cups-client, and elinks to access the localhost:631, but after adding the printer it did not seem to work, mayb I added it wrong? Also I have samba working right now, well not as I want but it works ( i wanted one folder for all user not every users home folder being shared..anywho ill figure that out later)

@frankbell
I had noticed that most people said to look at openprinting and like you said it has been down. I will check that link you provided though right now ^.^

@jlinkels

yes one of the guys here at work mentioned doing that ( though as I am not at home right now I can't open port 80 for me to do that externally but if I keep having issue's getting this to work before I go home then I will try that out when I can! (currently I only have ssh allowed through my router to my box)
 
Old 10-07-2011, 08:39 AM   #6
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 4,706

Rep: Reputation: 741Reputation: 741Reputation: 741Reputation: 741Reputation: 741Reputation: 741Reputation: 741
Quote:
Originally Posted by metalfiiish View Post
though as I am not at home right now I can't open port 80 for me to do that externally but if I keep having issue's getting this to work before I go home then I will try that out when I can! (currently I only have ssh allowed through my router to my box)
ssh -L 8080:localhost:631 your.host.athome
will open an ssh tunnel from your current machine to your box at home. It other words, it connects to your.host.athome, and redirects any traffic to itself at port 631, hence localhost:631.

After giving this command in a terminal window, start up your web browser on the machine at work, and got to
http://localhost:8080
You'll end up in your.host.athome:631.

Confusing as hell. If you want to access another host in your home network and you have to pass thru a gateway the ssh tunnel is like this:
ssh -L 8080:xotherhost:631 your.host.athome

Still you have to make the connection on the machine you are currently working on at work, leave the terminal alone and use your web browswer to localhost:8080

You can use the open ssh connection you have at that moment to edit the cups.conf file. WIthout the proper settings port 631 won't work of course.

jlinkels
 
Old 10-07-2011, 09:57 AM   #7
metalfiiish
LQ Newbie
 
Registered: Jul 2008
Posts: 13

Original Poster
Rep: Reputation: 0
So I'm home!

So I decided to try sane and it worked great seemingly.. after I finished installing it I set the Mx310 as the default printer and now when i make a print request
like cat file.txt | lp
I get this:

request id is Canon_MX310_series-5 (0 file(s))

this also happened to me yesterday when using cups with a driver I had installed...this leads me to believe I am missing something?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding a printer Gary_Menegon Linux - Software 1 08-27-2009 06:57 PM
Debian Printer issue fatum112 Linux - Hardware 0 01-05-2006 10:48 PM
Virtual Printer / CUPS-PDF Printer Issue in SuSE 10 jlstratton42 SUSE / openSUSE 0 12-21-2005 12:04 PM
Adding printer in Debian Sarge noxious Debian 2 06-28-2004 10:11 PM
adding a printer Schizo265 Linux - Hardware 2 12-01-2002 05:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration