-   Linux - Newbie (
-   -   Is installing a driver always such a pain? (

Travis86 12-29-2002 03:13 PM

Is installing a driver always such a pain?
I just bought two D-Link DFE-530TX+ ethernet cards so I could share a DSL modem between my Windows computer and my Linux computer. I put one card in the Windows computer, which recognized it, I told it where the driver was, and I was finished. It took maybe two minutes. I did the same thing with my Linux computer, but it did not say there was anything new like Windows did. The driver is a .c file that I tried to compile several times, but it failed each time due ultimately to missing header files ( .h [that's actually a "dot h" not some maimed emoticon]). All in all, I spent about two hours on it and never got it to work.

Do I have to get this driver going or can Linux do something on my behalf? Also, would a driver compiled by another system work? I found several versions on's FTP search. I'm just too chicken to try it. The file I'd ultimately like to have is rtl8139.o compiled for Red Hat and a kernel version of 2.4.18-3.

I guess I could call the D-Link 24/7 tech support, but they never got to me in the two hours I spent on hold last night, and I have no interest in doing it again.

deadbug 12-29-2002 04:06 PM

According to the Red Hat Website (, you need a Via-Rhine driver. A quick Google Search for "Via-rhine" turned up this website:

It looks like that should get you going

Travis86 12-29-2002 05:11 PM

That's for a DFE-530TX, I've got the DFE-530TX+, which is based on the RealTek 8139 instead of the Via-Rhine. However, while I was looking through that stuff, I found the source for another driver (8319too). I hope this will do the trick.

Just before I read that, I was trying to get everything installed from the command line, but since nothing else was working, I decided to try the "Network Configuration" tool in KDE, which I think is netcfg. It has a list of cards and I figured since my card wasn't listed, that I could find a card with the same chip. I tried it with the SiS 900 settings, but it said it couldn't be initialized. Bummer.

deadbug 12-29-2002 05:21 PM

Do a Google search for the driver you need (RealTek 8139)--should be helpful

Travis86 12-29-2002 09:33 PM

Fortunately, I found an entry called "RTL8139, SMC EZ Card Fast Ethernet" in Network Configuration and got the hardware up and running in no time. If I only knew it was that easy....

Now I will go start a new thread in the the networking section because I can't get the two computers to talk to each other.


blinux1 12-29-2002 10:52 PM

you need a Linux driver, usually distributed in an .rpm or .tar form

Aussie 12-30-2002 12:34 AM

Realtek 8139 cards are well supported in linux and all you need to do is "modprobe 8139too" to load the kernel driver module for one of these cards. Nothing needs to downloaded or installed.

All times are GMT -5. The time now is 02:16 AM.