LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 10-07-2001, 08:41 AM   #1
atari303
Member
 
Registered: May 2001
Posts: 34

Rep: Reputation: 15
IRQ conflict & ethernet configuration please


Hi, I have 2 problems that have been plagueing me.

I am running Slackware 8.0 kernel 2.4.5

first, I am trying to get my sound card configured but am having a problem with an IRQ conflict, the following:

dmesg | grep IRQ

shows the following:

sb: Interrupt test on IRQ5 failed - probable IRQ conflict
eth0: ADMtek Cetaur-P rev 17 at 0xe400, 00:03:6d:10:E9:F2, IRQ5
eth1: VIA VT3043 Thine at 0xe800, 00:50:ba:04:37:83, IRQ 11

so I guess my question here is, how can I change the IRQ of etho to something other than 5 so that my sounc card will work correctly?

Also I am having problems getting my machine w/multiple NIC's configured.

The 2 NIC's are:
D-Link DFE=530TX PCI Fast Ethernet Adapter
Network Everywhere Fast Ethernet (NC100 V2)

ifconfig shows eth0 and the card that the is working is the NE (NC100 V2) but the D-Link is not being seen on reboot.

ifconfig -a shows eth0 & eth1.

I have tried uncommenting the following in /etc/rc.d/rc.modules

/sbin/modprobe tulip //NE adapter
/sbin/modprobe via-rhine //D-link adapter

when I uncommented the via-rhine chipset I was then able to see the other card w/ifconfig -a but I'm trying to make these changes permanent as opposed to having to ifconfig up eth1 each time.

Doing some research I've found that adding the following:

append = "ether=0,0,eth1"

to lilo.conf was supposed to do the trick but it doesn't so I then recompiled the kernel and enabled both:

DECchip Tulip (dc21x4x) PCI support &
VIA Rhine support

but still no luck.

Does anyone know how I could enable my D-Link adapter and then netconfig each adapter so that the changes are permanent and change the IRQ or my NIC please please please? anyone? anyone? Beuler?

thx sooo much in advance

</nicholas>
 
Old 10-07-2001, 10:59 AM   #2
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
What sound card do you have???

It sounds to me like you have a resource conflict between your network cards too, one card 'disappearing' if a symptom of this. Try to get hold of the config utilities from the card manufacturers and hard set the resources to ones you know won't conflict, or if they are plug-n-pray cards make sure that your kernel includes plug-n-play support, and ensure your BIOS is set to 'Plug-n-Play aware OS: yes'

HTH

Jamie...
 
Old 10-07-2001, 11:40 AM   #3
atari303
Member
 
Registered: May 2001
Posts: 34

Original Poster
Rep: Reputation: 15
oh sorry, I have an ES1869 sound card.

So there is no way just to change the IRQ for the other NIC? it seems like the sound card is really to go except for that:

more of the dmesg shows

Soundblaster audio driver Copyright (C) by Hannu Savoliainene 1993-1996
SB 301 detected OK (220)
ESS chip ES1869 detected
sb: Interrupt test on IRQ5 failed - Probably IRQ conflict

See, when I installed Slackware the Network Everywhere card grabbed IRQ5 and the sound card was non-existant until a few modifications and a pnpdump, etc. I've read somwhere that sound cards usually try to occupy IRQ5 but.....

If you think that enabling PNP in the kernel will allocate the proper IRQ's I will try that but I've read that it doesn't really do much other than tell you that you have PNP devices, and it looks like it is at least finding the card and is ready to go (sorry I left out the card info). I haven't checked the BIOS but I think (dunno) that I'm ok there, this is a dual boot machine w/windows and all the devices are found w/no conflicts, it's just in Slackware that I am having the problem.

I feel like I'm so close and that all I need to do is just a few tweaks. So there is no way to manually set the IRQ? I apologize for being such a neophyte.

thx for responding
 
Old 10-07-2001, 11:47 AM   #4
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Plug-n-Play should both detect and initialise devices to ensure no conflicts occur, but if your BIOS is set to expect a non-PnP aware OS then it will attempt to initialise the devices and often do a bad job, hence your Linux PnP code will just detect the devices (and the conflicts).

As for maually setting the IRQ - AFAIK you'll need to use the manufacturers config tool... Some modules take IRQ options but these are normally to tell the module where the hardware is, not to set the hardware settings.

cheers

Jamie...
 
Old 10-07-2001, 06:22 PM   #5
atari303
Member
 
Registered: May 2001
Posts: 34

Original Poster
Rep: Reputation: 15
I'm still having problems after compiling but you're right, here is snip of my dmesg:

sb: ESS ES1869 Plug and Play AudioDrive detected
sb: ISAPnP reports 'ess es1869 Plug and Play AudioDrive; at i/o 0.220, irq 7, dma 1, 3
SB 3.01 ES1869 detected
sb: 1 Soundblaster PnP card(s) found

I still cannot hear sound in KDE's cd player. Perhaps it's my limited knowledge of KDE and the sound server but the cd plays w/no sound but will work in windows fine.

I also still have eth0 in IRQ 5 but that's ok w/me as long as it works, it's eth1 that I cannot figure out how to keep up on reboot and then how I might configure both w/netconfig so that I eventually run this machine as a gateway.

thanks for you're help so far, I feel like I'm a lot closer and just need a push in the right direction

</nicholas>
 
Old 10-07-2001, 07:33 PM   #6
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
For the CD sound, have you checked the volume levels in the Sound Mixer? Sometimes the default volume is pretty low; you might have to crank it up a fair amount. Click on the "K" menu on the taskbar, go to Mutimedia--> Sound--> Sound Mixer, and try adjusting levels there. If that works, choose "Save current volumes as default" under the Sound Mixer's File menu.

As for the NICs-

In /etc/modules.conf, do you have an "alias" line for each NIC to associate the NICs with the appropriate modules? They would look like this:
Code:
alias eth0 tulip
alias eth1 via-rhine
Slack might use a different file or syntax- I'm not sure.
 
Old 10-07-2001, 10:01 PM   #7
atari303
Member
 
Registered: May 2001
Posts: 34

Original Poster
Rep: Reputation: 15
I'm so confused, all of the levels were high in the sound mixer and I tried experimenting with the mute on each but no luck. When windows is up I usually hear a low hum coming from the speakers which lets me know it's ready to go but in Slackware, nothing.

As far as the NIC problem I'm at a total loss, I would have thought that putting those lines in modules.conf would have worked also and you're right, tulip and via-rhine are the right syntax. I don't have any idea what else I could do, but if you think it may help, here is are the results from dmesg | grep eth

eth0: ADMtek Comet rev 17 at 0xe400, 00:03:6D:10:E9:F2, IRQ 5.
etrh1: VIA VT3043 Rhine at 0xe800, 00:50:ba:04:37:83, IRA11.
eth1: MII PHY found at address 8, status 0x7809 advertising 08e1 Link 0000.

cat /proc/ioports shows:

e400-e4ff : PCI devices 1317:0985 (Bridgecom, Inc)
e400-e4ff : tulip
e800-e87f : VIA Technologies, Inc. VT86C100A [Rhine 10/100]
e800-e87f : via-rhine

is there any more information that I could give that would help me determine the problem? I would be more than glad to try anything at this point and would be open to any suggestions.

I really appreciate all of the responses so far, it feels like I'm really close here, it must be some obvious thing that I must be overlooking. thx again.

</nicholas>
 
Old 10-13-2001, 03:44 PM   #8
atari303
Member
 
Registered: May 2001
Posts: 34

Original Poster
Rep: Reputation: 15
Beuler? Beuler? Beuler? Beuler?
 
Old 10-17-2001, 01:45 AM   #9
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
For the sound check the permissions for /dev/dsp*, /dev/mixer* and /dev/sequencer*
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IRQ Conflict stevsurf Linux - Newbie 7 10-03-2003 01:01 AM
IRQ conflict joyxf86 Linux - Newbie 2 08-11-2003 12:43 PM
IRQ conflict Tommi Linux - Hardware 2 04-09-2003 05:15 AM
IRQ conflict Nitemare Linux - Hardware 1 05-22-2002 12:56 PM
irq conflict?? dsequeir Linux - Newbie 0 02-21-2002 01:11 AM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration