Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-25-2002, 07:59 AM   #1
LQ Newbie
Registered: Mar 2002
Location: Bangalore
Distribution: Linux
Posts: 11

Rep: Reputation: 0
iptables problem


I have configured iptables on linux 7.1, Having two NIC,
and running test ruleset for iptables.
It works fine for some time for some clients and won't work for other clients, it is really a strange problem for me.
Its own stops working for some clinets. if you ping to linux system from that client it pings for both eth0 and eth1. it won't ping to the internet.

if any one knows please tell why is that.


Old 03-25-2002, 12:19 PM   #2
Senior Member
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
If it's your your first iptables script or tables built for your network, it sounds like you most likely have some permissions set improper for the cooresponding ports and clients. If you could post the tables to the forum, someone will be able to tell if there is a mistake etc...
Old 03-25-2002, 10:58 PM   #3
LQ Newbie
Registered: Mar 2002
Location: Bangalore
Distribution: Linux
Posts: 11

Original Poster
Rep: Reputation: 0
# rc.firewall-2.4
# Initial SIMPLE IP Masquerade test for 2.4.x kernels
# using IPTABLES.
# Once IP Masquerading has been tested, with this simple
# ruleset, it is highly recommended to use a stronger
# IPTABLES ruleset either given later in this HOWTO or
# from another reputable resource.
# Log:
# 0.63 - Added support for the IRC IPTABLES module
# 0.62 - Fixed a typo on the MASQ enable line that used eth0
# instead of $EXTIF
# 0.61 - Changed the firewall to use variables for the internal
# and external interfaces.
# 0.60 - 0.50 had a mistake where the ruleset had a rule to DROP
# all forwarded packets but it didn't have a rule to ACCEPT
# any packets to be forwarded either
# - Load the ip_nat_ftp and ip_conntrack_ftp modules by default
# 0.50 - Initial draft

echo -e "\n\nLoading simple rc.firewall version $FWVER..\n"

# The location of the 'iptables' program
# If your Linux distribution came with a copy of iptables, most
# likely it is located in /sbin. If you manually compiled
# iptables, the default location is in /usr/local/sbin
# ** Please use the "whereis iptables" command to figure out
# ** where your copy is and change the path below to reflect
# ** your setup

#Setting the EXTERNAL and INTERNAL interfaces for the network
# Each IP Masquerade network needs to have at least one
# external and one internal network. The external network
# is where the natting will occur and the internal network
# should preferably be addressed with a RFC1918 private address
# scheme.
# For this example, "eth0" is external and "eth1" is internal"
# NOTE: If this doesnt EXACTLY fit your configuration, you must
# change the EXTIF or INTIF variables above. For example:
# EXTIF="ppp0"
# if you are a modem user.
echo " External Interface: $EXTIF"
echo " Internal Interface: $INTIF"

#== No editing beyond this line is required for initial MASQ testing ==

echo -en " loading modules: "

# Need to verify that all modules have all required dependencies
echo " - Verifying that all kernel modules are ok"
/sbin/depmod -a

# With the new IPTABLES code, the core MASQ functionality is now either
# modular or compiled into the kernel. This HOWTO shows ALL IPTABLES
# options as MODULES. If your kernel is compiled correctly, there is
# NO need to load the kernel modules manually.
# NOTE: The following items are listed ONLY for informational reasons.
# There is no reason to manual load these modules unless your
# kernel is either mis-configured or you intentionally disabled
# the kernel module autoloader.

# Upon the commands of starting up IP Masq on the server, the
# following kernel modules will be automatically loaded:
# NOTE: Only load the IP MASQ modules you need. All current IP MASQ
# modules are shown below but are commented out from loading.
# ===============================================================

#Load the main body of the IPTABLES module - "iptable"
# - Loaded automatically when the "iptables" command is invoked
# - Loaded manually to clean up kernel auto-loading timing issues
echo -en "ip_tables, "
/sbin/insmod ip_tables

#Load the IPTABLES filtering module - "iptable_filter"
# - Loaded automatically when filter policies are activated

#Load the stateful connection tracking framework - "ip_conntrack"
# The conntrack module in itself does nothing without other specific
# conntrack modules being loaded afterwards such as the "ip_conntrack_ftp"
# module
# - This module is loaded automatically when MASQ functionality is
# enabled
# - Loaded manually to clean up kernel auto-loading timing issues
echo -en "ip_conntrack, "
/sbin/insmod ip_conntrack

#Load the FTP tracking mechanism for full FTP tracking
# Enabled by default -- insert a "#" on the next line to deactivate
echo -en "ip_conntrack_ftp, "
/sbin/insmod ip_conntrack_ftp

#Load the IRC tracking mechanism for full IRC tracking
# Enabled by default -- insert a "#" on the next line to deactivate
echo -en "ip_conntrack_irc, "
/sbin/insmod ip_conntrack_irc

#Load the general IPTABLES NAT code - "iptable_nat"
# - Loaded automatically when MASQ functionality is turned on
# - Loaded manually to clean up kernel auto-loading timing issues
echo -en "iptable_nat, "
/sbin/insmod iptable_nat

#Loads the FTP NAT functionality into the core IPTABLES code
# Required to support non-PASV FTP.
# Enabled by default -- insert a "#" on the next line to deactivate
echo -en "ip_nat_ftp, "
/sbin/insmod ip_nat_ftp

# Just to be complete, here is a list of the remaining kernel modules
# and their function. Please note that several modules should be only
# loaded by the correct master kernel module for proper operation.
# --------------------------------------------------------------------
# ipt_mark - this target marks a given packet for future action.
# This automatically loads the ipt_MARK module
# ipt_tcpmss - this target allows to manipulate the TCP MSS
# option for braindead remote firewalls.
# This automatically loads the ipt_TCPMSS module
# ipt_limit - this target allows for packets to be limited to
# to many hits per sec/min/hr
# ipt_multiport - this match allows for targets within a range
# of port numbers vs. listing each port individually
# ipt_state - this match allows to catch packets with various
# IP and TCP flags set/unset
# ipt_unclean - this match allows to catch packets that have invalid
# IP/TCP flags set
# iptable_filter - this module allows for packets to be DROPped,
# REJECTed, or LOGged. This module automatically
# loads the following modules:
# ipt_LOG - this target allows for packets to be
# logged
# ipt_REJECT - this target DROPs the packet and returns
# a configurable ICMP packet back to the
# sender.
# iptable_mangle - this target allows for packets to be manipulated
# for things like the TCPMSS option, etc.

echo ". Done loading modules."

#CRITICAL: Enable IP forwarding since it is disabled by default since
# Redhat Users: you may try changing the options in
# /etc/sysconfig/network from:
# FORWARD_IPV4=false
# to
echo " enabling forwarding.."
echo "1" > /proc/sys/net/ipv4/ip_forward

# Dynamic IP users:
# If you get your IP address dynamically from SLIP, PPP, or DHCP,
# enable this following option. This enables dynamic-address hacking
# which makes the life with Diald and similar programs much easier.
echo " enabling DynamicAddr.."
echo "1" > /proc/sys/net/ipv4/ip_dynaddr

# Enable simple IP forwarding and Masquerading
# NOTE: In IPTABLES speak, IP Masquerading is a form of SourceNAT or SNAT.
# NOTE #2: The following is an example for an internal LAN address in the
# 192.168.0.x network with a or a "24" bit subnet mask
# connecting to the Internet on external interface "eth0". This
# example will MASQ internal traffic out to the Internet but not
# allow non-initiated traffic into your internal network.
# ** Please change the above network numbers, subnet mask, and your
# *** Internet connection interface name to match your setup

#Clearing any previous configuration
# Unless specified, the defaults for INPUT and OUTPUT is ACCEPT
# The default for FORWARD is DROP
echo " clearing any existing rules and setting default policy.."
$IPTABLES -t nat -F

echo " FWD: Allow all connections OUT and only existing and related ones IN"

echo " Enabling SNAT (MASQUERADE) functionality on $EXTIF"

echo -e "\nrc.firewall-2.4 v$FWVER done.\n"

This what I am using for testing, but there no restriction only masq is there.
Old 03-26-2002, 07:44 AM   #4
Senior Member
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 47
I don't see any problems with that test script. It's probably how you've configured the rest of your network. I couldn't totally follow your first post on what exactly was working and what wasn't. But from what I understand is that it works for some clients and for others it doesn't. How have you setup those clients? What is the default gateway set to on the client? And how is the client resolving it's dns names?
Maybe a little more information on how you've set up the clients and exactly what is getting through and what is not might help.
Old 03-26-2002, 10:35 PM   #5
LQ Newbie
Registered: Mar 2002
Location: Bangalore
Distribution: Linux
Posts: 11

Original Poster
Rep: Reputation: 0
Hi mik,

Thanx, here is the setup detail.
I have router which connects to the internet, in linux I am running this sample script, if it works I wanted use stronger one and port forwarding for my mail server which inside my LAN. Squid proxy also runs in that, but some usrers are using "outlook Express" for those I have to setup linux box as gateway, because my squid won't support for "pop". In that users only, some people can able to get connected for some time and some people are not. After some time it get connected as its own. It is really strange for me.

All clients are using linux box as gateway.
I hope now you can able to understand what is my problem is.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem iptables stomach Linux - Software 3 09-22-2005 03:21 PM
problem with iptables Israfel2000 Linux - Security 3 07-18-2004 01:30 AM
iptables problem bhagat_panwar Linux - Software 0 08-27-2003 07:45 AM
iptables problem? poulaum Linux - Networking 12 02-27-2003 04:57 PM
Problem with IPTABLES jfall Linux - Networking 3 11-04-2002 04:10 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:04 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration