LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2017, 07:39 AM   #1
mike acker
Member
 
Registered: Feb 2014
Location: Michigan
Distribution: Debian 10
Posts: 190

Rep: Reputation: Disabled
iPhone6s mount refused


my LMDE/2 systems refuse to mount iPhone6S

some sort of software update is needed but I can't seem to get an up to date solution

I think I need to update libimobiledevice to version 6 but this doesn't pull from the backports
 
Old 06-03-2017, 08:40 AM   #2
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 19
Posts: 6,309
Blog Entries: 21

Rep: Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166
Have you read these?

https://forums.linuxmint.com/viewtopic.php?t=175094

https://forums.linuxmint.com/viewtopic.php?t=202023

Quote:
There are a few libimobiledevice listed in the software manager. Once I installed libimobiledevice-dev and libimobiledevice6 I was able to mount my iphone 5s with ios 10.1.1 and was able to transfer my photos and videos. I will note that I also just updated my kernel to 4.10.0-14
 
Old 06-03-2017, 09:44 AM   #3
mike acker
Member
 
Registered: Feb 2014
Location: Michigan
Distribution: Debian 10
Posts: 190

Original Poster
Rep: Reputation: Disabled
thanks,--

I think the problem is related to changes AAPL made recently to protect iPhones from malware that was being distributed in after-market chargers

i have only libimobiledevice4 available; i might get libimobiledevice6 here:
https://packages.debian.org/sid/amd6...vice6/download

i think this should be a good source; i was hoping to get a note from someone who had used this source,--

this would be for version:
libimobiledevice6_1.2.0+dfsg-3.1_amd64.deb on AMD64 machines

$ dpkg -l | grep libimobiledevice
ii libimobiledevice-utils 1.1.6+dfsg-3.1 amd64 Library for communicating with iPhone and iPod Touch devices
ii libimobiledevice4:amd64 1.1.6+dfsg-3.1 amd64 Library for communicating with the iPhone and iPod Touch

thanks for helping; hopefully i'm on the right track,--

i do have a research box i can test the change on

Last edited by mike acker; 06-03-2017 at 09:45 AM.
 
Old 06-04-2017, 12:59 PM   #4
mike acker
Member
 
Registered: Feb 2014
Location: Michigan
Distribution: Debian 10
Posts: 190

Original Poster
Rep: Reputation: Disabled
attempting to install libimobiledevice6 -- NOGO:


Quote:
Selecting previously unselected package libimobiledevice6:amd64.
(Reading database ... 192572 files and directories currently installed.)
Preparing to unpack libimobiledevice6_1.2.0+dfsg-3.1_amd64.deb ...
Unpacking libimobiledevice6:amd64 (1.2.0+dfsg-3.1) ...
dpkg: dependency problems prevent configuration of libimobiledevice6:amd64:
libimobiledevice6:amd64 depends on libgcrypt20 (>= 1.7.0); however:
Version of libgcrypt20:amd64 on system is 1.6.3-2+deb8u2.
libimobiledevice6:amd64 depends on libgnutls30 (>= 3.5.6); however:
Package libgnutls30 is not installed.
libimobiledevice6:amd64 depends on libplist3 (>= 1.11); however:
Package libplist3 is not installed.
libimobiledevice6:amd64 depends on libtasn1-6 (>= 4.5); however:
Version of libtasn1-6:amd64 on system is 4.2-3+deb8u3.
libimobiledevice6:amd64 depends on libusbmuxd4 (>= 1.0.10); however:
Package libusbmuxd4 is not installed.

dpkg: error processing package libimobiledevice6:amd64 (--install):
dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.19-18+deb8u9) ...
Errors were encountered while processing:
libimobiledevice6:amd64
my brother tells me he is able to use a Bluetooth link. I'm no fan of bluetooth but until we get a complete .deb for this libimobiledevice program i guess we are kinda stuck

Last edited by mike acker; 06-04-2017 at 01:04 PM.
 
Old 06-04-2017, 01:50 PM   #5
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
It sounds like your system is too old to install the package.
 
Old 06-04-2017, 04:06 PM   #6
mike acker
Member
 
Registered: Feb 2014
Location: Michigan
Distribution: Debian 10
Posts: 190

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AwesomeMachine View Post
It sounds like your system is too old to install the package.
i think it is more that I need a collection of programs rather than just the 1 .deb -- i.e. i need the other .deb files that are associated with libimobiledevice6

the system is LMDE/2

I think we are getting to the point where we are needing an LMDE/3 pretty bad though. even with that though I think they are planning on kernel 4.9 where we need 4.10 or better to handle the new RYZEN chips. not that it really matters all that much,-- I already updated the kernel to 4.10 in my MINT-18/KDE box -- and it seems to be fine.

in reality though I think a good 4core chip is plenty for general desktop use -- and these can be had with integrated graphics so as not to need to fuss with a graphics card

Last edited by mike acker; 06-04-2017 at 04:08 PM.
 
Old 06-04-2017, 07:19 PM   #7
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 19
Posts: 6,309
Blog Entries: 21

Rep: Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166Reputation: 3166
I don't know if this will work or not. Never tried it.

Quote:
More clients are under development; Web, Linux (GTK), Windows and OS X.
https://pushjet.io/

I can't help much. I sold my Iphone 5s and moved on to a Samsung S7 edge. Here are my steps if they help or not. LMDE is Debian Mint. My posts are in AntiX. Another Debian based distro.

http://antix.freeforums.org/iphone-5...8-2-t5586.html

I might be talking pineapples vs apples though <different libs and all>. So take my post with a grain of salt.

Last edited by rokytnji; 06-04-2017 at 07:25 PM.
 
Old 06-05-2017, 05:58 AM   #8
mike acker
Member
 
Registered: Feb 2014
Location: Michigan
Distribution: Debian 10
Posts: 190

Original Poster
Rep: Reputation: Disabled
thanks

i've ordered a Bluetooth USB transceiver; my brother says his works that way so i'm gonna try that method.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS mount problem: Connection refused kenneho Linux - Software 7 10-16-2008 10:42 AM
mount: mount to NFS server '192.168.0.3' failed: System Error: Connection refused. fakie_flip Linux - Server 1 04-10-2008 12:28 AM
USB stick - hal-storage-removable-mount refused serge_shp Linux - Software 1 07-01-2007 06:53 PM
on boot mount: RPC: remote system error - connection refused overlinx Linux - Networking 0 10-02-2006 10:51 AM
mount: RPC: Unable to receive; errno = Connection refused peacho Linux - Networking 1 01-15-2003 02:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration