LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-09-2014, 07:35 AM   #1
sumeet inani
Member
 
Registered: Oct 2008
Posts: 902
Blog Entries: 26

Rep: Reputation: 49
ip , network address , subnet mask basics


we have a cisco catalyst network switch in our lab
I want to use ip 172.16.200.something to create two separate networks
I tried to use following
Code:
#sh int vlan 280
Vlan280 is up, line protocol is up
  Hardware is EtherSVI, address is 588d.090e.597f (bia 588d.090e.597f)
  Internet address is 172.16.200.241/28
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:23:23, output 00:24:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     180 packets input, 18123 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     8 packets output, 1640 bytes, 0 underruns
     0 output errors, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
This works.
here I have set subnet mask 255.255.255.four-ones-four-zeros
Now I am unable to think of another network ?
 
Old 05-09-2014, 08:08 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
Quote:
255.255.255.four-ones-four-zeros
?? what on earth does that mean?

why do you need to "think" of another network, you would just use an appropriate network mask. if you want to split a /24 into two halevs, then the mask would be a /25. You don't memorize binary strings.
 
Old 05-09-2014, 08:17 AM   #3
sumeet inani
Member
 
Registered: Oct 2008
Posts: 902
Blog Entries: 26

Original Poster
Rep: Reputation: 49
OK , I could not clarify myself in my first post.

Current configuration is
Code:
gpon1#sh runn int vlan 280
Current configuration : 68 bytes
!
interface Vlan280
 ip address 172.16.200.241 255.255.255.240
end
ip dhcp pool vlan280
   network 172.16.200.240 255.255.255.240
   dns-server 196.1.105.47
   default-router 172.16.200.241
!

gpon1#sh runn int vlan 281
Current configuration : 66 bytes
!
interface Vlan281
 ip address 172.16.200.1 255.255.255.240
end


ip dhcp pool vlan281
   network 172.16.200.0 255.255.255.240
   dns-server 196.1.105.47
   default-router 172.16.200.1
!
I am hoping that this will give IP 172.16.200.242-255 for those with vlan 280.
This happens.
Also , I hope that those with vlan 281 will get IP 172.16.200.2-15
This does not happen ?
 
Old 05-11-2014, 11:33 PM   #4
sumeet inani
Member
 
Registered: Oct 2008
Posts: 902
Blog Entries: 26

Original Poster
Rep: Reputation: 49
Is that understandable ?
Where am I wrong in my settings ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network Address subnet mask kapilbajpai88 Linux - Newbie 4 04-28-2009 04:27 PM
question about IP address and subnet mask 2007fld Linux - Networking 4 03-28-2007 11:00 AM
subnet mask kizersouzay Linux - Networking 1 08-31-2005 03:07 PM
All network/broadcast pairs for subnet mask? debbo Linux - Networking 1 06-14-2004 04:27 PM
Setting IP Address and Subnet Mask and whatnot... Sloanr333 Linux - Networking 6 11-06-2003 11:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration