LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-01-2011, 08:05 PM   #1
loveulinux
Member
 
Registered: Aug 2011
Posts: 68

Rep: Reputation: Disabled
IP address and gui mode problem


Hi..All,
Few days back we turned off the servers to remove the dust. All of the servers are working fine after switching on.
But one server(ubuntu 9.04) is not able to boot to GUI mode and GUI mode will cuts off in the middle while booting to GUI and monitor shows to check display.
In the same server, the IP address is frequently changing itself to dhcp even static IP address given in /etc/network/interface. Here is the output of those files.
Quote:
cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1

auto eth4
iface eth4 inet static
address 192.168.0.2
netmask 255.255.255.0
gateway 192.168.0.1
Quote:
cat /etc/resolv.conf
nameserver 192.168.0.1
There are only two NICs. Although it is showing eth4 instead of eth1 if run
Quote:
mii-tool
The cable is connected to eth4 and no one cable is connected to eth0. Everything will be working fine only for 1 or 2 days in ubuntu 9.04 server. We are not coming to know when and why eth4 address is changing to dhcp.
Please help me masters in fixing up GUI mode and permanent static IP to eth4.
 
Old 11-01-2011, 08:34 PM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,665

Rep: Reputation: 485Reputation: 485Reputation: 485Reputation: 485Reputation: 485
Hard wired connection. I don't say do this, but if I was in your shoes I will do the ff:
Try shut down the machine. Carefully detach cable and all lan cards (eth0 and eth4); clean the contact pins, re-attach eth0 card properly in its place see that all pins take the bite; do not re-attach the eth4; attach the lan cable into the eth0 (meanwhile condemn eth4). In your /etc/network/interfaces comment everything about eth4 and leave eth0 configuration as is. Reboot. Observe. Come back.

Gui in a server? I don't believe servers need GUI. Anyway that's Ubuntu right? Check your xorg.conf.

Hope that helps.
 
1 members found this post helpful.
Old 11-01-2011, 11:52 PM   #3
loveulinux
Member
 
Registered: Aug 2011
Posts: 68

Original Poster
Rep: Reputation: Disabled
IP address and gui mode problem

Thanks for reply.
We are having Intel Xeon server, so both eth0 and eth1 are built into the motherboard and we can't remove LAN cards. So how can I fix this IP address problem master?
And you are right, the server doesn't need GUI mode. But other admins don't have much experience about CLI. So if the server has GUI, they can fix up such problems on my behalf.



Quote:
Originally Posted by malekmustaq View Post
Hard wired connection. I don't say do this, but if I was in your shoes I will do the ff:
Try shut down the machine. Carefully detach cable and all lan cards (eth0 and eth4); clean the contact pins, re-attach eth0 card properly in its place see that all pins take the bite; do not re-attach the eth4; attach the lan cable into the eth0 (meanwhile condemn eth4). In your /etc/network/interfaces comment everything about eth4 and leave eth0 configuration as is. Reboot. Observe. Come back.

Gui in a server? I don't believe servers need GUI. Anyway that's Ubuntu right? Check your xorg.conf.

Hope that helps.

Last edited by loveulinux; 11-01-2011 at 11:58 PM. Reason: correction
 
Old 11-02-2011, 12:20 AM   #4
hen770
Member
 
Registered: Oct 2010
Distribution: Arch
Posts: 136

Rep: Reputation: 7
Just to be clear, there is just one cable that is attached to the serevr correct?
What ifconfig brings?
 
1 members found this post helpful.
Old 11-02-2011, 07:51 AM   #5
loveulinux
Member
 
Registered: Aug 2011
Posts: 68

Original Poster
Rep: Reputation: Disabled
IP address and gui mode problem

Yes, only one cable is connected to eth4. ifconfig brings up 3 interface eth0-192.168.1.2, eth4-192.168.0.2 and lo. I have given static IP to eth0 because if I give dhcp and since no one cable is connected to eth0, it will not get any dhcp address and takes long time to complete
"/etc/init.d/networking restart" command. Please see the mii-tool output.
Quote:
#mii-tool
SIOCGMIIREG on eth0 failed: Input/output error
SIOCGMIIREG on eth0 failed: Input/output error
No MII transceiver present!.
SIOCGMIIREG on eth4 failed: Input/output error
SIOCGMIIREG on eth4 failed: Input/output error
eth4: negotiated 1000baseT-FD flow-control, link ok

Quote:
Originally Posted by hen770 View Post
Just to be clear, there is just one cable that is attached to the serevr correct?
What ifconfig brings?

Last edited by loveulinux; 11-02-2011 at 09:03 AM. Reason: correction
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Display problem in Linux (GUI Mode) Nishvlsi Linux - Hardware 1 12-08-2009 03:58 AM
GUI mode problem praneethgv Linux - Newbie 3 11-24-2008 03:40 AM
Problem in entering GUI mode after installation venmugil VectorLinux 1 03-27-2008 05:08 AM
problem booting in GUI mode aquasika Linux - Newbie 3 04-01-2005 11:20 AM
GUI mode login problem Tinku Linux - General 6 10-16-2004 01:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration