LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-12-2018, 12:09 PM   #1
heromedel
LQ Newbie
 
Registered: May 2018
Posts: 3

Rep: Reputation: Disabled
invalid video mode specification 1280x768 booting in blind mode.


Basically I couldn't get my screen resolution to work with an hdmi cable and eventually just switched to vgs. Everything is working fine except I can't remove a video mode I added that keeps causing errors at start up.

I tried using xrande --rmmode and xrandr --delmode but couldnt get them to work.

I am basically brand new to linux. Can I just remove the invalid video mode?
 
Old 05-12-2018, 07:55 PM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Welcome!

Does the system get stuck at the login screen? Which distro are you using?
 
Old 05-12-2018, 09:33 PM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,128

Rep: Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676Reputation: 1676
you are speaking of booting up your system and it fails at getting a particulr video size?

in your file here
Code:
/etc/default/grub
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
#GRUB_GFXMODE=1024x768x32
GRUB_GFXMODE=1024x768x32, 640x480, auto
you can set it to try some different settings and if all else fails set it to auto at the end and let it pick it for you, as stated in this doc

https://wiki.archlinux.org/index.php...ips_and_tricks
just remember for any changes made to that file you have to run update-grub again as root, for any changes to take place.

Last edited by BW-userx; 05-12-2018 at 09:34 PM.
 
Old 05-15-2018, 08:57 AM   #4
heromedel
LQ Newbie
 
Registered: May 2018
Posts: 3

Original Poster
Rep: Reputation: Disabled
No it doesn't get stuck in login. Only the error message and otherwise works fine on vga but not in hdmi.

I edited the file and changed it to the display size that is working for me but there error still said 1280 even though I changed the number in the file to 1360.

I am using linux mint latest version (18.3 If I recall correctly)

I don't know if these graphics issues are related to the entire machine freezing on occasions usually with mouse control but nothing else working sometimes without mouse control. Sorry that might be an unrelated issue.

I am think of changing monitors or just trying out antergos instead of mint.

TLDR: Still have the error after editing grub
 
Old 05-15-2018, 09:00 AM   #5
heromedel
LQ Newbie
 
Registered: May 2018
Posts: 3

Original Poster
Rep: Reputation: Disabled
I edited the grub file to match the display setting which is working for 1360x768 but I still got an error at start up saying 1280x768

I am using linux mint (18.3 the latest I belive) and no it's not freezing on startup.

Everything mostly works fine on vga once it is started but not on hdmi then the display never looks right .

my monitor is an Emerson LC190EM1


I am unsure if this related to the system occasional freezing while playing games. Usually with mouse control still enabled but not always. Sorry that might be a separate issue.

Last edited by heromedel; 05-15-2018 at 09:04 AM.
 
Old 05-15-2018, 03:13 PM   #6
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,198

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Quote:
Originally Posted by heromedel View Post
I edited the grub file to match the display setting which is working for 1360x768 but I still got an error at start up saying 1280x768
What is the output from
Code:
cat /proc/cmdline
and
Code:
lspci -nnk | grep -A4 VGA
That Emerson looks to be old enough that it could be a victim of the tail end of the capacitor plague and the cause of ill behavior trying to use the HDMI port.
 
Old 05-15-2018, 03:18 PM   #7
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,198

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Quote:
Originally Posted by heromedel View Post
I edited the grub file to match the display setting which is working for 1360x768 but I still got an error at start up saying 1280x768
1360, or 1366? https://www.cnet.com/products/emerso...-lcd-tv/specs/ says 1366.
 
Old 05-16-2018, 05:34 AM   #8
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 9,918

Rep: Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077Reputation: 1077
If you're using Veda or Framebuffer, all the modes are 4:3 ratio, a little off square.
Later monitors are 16:9, noticeably wider than long.
Movies can be wider again.

1280 X 720 is a. 16:9 mode, or 1024 X 768 is a 4:3 mode. Maybe try one of those?
 
Old 05-16-2018, 07:39 AM   #9
dave@burn-it.co.uk
Member
 
Registered: Sep 2011
Distribution: Puppy
Posts: 601

Rep: Reputation: 172Reputation: 172
16:10 is popular nowadays as well
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting problem: Kubuntu 14.04 error no suitable video mode found Ssawyer1 Linux - Newbie 4 07-02-2016 01:48 PM
Booting in text mode versus graphics mode LChalupa Linux - Newbie 3 01-15-2005 07:53 PM
Invalid graphic mode? mykrob Linux - General 18 08-25-2004 04:02 PM
How can I change display mode from character mode to graph mode wuzhong Linux - Hardware 1 08-08-2004 09:36 AM
Slack booting issue (Video mode Not supported) enk0d Slackware 6 10-24-2003 07:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration