LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   "Invalid mount option when attempting to mount the volume." on plugging USB (https://www.linuxquestions.org/questions/linux-newbie-8/invalid-mount-option-when-attempting-to-mount-the-volume-on-plugging-usb-782940/)

sumeet inani 01-18-2010 06:19 AM

"Invalid mount option when attempting to mount the volume." on plugging USB
 
I plugged in USB(single fat32 partiton of 2GB) and got message window

Cannot mount volume.
Invalid mount option when attempting to mount the volume.

I tried
# vol_id /dev/sdb1
ID_FS_USAGE=filesystem
ID_FS_TYPE=vfat
ID_FS_VERSION=FAT32
ID_FS_UUID=29AE-4380
ID_FS_UUID_ENC=29AE-4380
ID_FS_LABEL=
ID_FS_LABEL_ENC=
ID_FS_LABEL_SAFE=

Also did check in gparted , dosfsck and fsck.vfat but no errors reported.
What do you suggest ?

evo2 01-18-2010 06:23 AM

Quote:

Originally Posted by sumeet inani (Post 3830666)
Also did check in gparted , dosfsck and fsck.vfat but no errors reported.
What do you suggest ?

Try mounting it manually.

Code:

sudo mount -t vfat /dev/sdb1 /mnt
Evo2.

sumeet inani 01-18-2010 06:34 AM

I do that presently ( 'mount /dev/sdb1 /pd' ) where i have created folder /pd .
It works well )but as you know only root can mount so copying & deleting files to USB is tedious.
I think either I have to label the file-system (maybe then it will automount ) or find way so that ordinary user can mount /dev/sdb1 (atleast better than root doing it)

evo2 01-18-2010 07:05 AM

Quote:

I do that presently ( 'mount /dev/sdb1 /pd' where i have created folder /pd . It works well )but as you know only root can mount so copying & deleting files to USB is tedious.
Just put an entry in your /etc/fstab then anyone can mount it.
Code:

/dev/sdb1        /pd        vfat    defaults,user,noauto 0 0
The problem seems to be with whatever system you are using to automagically mount the device. I suggest you find out what that system is and investigate it. Perhaps some Ubuntu users will be able to help you (I dislike and don't use automounting for devices like usb sticks).

Cheers,

Evo2.

PS. After adding the fstab entry, anyone can mount with the following command
Code:

mount /pd

sumeet inani 01-18-2010 07:16 AM

Thanks evo2.It worked well.
i will also try to understand the meaning of line added in /etc/fstab.
I did read to get basic idea that
Code:

entry in /etc/fstab is
device mountpoint filesystem option defaults dump check
(1)For external we keep 0 for last two meaning don't backup & check.
(2)we can use auto for type so system tries to detect.
(3)In option Defaults means root can mount.
(4)user option means anyone can mount but one who mounted has to unmount.
(5)users option ( see extra 's' ) means anybody can unmount.


sumeet inani 02-23-2010 10:40 PM

Questions
(1)Also i was wondering that in gparted > show features > they show operation possible for particular file system . Why is there a refresh button in it . Can i install some extras to enable something (say reading lable of fat32) ?


All times are GMT -5. The time now is 11:35 AM.