-   Linux - Newbie (
-   -   Internet suddenly stopped working. (

figster 08-29-2005 05:04 PM

Internet suddenly stopped working.
Hello everyone,

I'm a total newb, know next to nothing about Linux except that I should probably start using it b/c of all the good things I hear. I installed Fedora Core 4 with a dual boot system that allows me to still use Win XP about a month ago. For the first 2-3 weeks, everything was great, my internet (Cox Cable Hi Spd Intrnt) worked fine on both OS. Now, a few days ago, Mozilla says "could not find xxxxxx" whenever I try to access a webpage.

I know the internet connection is still good as I'm writting this right now using XP and I know it did work w/o incident before on FC. The only things that have changed that I can think of within the last week or two are that I had to unplug my ethernet cable to move my desk and I also installed AVG on Win XP (free anti-virus program). I can't really see these events as causing my problem, but I really dont know what it is.

When I start FC, the boot process goes ok until it reaches "Determining IP information for eth0..." then, after a min: "icmp open socket: Permission denied" and the test is listed as FAILED and it moves on.

I use the XP firewall, but I turned it off and still the same thing. I'm not sure if I have on in FC.

I see a lot of posts about pinging your IP but I'm not sure how to do that or if I even need to. I guess I'm pretty much like a blind guy trying to hit fastballs off Nolan Ryan: I ain't got a chance on my own. Any dumbed down advicce would be greatly appreciated.



bosewicht 08-29-2005 05:14 PM

after you boot up, try taking a look at dmesg (open a terminal and type dmesg)

jonaskoelker 08-29-2005 05:18 PM

here's a few things to try out:

open an xterm (or whatever terminal you prefer), and run the following (`$' represents your normal user prompt (and thus isn't a part of the command), `#' the root prompt):

$ ip addr show eth0 #look for `inet'
$ ping # is your machine; stop it w. ^C
$ tcptraceroute
$ tcptraceroute
# ifconfig eth0
# dhclient
# iptables -L


I also installed AVG on Win XP...

I use the XP firewall, but I turned it off and still the same thing. I'm not sure if I have on in FC.
They shouldn't relate to what goes on in GNU/Linux, since they both run under Microsoft Windows XP.

hth --Jonas

All times are GMT -5. The time now is 09:48 AM.