Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 12-18-2003, 11:11 AM   #16
LQ Newbie
Registered: Dec 2003
Posts: 19

Original Poster
Rep: Reputation: 0

Well I tried pinging the PC that hosts the connection and that is fine. I also pinged the loopback address and that is fine also. I tried pinging Google's IP (which I think is and got "Network is unreachable"
All very frustrating.
Any other thoughts anyone?


Old 12-18-2003, 12:05 PM   #17
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30

ICS simply turns the Win2K box into a simple router and DHCP server, and provided that eth0 is configured to use DHCP it should get all relative info from the Win2K box. I believe that you can set it to use DHCP in the mandrake control center, but I don't use Mandrake so I am not positive. If you can set it to DHCP, the eth0 should broadcast a DHCP_REQUEST packet and get all of the info needed from tthe Win2K box.

That's my best advice. The settings can be done manually as well, but DHCP should work just fine.

Old 12-18-2003, 02:46 PM   #18
LQ Newbie
Registered: Dec 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Aha. Now that makes a lot of sense. I will explore the Mandrake Control Panel to see if it has a "Obtain IP address automatically" setting.

If anyone knows how to do this, that would be really helpful.


Old 12-18-2003, 04:41 PM   #19
Registered: Dec 2003
Location: Al-Diwania, Iraq (deployed)
Distribution: Slackware ONLY
Posts: 237

Rep: Reputation: 30
that would make things get along better, in the meantime, resend your route table, there should be a line for
destination default gateway genmask (whatever your router uses..)
or something similar, there is an example in man route, or man routeadd
Old 12-18-2003, 05:44 PM   #20
LQ Newbie
Registered: Dec 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Route table now shows:
Destination:; Gateway:; Genmask: iface eth0
Destination: Gateway: Genmask: iface l0
Destination: Gateway: Genmask iface eth0

The last entry was as a result of me entering "route -v add default gw" I hope that was right; I was trying to set a default gateway.

Just to recap, is the IP of the W2K PC hosting the internet connection. It is set up to run Windows ICS.
Any idea how I can get the Linux PC to obtain its IP address automatically?

Thanks again


Old 12-18-2003, 06:11 PM   #21
LQ Guru
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
you could always set static ips for both machines and add the gateway as a nameserver to resolv.conf of the linux machine.
Old 12-18-2003, 06:21 PM   #22
LQ Newbie
Registered: Dec 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Well team, you will be glad to hear that I am typing this on my linux box. I found the DHCP configuration on a freeBSD site ( It is buried in etc/sysconfig/network-scripts/ifcfg-eth0. It seemed to require a re-boot (I thought linux didn't need those) to enable connection, but it seems fine now.

A really big thank you to all those who took the time to respond. I hope you will all be as patient for the inevitable "next time".

Bye for now.


Old 01-02-2004, 12:37 AM   #23
LQ Newbie
Registered: Jan 2004
Posts: 2

Rep: Reputation: 0
I don't know if you have found your solution yet, but I have a very similar network using Mandrake 9.2, Win2KPro, WinXP, and Familiar Linux (Ipaq)

Here's what I have done. Hopefully it will help.

Here are the machines:
1) Win2K -- Internet Connection box.
a) Network Card 1 : ethernet connection to house network
IP Address -- static (
Netmask --
Broadcast --
Internet Connection Sharing disabled
b) Network Card 2 : internet connection
IP Address -- dynamic (generated by ISP)
Internet Connection Sharing enabled

2) Mandrake 9.2 / Win XP dual boot notebook (only mandrake config shown)
a) eth0 : ethernet connection to house network
IP Address -- dynamic (usually
Netmask --
Broadcast --

Now on the Mandrake box I have the following in my /etc/resolv.conf file:


Until you get things running I would suggest that you disable shorewall completely. This may require you to add the following to the /etc/shorewall/

eth0 -

Then make sure the following is in your routing table (type route to find out)
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 0 0 0 eth1
default UG 0 0 0 eth1

This is all I required to get things going. Most are set up properly when you install Mandrake, or turn on ICS on the Windows box.

Last edited by esmithbss; 01-02-2004 at 12:40 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet connection sharing fdawy Linux - Networking 22 10-06-2005 09:23 AM
sharing my internet connection berrance Linux - Networking 1 02-25-2005 11:33 AM
SHaring internet connection bart59 Linux - Networking 1 01-27-2005 07:24 AM
Internet Connection Sharing geekbyday Linux - Networking 9 11-19-2004 10:59 PM
Internet Connection Sharing Chijtska Linux - Networking 7 09-02-2002 11:50 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:11 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration