LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Internet connection (https://www.linuxquestions.org/questions/linux-newbie-8/internet-connection-73092/)

linda 07-15-2003 09:34 PM

Internet connection
 
I am really upset! I finally got Mandrake 9.1 installed, and fired up an internet connection, went to my yahoo mail, read it and replied to someone, no problems. Then I decided to close the Mandrake control center box (which was open because I had to connect manually) and got disconnected from the net. And now I can't get it to connect again!

I have been trying to use Mandrake (7.0, 8.0, and now 9.1) for a few years, but keep getting hung up with the internet config. I was so happy that it worked just now, and then to have it snatched away.... anyway, here's the deal...

I have a dsl connection with verizon. I have a card installed in my computer, which mandrake found and set up (as a lan). I also have an external modem that verizon gave me, which is also detected by mandrake. What I don't know, is how I got it to work once, and not again! I went thru the wizards, and made sure it was adsl and ppoe, because that worked for me the one time. But now it wont. Oh, can anyone help me? I will be eternally grateful!

MasterC 07-18-2003 04:38 AM

Are you sure you use ppoe? Is it possible you use DHCP? When you are in any other OS what do you have to do to get on the internet?

Cool

linda 07-21-2003 11:02 AM

Well, I got it to work!

I got rid of Mandrake because I read somewhere that there was a bug concerning internet connections, and I didn't want to have that getting in the way, since i didn't know what I was doing anyway.

I installed Libranet without letting it automatically find my network card or configure my network connection.
Then I went here http://www.roaringpenguin.com/pppoe/
and got their program. And read all of the information!
Then I went back to Libranet, went to XAdmin and loaded my network card. That worked fine for me, it detected it.
Then I followed the instructions included with Roaring Penguin's program to the letter: I did NOT use any of Libranet's menus. I think that is what did me in the last time I tried: all of those editing menus added too much conflicting information. (Maybe)
Anyway, I checked to make sure my card was working by typing lsmod and ifconfig the0, and it was fine.
So I then typed adsl-setup and followed it from there. For Verizon, I had to type in my username with the @verizon.net. When it asked for dns numbers, I typed in server (as suggested by the promp since Verizon takes care of numbers). And by golly it all worked. I am so happy!

Oh, another thing I did before I booted into Libranet, I turned off the Westell modem from Verizon. I booted into Libranet, and then turned it on. I don't know if that helped, but it does send info to the computer, so maybe turing it on while in Libranet sent some needed info to my computer.

Well, I hope this keeps working!


All times are GMT -5. The time now is 07:58 PM.