LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Internet access on root bot not on user (https://www.linuxquestions.org/questions/linux-newbie-8/internet-access-on-root-bot-not-on-user-201736/)

Focalpoint 07-06-2004 11:14 AM

Internet access on root bot not on user
 
Well...
I can trigger an adsl connection form root console but uder user programs
still don't see any connection. I suppose the problem is trivial, where can I set
something so that my 'user' can have access to the internet...

Still working from root ;>

Greetz :-)

aaa 07-06-2004 11:22 AM

Use 'sudo'. Wrap up what you do to connect in a shell script, and have your user use sudo to call it: 'sudo [theshellscript]'. You will need to edit the /etc/sudoers file with the visudo command ('visudo' by itself) for it to work.

MikeZila 07-06-2004 11:22 AM

What do you do to "trigger" the connection? If you can do it from a root console, does using a root console from within a user session work?

Focalpoint 07-06-2004 11:33 AM

To trigger a connection I need to type form root or root console 'adsl-setup'.
When from user I run a console, then su - and get root and from root 'adsl-setup'
it connects, but programs form user such as Kadu (communicator popular in my
country) still doesn't see internet connection.
I will try to use visudo...


All times are GMT -5. The time now is 02:42 PM.