LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Internal Modem - am I doomed? (https://www.linuxquestions.org/questions/linux-newbie-8/internal-modem-am-i-doomed-176/)

CragStar 10-17-2000 07:59 AM

Hello, I have just installed SUSE 7.0 on my PC and am really getting to grips with it.However, there are many problems that I am having at the moment. The main problem for me is that internal, PCI, softmodems are not well supported. I posted a question an another site to see If I could get around this prob, and was directed to a site where I downloaded some files appropriate to the modem I have (HSP, PCTEL). Now, what do I do to these files? I am at college at the moment, so I dont know what I downloaded as such. Later on I will post from home to tell you what I have. But if anyone knows what to do I will appreciate ANY information at all. I am a complete novice that has been messing around with Linux for about 2 days. So I dont know much. Thanks for any help.

bjc 10-22-2000 05:51 PM

http://www.linmodems.org - Winmodems on Linux
ftp://www.pcchips.com.tw/driver/Linux/MODEM/PCTEL.ZIP - PCTel Modem on Linux

I have a PCTel Modem myself, and found a driver for PCTel modems. I haven't tested it myself, mainly because I can't figure out how to install the driver, but here it is.

CragStar 10-25-2000 11:54 AM

Hehe, you know what, I have found that Driver, and like you, cannot work out how to install it! However, I am reading Running Linux, and hope to learn enough to install the driver so I dont have to use Windoze to use the internet.

I will let you know how it goes.

bjc 10-28-2000 01:38 PM

well..for one thing, many people have suggested to me that the way to use that driver is to insert it into the kernel and recompile it...and guess what?..

IT DOESN'T WORK!

so I'm still stuck where I am....

jeremy 10-28-2000 03:55 PM

1) Download the file
2) unzip -a PCTEL.ZIP
3) cd src/module
4) make
5) insmod ptmodule.o

bjc 10-28-2000 07:28 PM

insmod ptmodule.o will produce an error:
"
insmod: a module named ptmodule already exists.
"
Someone else suggested, in /lib, to "insmod pctel.o"...
error message would be:
"
pctel.o:unresolved symbol IntrOpen
pctel.o:unresolved symbol IntrClose
pctel.o:unresolved symbol IntrWrite
"

CragStar 11-05-2000 10:43 AM

Jeremy, you have said to insmod the wrong module. It should be insmod pctel.

The reason for the ptmodule.o file is that you can make the necessary files for pctel. This is according to the Linux howto on linmodems. I still cannot get my modem to work because I cannot configure the serial port. Does anyone knoe how to get it to work with the modem?

bjc, I recommend looking at the Howto at http://www.Linuxdoc.org
Its called Linmodem Howto. It is pretty good, but like I said, I still haven't got round to getting my modem to work.
:-)

bjc 11-05-2000 02:53 PM

I have read the howtos since that last post...however, Linux does not know that it is supposed to use that driver for the modem. I did finally get that module installed properly, after reinstalling, but now minicom, setserial, pnpdump all say there isn't a modem in existance, so I'm stuck again.

CragStar 11-05-2000 03:03 PM

The way you get Linux to recognise the modem is to configure the serial ports. It covers it in the Linmodem howto. It suggests reading the serial Howto aswell. I have just downloaded the file, and will try to understand what it is saying. Again, all I can say is to read them both and try to work with them. I must admit it is hard, but any progress I make I will pass it on. Sorry I cant help much at the moment.

bjc 11-05-2000 04:17 PM

I've read the howtos at linuxdoc.org this morning, but I can't even get past the any GUI config because the hardware is not set. Linuxnewbie.org, I can't even get past pnpdump...and #linuxhelp, ppft!, like THEY know anything. They just keep on telling me to "read the documentation", "stop asking documented questions"..blah blah blah. Just because they have broadband doesn't mean they don't need to know or explain older technologies!

Besides, the way I see it is that is linux basically limited to "older technologies because they don't support a LOT of the newer technologies and devices!

GEEZ, I'm so ticked off at everyone on IRC...listening to a BUSY signal is better than asking 173 people on #linuxhelp.

jeremy 11-05-2000 04:37 PM

This should be the relevant part of the howto - http://www.linuxdoc.org/HOWTO/Linmodem-HOWTO-4.html

If you are still having trouble after reading that or if you need something explained let us know.
Thanks for the correction CragStar...I was in too much of a hurry when I typed that!

CragStar 11-06-2000 09:23 AM

Jeremy, can you help a second.

I have successfully installed the module using insmod. Now I have tried to configure /dev/ttyS15 using setserial. Is this right. What I have typed is:
setserial /dev/ttyS15 port 0xd000 irq 10
THEN
ln -sf /dev/ttyS15 /dev/modem

This sets the device file ttyS15 to what I want then limks it to the modem file, but I am still unable to talk to the modem. Is there anything which I am doing wrong? The port settings and the irq settings I obtained from windows. :-) I assume they are right beacuse it works in there.

If you can see what is wrong then I would like to know.
Cheers.

jeremy 11-06-2000 10:25 AM

Sure. Did you follow the steps 4-4 through 4-11? If so did you get any errors?

CragStar 11-06-2000 02:45 PM

Actually, I could not create /dev/ttyS15 beacuse it was already a file. So that was fine. I had to use the -f for insmod and ls -s , otherwise it wouldn't do it.

I haven't tried to edit the serial.conf file. Do you think this could be it?

Its the port address and irq that I am worried about. I think they are right, but again I set them with setserial, so they should be set up? Yes or no? And I didn't bother fixing the ppp.o file. Does this matter?

But no I didn't recieve any errors apart from a busy modem.

Ahhh, this is really annoying, but no way am I going to give up.

Do you know what the pctel.o module is for? It doesn't link in with anything that I do, apart from inistilising it.





bjc 11-06-2000 07:15 PM

I can't run the fixscript script.

I went "chmod +x fixscript", and it says "./fixscript: command not found" in tcsh, or "bash: ./fixscript: No such file or directory" in bash.


All times are GMT -5. The time now is 08:13 AM.