-   Linux - Newbie (
-   -   Intel i810 video mode to use at boot prompt for high res video in Xwin (

will_kranz 02-17-2009 10:07 AM

Intel i810 video mode to use at boot prompt for high res video in Xwin
[see note at end, I've solved this problem....]

I'm not exactly a newbie, but this question fits the bill.
I find I really don't understand what the video mode one
enters at the boot prompt is doing when lilo.conf contains
"vga=ask". I have a couple different system with different video
controllers. All are currently running the 2.4.31 kernel, but
I think is is a fairly generic issue.

Some of these systems allow me to enter vesa video modes (at least
I think they are, 791 is one that works on two systems). However if
I list the valid modes at the prompt after the kernel loads it says
the only available modes are 0 to 0xb even though it accepts and honnors
the 3 digit number above. Whats going on here?

I tried doing research and think I read that these are bios video modes
supported by the controller chip. I also read some of the i8xx series
have problems with linux incorrectly reading the video modes available from the chip. Maybe this is my problem. On the system that does have
an i810 chipset it rejects any video mode not in the range 0 to 0xb, yet
my other two systems are happy with much larger modes. dmesg on this system shows the agpgart is seeing the frame buffer, but this happens long after the prompt for video mode.

Am I off base here? Is there a better way to control my video mode when
I start Xwindows.


------------------- update the next day ------------------
I wish I could retract the post above, it now seems foolish :-(.

A little more research allowed me to solve most of my own questions.
Clearly I should be setting X Window resolution in my /etc/X11/xorg.conf I found a good list of VESA modes at
0x100 through 0x11B would be better choices if I really wanted a graphics mode (which I don't).

My 2.4.31 kernels do accept these modes and dutifully switch into graphics mode. This isn't so useful as one can't read the boot prompts in graphics mode but one can type blind and control the system. 'Shutdown' and 'startx' both work properly after login.

All times are GMT -5. The time now is 05:42 PM.