LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-24-2019, 04:21 AM   #1
DezSanchez1605
LQ Newbie
 
Registered: Dec 2019
Posts: 2

Rep: Reputation: Disabled
Intel Graphics issues - glxinfo, compositor


Hello,
I have a laptop with intel graphics, and after some tweaking, compton (or picom) is not working anymore, where it did before.
OS: void linux
glxinfo output
Code:
name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig
lspci information
Code:
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
Picom command
Code:
picom --vsync -b --backend glx
Picom did work before, please help remote debugging :|
 
Old 12-24-2019, 07:57 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, Pi OS & Android
Posts: 11,980

Rep: Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414Reputation: 1414
Quote:
Originally Posted by DezSanchez1605 View Post
Hello,
I have a laptop with intel graphics, and after some tweaking, compton (or picom) is not working anymore, where it did before.

Picom did work before, please help remote debugging :|
That's a bit vague. Evidently it was working, and you "fixed" it, breaking rule #1 of maintenance
Quote:
If it ain't broke, don't fix it!
Can you undo what you did, tell us what you changed, or show logs or something? You may find runlevel 3 useful for this. You can set that in /etc/inittab; change the number on the line with initdefault to

initdefault:3

and start X by typing 'startx'
also post the output of
Code:
cat /var/log/Xorg.0.log |grep -e 'EE' -e 'WW'

Last edited by business_kid; 12-24-2019 at 07:59 AM.
 
Old 12-24-2019, 10:56 PM   #3
DezSanchez1605
LQ Newbie
 
Registered: Dec 2019
Posts: 2

Original Poster
Rep: Reputation: Disabled
Sorry for the late reply
I ended up reinstalling void linux anyway, so it's all good. Honestly, I have no clue how it broke while I was modifying the DE.
Thanks for the assistance
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: SteamOS Now Features a New Custom Graphics Compositor Specifically Designed for It LXer Syndicated Linux News 0 05-19-2014 04:40 PM
[SOLVED] Video DRI problems with Intel i865. glxinfo gives wrong output vdemuth Slackware 10 08-14-2011 04:30 AM
Thinkpad T410 graphics issues / Intel HD Graphics Landshark Linux - Laptop and Netbook 1 04-02-2010 07:13 PM
Graphics card supports opengl 2.1, but glxinfo shows only 1.4 WhatsUnderThere Linux - Hardware 3 02-26-2009 12:23 AM
Graphics issues with Intel 82856G Graphics Adapter herrmag Linux - Newbie 1 08-09-2004 03:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration