LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   intel 536ep modem with suse 9.3 pro (https://www.linuxquestions.org/questions/linux-newbie-8/intel-536ep-modem-with-suse-9-3-pro-323265/)

pcandpc 05-13-2005 08:05 PM

intel 536ep modem with suse 9.3 pro
 
Hello?

I am trying to make the Intel 536EP modem
in SuSE 9.3 Professional. This modem is automatically
detected by 9.3, but when configured correctly, the
modem does not work.

The same modem works great under SuSE 8.2 Pro
and FC3.

Has anybody using SuSE 9.3 made this modem work?

I even tried Intel's latest modem driver, but failed. Actually,
9.3 already comes with the latest Intel driver.

Thanks.

nawwar 05-28-2005 07:21 PM

I have the same problem, the modem worked well on SuSe 9.1 with intel driver ver:4.69 (which is the latest). now SuSe 9.3 already comes with the same driver but it's not working. -frustrating :(
Any idea?

pcandpc 05-29-2005 03:28 PM

Hi nawwar,

Thanks for your supportive feedback.

So, it wasn't me alone who's having the issue
on SuSE 9.3 Pro with Intel 536EP modem.

I suppose Intel should update their current driver
accordingly for SuSE 9.3 Pro, but does anybody have
any idea on resolving this issue meanwhile?

Again, the same 4.69.1 driver works great on SuSE 8.2 Pro,
FC3, and Mandrake PowerPack 10.1.

Regards,

nawwar 05-30-2005 06:55 PM

Hi pcandpc,
no, you're not only facing this problem, it looks like a common problem, I know a couple of freinds having the same problem too.

The current driver doesn't work with linux kernel ver 2.6.11.* , I hope someone finds a way to hack around it or make a patch to the driver.

I don't really count on Intel to update their driver, because they're very lazy in this area, it took them a really long time (something like a year) before they updated the driver to the current one to make it work with linux 2.6.*



NB:
Although I'm new here, but I was wondering whether this is the proper forum to place this thread, isn't the Hardware forum more suitable for such topics? (Admins?)

pcandpc 05-30-2005 07:47 PM

Hi nawwar,

Thanks for your confirmation.

Actually, I was trying to understand the mechanics of Intel's
driver, but their coding was not very well documented for
readers to follow through and understand.

So, someone needs to update the Intel modem driver. Sad.

I'll be looking forward to the updated driver.

Regards,

Emmanuel_uk 05-31-2005 03:05 AM

Hi,

What is the kernel version in suse 9.3?

I know of at least 1 person using 9.3 and a 536ep

See my post, that should be applicable to you.

http://www.linuxquestions.org/questi...17#post1636217

I only really have introduced disbling pm_access
- pm_access(power_dev);
+ //pm_access(power_dev);

The original patch is from "Vedran"

Please let us know how this goes

nawwar 05-31-2005 05:35 PM

Thank you Emmanuel_uk very much for your help, I'll try the patch and tell you what happens.

SuSe 9.3 uses kernel version 2.6.11

I wonder if there is any difference between the UP and the SMP drivers, the patch depends on the UP version, but I'm using the SMP versin of the kernel (my CPU is Intel Pentium 4 3.0 GHz/HT).

Edit: I've just understood that there is no UP and SMP in the uncompiled version of the driver. The difference is, when it's compiled, whether it's compiled for UP kernel or SMP kernel. Right?

pcandpc 05-31-2005 06:54 PM

Hi Emmanuel_uk,

Thanks for your tips.

nawwar,
Great! I'll be looking forward to your bright outcome
and thanks for getting back to Emmanuel_uk for the
SuSE 9.3 Pro kernel info.

Regards,

Emmanuel_uk 06-01-2005 02:35 AM

2.6.11 is the "right" answer. The patch applies to this version.

I am curious to know if you need or not to disable
pm_access(power_dev);

for the patch to work. Can you let us know, if you ever get a chance.

Normally, the guy from Intel in charge of the driver should
know by now about these problems. But some more users
confirmation would be good.

pcandpc 06-01-2005 11:38 AM

Hi Emmanuel_uk,

I'll try to work with your suggestion, but by then,
Intel might have already officially released a new
driver, I hope.

Anyway, great suggestion and resource, Emmanuel_uk!

Thanks.

Emmanuel_uk 06-02-2005 02:32 AM

Quote:

but by then,
I would not count on this for now. Personal opinion here, but
from what I read "modem companies" do not keep up very well
with Kernel updates. So if I were you I would not wait,
I would try asap. Personally, my 536ep board has a physical defect,
it is still under guarantee, that is nothing to say about any other 536ep,
it is just a random thing I suppose,
and yes it was great to learn a bit about drivers and patches,
and help other people, but as soon as I can I will buy a hardware modem.

pcandpc 06-02-2005 10:30 PM

Hi Emmanuel_uk,

Following your patch 1 and 2, I changed the ".../coredrv/softserial.h"
and ".../coredrv/softserial_io.c" files accordingly but during the "make
install" stage where the Intel driver is supposed get installed, I get
the following script errors:

...

chgrp: cannot access `/dev/536ep`: No such file or directory
chmod: cannot access `/dev/536ep`: No such file or directory

done

But, the /dev/536ep has been created and exists properly. So, I went
ahead and tried to initiate the dial-up account but the connection failed.

Do you have any further suggestions?

Thanks.

Emmanuel_uk 06-03-2005 02:17 AM

These are not my patch :-), only a minor contribution
I wish I was that good!

Possibly look like you did not do the
make clean
make 536ep
make install
as root

Be root (type su in a terminal windows
then cd /where/ever/thepatchedfiles are)

Please try that, if it does not work, post the whole make session,
and ls -l /dev/5*; ls -l /dev/m*

On my system I also have /dev/536ep0
Never digged out why or even if it is normal

By the way, I am not clear how the patching process went.
If you used the patch command you should have had 3 lines
saying basically that it went well.

pcandpc 06-03-2005 03:39 AM

Hi Emmanuel_uk,

Yes, of course! If the scripting process went successful,
one'll have a clean "done" script response at the end of
three makes.

And surely, I've run the make scripts as "root", but it's
a puzzle to you and me why I'm getting "chgrp" and "chmod"
access errors on /dev/536ep.

I think the /dev/536ep is the result from compiling the Intel's
driver where as /dev/536ep0 is SuSE's default pre-compiled
module. And, the /dev/modem is a symbolic link that points
to the /dev/536ep, and this link is the result from the driver
compiling.

So, it appears important to figure out the access errors first
in solving this issue, Emmanuel_uk.

Do you know of anyone who successfully compiled the patches
on SuSE 9.3? I thought you stated in your previous replies that
you know of someone who made the 9.3 working.

Thanks.

BTW
Posting the whole make session is just too long. Perhaps, you
should just look at it yourself from your own compiling.

Emmanuel_uk 06-03-2005 03:54 AM

sorry I suggested newbee stuffs
wanted to be sure the modem link was there
my compiling was in mandy 10.2

Klaus is the man with suse 9.3
http://linmodems.technion.ac.il/arch.../msg02026.html

pcandpc 06-03-2005 08:36 PM

Hi Emmanuel_uk,

Thanks for your feedback.

I've e-mailed Klaus regarding the access error issue
during the "make install" to see if he can share some
of his idea.

I'll update this thread accordingly if I hear from him.

Meanwhile, if anybody has any idea/suggestion, your
comments will be greatly appreciated.

Regards,

nawwar 06-04-2005 08:47 PM

Hi,
Sorry for being late to respond, <I am actually busy with me exams currently>.

Here's what happend with me.
I Applied the patch . then I did the "make" steps (clean, 536, install).
Something was wrong during the install, similar to what happened with pcandpc. I found out later that there was some confusion in that there was something called /dev/536ep0 while it was supposed to be /dev/536ep .
So I did some manual steps described in that readme file that came with the driver, something like:
Code:

insmod -f Intel536.ko
rm /dev/536ep
mknod /dev/536ep c 240 1
ln -s /dev/536ep /dev/modem

That made the /dev/536ep driver and /dev/modem linking to it. I felt that I acheived something at that point, so I started the kppp, used /dev/modem device, when I tried to connect, the kppp crashed (it started alocating huge amounts of memory endlessly). I also remember that there was a "Query" button in kppp configuration, when I pressed that butten it walked through several steps "succesfully apparently", then displayed a dialog box showing 7 empty strings. (AT1,AT2,...etc).

PS: I tried doing all the steps twice, with and with out commenting the line pm_access(power_dev). I got the same results in both cases.

pcandpc 06-05-2005 01:12 PM

Hi nawwar,

Thanks for your resourceful updates.

I havn't heard from Klaus yet, but when I do, I'll certainly
update this on-going thread.

Regards,

Emmanuel_uk 06-06-2005 08:28 AM

PcandPC
A user on kernel-devel-2.6.11-1.1366_FC4.i686
has commented on linmodem having to comment
out pm_access as well, so "my fix" is necessary.

I am keeping en eye on the list so if anything props up about suse
I will let you know.

You know that group error, I do not if it matters or if this
can be resolve by changing permissions? Did you look
if /dev/536ep was part of the dial group (or whichever group is needed)?

>>So, I went ahead and tried to initiate the dial-up account but the connection failed

Can you post the error messages?
I suggest you use wvdial rather than kppp, if you can, it is easier to diagnose
problems during dial-up. Mave be nothing is wrong with the driver,
but still you could have a problem with the setup of kppp.
Do the ATI command works (in Kppp)?

You may need to trick wvdialconfig if you want to use it by
creating a few symbolics link to ttyS0 (???) because that the
only ports wvdialconfig can scan.

pcandpc 06-07-2005 03:52 AM

Hi Emmanuel_uk,

Actually, the /dev/536ep was never created in my case.
I was misled by not correctly reading the directory listing.

As far as my comment on "connection failed", I simply meant
that the connection was never successfully made by observing
the icon on the panel.

I've used the KPPP since 8.2 Pro and quite familiar with its GUI
configuration than any other dial-up utility, but I'll consider the
wvdial per your suggestion.

As it stands now, the ATIs do not matter because my modem is
never detected by 9.3 Pro to begin with.

I just hope I can hear something from Klaus.

Thanks.

Emmanuel_uk 06-07-2005 08:23 AM

PcandPc, did you try Nawwar manual method, i.e.
mknod /dev/536ep c 240 1
before or after the make install (try both?)
A shot in the dark, to see if that changes the error message

nawwar 06-08-2005 06:23 PM

I tried wvdial, it failed and printed error message "Segmentation fault"

This is a sinppet from the syslog:

Code:

Jun  8 00:01:49 linux kernel:  <6>ACPI: PCI interrupt 0000:02:09.0[A] -> GSI 21 (level, low) -> IRQ 225
Jun  8 00:01:49 linux kernel: divide error: 0000 [#5]
Jun  8 00:01:49 linux kernel: SMP
Jun  8 00:01:49 linux kernel: Modules linked in: ppp_generic slhc Intel536 thinkpad nvidia speedstep_lib freq_table thermal processor fan button ipv6 battery ac nvram joydev st evdev af_packet sg snd_pcm_oss snd_mixer_oss edd sk98lin ohci1394 ieee1394 uhci_hcd ehci_hcd i2c_i801 usbcore i2c_core intel_agp agpgart hw_random parport_pc lp parport snd_intel8x0 snd_ac97_codec snd_pcm snd_timer snd soundcore snd_page_alloc nls_cp437 vfat fat nls_utf8 ntfs sr_mod dm_mod ext3 jbd ide_cd cdrom ide_disk ata_piix libata piix ide_core sd_mod scsi_mod
Jun  8 00:01:49 linux kernel: CPU:    0
Jun  8 00:01:49 linux kernel: EIP:    0060:[<e1547fc8>]    Tainted: PF    U VLI
Jun  8 00:01:49 linux kernel: EFLAGS: 00210246  (2.6.11.4-20a-smp)
Jun  8 00:01:49 linux kernel: EIP is at SetPLL+0x1fa/0x2a0 [Intel536]
Jun  8 00:01:49 linux kernel: eax: 00000000  ebx: 00000000  ecx: 00000000  edx: 00000000
Jun  8 00:01:49 linux kernel: esi: c7fd0d80  edi: 00000000  ebp: dc49de58  esp: dc49ddf0
Jun  8 00:01:49 linux kernel: ds: 007b  es: 007b  ss: 0068
Jun  8 00:01:49 linux kernel: Process wvdial (pid: 8355, threadinfo=dc49c000 task=dfb30020)
Jun  8 00:01:49 linux kernel: Stack: 0100ef60 c0404928 c03fdb00 00000000 c012a525 dc49de30 dc49de30 005143f8
Jun  8 00:01:49 linux kernel:        c01360c0 dc49c000 c012a577 005143f8 c030ef2c 00000000 00000001 00000000
Jun  8 00:01:49 linux kernel:        01100100 7f000f00 0000f0b7 0000f0b6 4b87ad6e 00200287 c0136080 e1612f20
Jun  8 00:01:49 linux kernel: Call Trace:
Jun  8 00:01:49 linux kernel:  [<c012a525>] del_timer_sync+0x85/0xc0
Jun  8 00:01:49 linux kernel:  [<c01360c0>] autoremove_wake_function+0x0/0x50
Jun  8 00:01:49 linux kernel:  [<c012a577>] del_singleshot_timer_sync+0x17/0x30
Jun  8 00:01:49 linux kernel:  [<c030ef2c>] schedule_timeout+0x6c/0xc0
Jun  8 00:01:49 linux kernel:  [<c0136080>] finish_wait+0x30/0x70
Jun  8 00:01:49 linux kernel:  [<e1547d1f>] IM_PLL_SetDSPFrequency+0x6d/0x76 [Intel536]
Jun  8 00:01:49 linux kernel:  [<e154a3e8>] IM_Power_Down+0x22/0x8e [Intel536]
Jun  8 00:01:49 linux kernel:  [<e1549eef>] IM_DSP_OFF+0xb/0x34 [Intel536]
Jun  8 00:01:49 linux kernel:  [<e1544d52>] clm_terminate+0x52/0x70 [Intel536]
Jun  8 00:01:49 linux kernel:  [<e15441c5>] close+0x5/0x30 [Intel536]
Jun  8 00:01:49 linux kernel:  [<e1546926>] softserial_close+0x26/0x50 [Intel536]
Jun  8 00:01:49 linux kernel:  [<c0240c12>] release_dev+0x402/0x7d0
Jun  8 00:01:49 linux kernel:  [<c023ee7a>] tty_ldisc_try+0x3a/0x50
Jun  8 00:01:49 linux kernel:  [<c011d4c8>] __wake_up+0x38/0x50
Jun  8 00:01:49 linux kernel:  [<c023effb>] tty_ldisc_deref+0x8b/0xb0
Jun  8 00:01:49 linux kernel:  [<c0241ff7>] tty_ioctl+0x237/0x6b0
Jun  8 00:01:49 linux kernel:  [<c01769e0>] __pollwait+0x0/0xd0
Jun  8 00:01:49 linux kernel:  [<c0175f61>] do_ioctl+0x71/0xa0
Jun  8 00:01:49 linux kernel:  [<c024146f>] tty_release+0xf/0x20
Jun  8 00:01:49 linux kernel:  [<c01643e6>] __fput+0x116/0x160
Jun  8 00:01:49 linux kernel:  [<c0162a6f>] filp_close+0x4f/0x90
Jun  8 00:01:49 linux kernel:  [<c0104079>] sysenter_past_esp+0x52/0x79
Jun  8 00:01:49 linux kernel: Code: e0 89 04 24 0f b6 07 e9 af 00 00 00 3b 1d 48 3c 61 e1 76 06 8b 1d 48 3c 61 e1 89 d8 d1 e8 8b 0d 48 3c 61 e1 01 c8 ba 00 00 00 00 <f7> f3 88 45 d9 fe 4d d9 0f b6 5d d9 8d 73 01 89 c8 ba 00 00 00


pcandpc 06-09-2005 12:06 AM

Hi nawwar and Emmanuel_uk,

Thanks for your consistent interest and feedback.

I'm so impressed! By the way, I'm in the middle of communication with Klaus.
Basically, he suggested the same methods as in Emmanuel_uk's patch link.
This took care of my previous script errors, but still my modem connection is
not made at all, and I conveyed this information to Klaus, and currently, I'm
awaiting for his feedback.

So, Emmanul_uk, you've made the patch working under Mandriva 2005 LE?
Lucky for you!

Besides this modem connection, I'm having other issues here and there on
SuSE 9.3 Pro. And, perhaps, I'll switch to other distro eventually if this modem
connection is not resolved. You know, I can't just try this and that indefinitely.

Again, thanks you all folks.

Regards,

Emmanuel_uk 06-09-2005 02:44 AM

Hi you two,

All I know about segmentation fault is that it _may_ be
a sign of the driver being unsuitable (i.e. code wrong or unsuitable).
Those bl..y patch are a pain when they come to line wrapping.
Can you try to patch by hand and see what the make steps give then?
(one of my mail explain how you can do the patch by hand)

I am sorry this 536ep is causing you so much trouble. As Klaus
had no problem, I assumed it would be the same for you two...
It seems the problem is out of my league.

Unless you can find what is different between Klaus system and yours,
I suggest
- you download scanmodem
- make uninstall (remove the /dev/536* if still there

then "record" all the steps (I mean the command line you used + 1 or 2
output lines if informative, you know what I mean)
- which intel file you are using
- state if you had error or not during the patch
(maybe best you take the patch from the ubuntu website and
disable the pm_access by hand)
- the exact errors with a few context lines during compilation
- the errors using wvdial
- make ref to http://linmodems.technion.ac.il/arc...h/msg02026.html
- make ref to linmodem email dated 04/06/05
"RE: Problem with Intel 536EP and Fedora Core 4 (RC3): Working! (Sort of)"
stating that it is the third confirmation that pm_access needs disabling
with 2.6.11 kernel for the 536ep

then run scanmodem

email all that + modemdata.txt to the discussion list of
http://linmodems.technion.ac.il

These guys there are fantastic, they surely will have further suggestions.
On top it is two of you with the same chip, same distro,
so it should make their life easier

I am looking forward to see what they suggest

If this fail (I do not think so), then this will go direct to
the intel developer

pcandpc 06-10-2005 08:29 PM

Hi Emmanuel_uk,

It'd be nice if Intel promptly updates their Linux drivers, but
then being Linux issues, I assume that they're under no obligation
at all other than their "voluntary" commitment, which is still appreciative.

By the way, I'm in the middle of communication with Klaus as I stated
in one of my previous posts. Hopefully, things iron out smoothly. His
suggestion is no different from what you, Emmanuel_uk, suggested in
the patch 1 link.

After all, he appears to be the one who made this modem work under
SuSE 9.3 Pro, and I'm diligently following up with him.

I'll certainly update this thread whether the result is successful or otherwise.

As a last resort, I'll consider working with the Linmodem.org guys. But then,
if I decide to switch over to the other distros, this is it for me.

So, the whole deal here is the kernel 2.6.10 and later with Intel 536EP modem
driver on SuSE 9.3 Pro, huh? Well, I don't have this issue at all under FC3 with
the same latest Intel driver. I suppose this is because FC3's kernel version is
2.6.9-something.

Hopefully, things work out for good with Intel drivers for kernels 2.6.10 and later
sooner or later.

Regards,

pcandpc 06-20-2005 12:14 PM

Hi,

I've been working with Klaus on this modem issue
since he appears to have made the modem working
on SuSE 9.3.

He was very helpful, and I made my modem working
the first time ever after reinstalling SuSE and carefully
following his suggestions.

His suggestions were no different from the earlier ones
by Emmanuel_uk on applying the patch.

However, my working with the modem didn't last long.
After having made work the first time, restarting the
modem conncetion failed. Since then, the modem hasn't
worked at all -- back to square one.

Now, I've decided to replace this SuSE with another
distro and sadly given up on this issue.

Hopefully, there'll be newer, officialy driver by Intel soon.

Thanks all for your efforts and helpful suggestions.

Regards,

nawwar 06-20-2005 12:46 PM

Thanks pcandps for your follow-up,

However, I've decided to change my modem, I'm thinking of an external one.

Thanks again everyone.

-Nawwar

pcandpc 09-05-2005 10:22 PM

Hi all,

If anyone's following this issue, I have a semi-bright news!

I've come back to this issue after some time lapse.

The 536EP modem is detected successfully under SuSE 9.3 Pro
when the DSL modem connection is on simultaneously.

As soon as the DSL modem is off, the modem wouldn't be able
to be detected nor would it work.

This is sad ...


pcandpc 09-10-2005 01:32 AM

Hi all,

Good news at last!

Intel appears to have released an updated
driver (4.71) that works nicely. I just tried it.

But, it appears the modem driver is not loaded
on each reboot ...

Please anyone look into this and advise us how
to fix the driver load on each reboot.

Thanks.

Emmanuel_uk 09-11-2005 12:21 PM

This is good news indeed.
re starting up, what about editing
/etc/modprobe.preload
# /etc/modprobe.preload: kernel modules to load at boot time.

pcandpc 09-11-2005 02:09 PM

Hi Emmanuel_uk,

It's nice talking to you again :)

By the way, I tried to look at /etc/modprobe.preload,
but no where could I see this file.

Just for your reference here, since I'd have to reinstall
the modem driver after each reboot for the modem to
work, I thought is the driver somehow missing and tried
to just uninstall the driver.

Well, the error message I got was the driver was not found.

This tells me that the installed driver is somehow gone
mysteriously on each reboot.

I came across reading somewhere that this is due to SuSE 9.3
keeping the driver in RAM ... Could this be the very reason?

If so, how can I have the driver in some non-volatile area even
after reboots?

As a side note, the same new driver is somewhat weirdly acting
in the other distro such as CentOS 4.1 I'm using.

The installation was successful but when KPPP tried to detect
the modem, the keyboard's Caps and Scrool Locks were blinking
and the entire system got frozen.

But that's another issue on this new driver.

I just want to get this SuSE 9.3 get going ...

Any idea, my friend? :)

Thanks.

Emmanuel_uk 09-12-2005 02:14 AM

Hi,

There is no reason why you should need to reinstall the driver everytime you reboot.
The driver should just need loading
Try in a terminal
insmod 536ep (you may need to be root)
if this does not work try
modprobe 536ep

if it does not work, then find where the 536ep driver lives (use the locate function, or find with konqueror)
and add the path like
insmod /path/to/536ep

Otherwise, well this would be really weird

sorry about modprobe.preload this must be mandrake specific
You might have a modprobe.conf, or something of the like

Otherwise, a dirty way to start the driver is to add the modprobe line
to you bashrc file

I have got old of suse 9.3 pro. Might give it a go at some point

pcandpc 09-13-2005 01:35 AM

Hi Emmanuel_uk,

I tried insmod /dev/modem (as well as /dev/536ep)
as root, but the reply was that this driver was not
found.

But, I see both modem and 536ep under /etc with
modem linked to 536ep. However, the size of each
file is reported as 0.

What does this tell you?

Thanks.

Emmanuel_uk 09-13-2005 02:16 AM

module (drivers) is a file called 536ep.ko
most module I understand can be loaded in addition to the kernel (they are drivers)
and finish in ko for kernel above 2.6 (they were .o before I think)
Find where it leaves (to be sure it is there)

the command to load the driver is
insmod 536ep
nothing else, no ko at the end, usually path not needed

If this works from command line (as root) after reboot, then next will be automation

if it does not work then add the path to
insmod /path/to/536ep (that is 536ep.ko)

pcandpc 09-13-2005 02:28 AM

Hi Emmanuel_uk,

Yes, I understood that well.

But what I meant was what do you think happened when
I ran insmod /etc/536ep and received an error that says
there's no module for 536ep when, in fact, I see it residing
under the /etc?

Bottom line is that the insmod 536ep or /etc/536ep doesn't
work.

Any further suggestions?

Thanks.

Emmanuel_uk 09-13-2005 02:40 AM

You mean 536ep.ko lives in /etc ?
Try modprob (or modprobe) instead of insmod
No other idea for now. I am away from my linux machine

pcandpc 09-14-2005 02:08 AM

Hi Emmanuel_uk,

What I meant to say was /dev/536ep ...

By the way, I tried the modprobe on
/dev/536ep but the result came up to
be not found even though there is
/dev/536ep.

Isn't this weird?

I also looked at /etc/init.d/ to see if I can
find something that's related to this Intel
modem, and I found /etc/init.d/S99_Intel536
that's linked to /dev/modem, which, in turn,
is linked to /dev/536ep.

This looks very sane to me, but it's weird that
I have /dev/536ep reporting as 0-byte sized
file. But then again, I think that I also saw this
0-byte size just after the driver installation and
before the reboot.

So, I don't think the size of /dev/536ep doesn't
really matter, or does it in relation to the probelm
I'm having on each reboot?

Thanks.

Emmanuel_uk 09-14-2005 02:23 AM

/dev/536ep is the device. The same way /dev/hda would be a hard drive device for example.
You cannot load /dev/536ep bec it is not a driver. /dev/536ep is a character device I believe,
so it is normal that /dev/536ep is 0 or 1 byte (size does not matter).

What is the output of
lsmod | grep 536
dmesg | grep 536
after reboot

Hoopps I said bashrc in a previous post, I really meant /etc/rc.local

S99 looks wrong, it should not be a link but a script (i.e. a text file)

What's S99 like after a .configure make etc
what is the output of
lsmod | grep 536
dmesg | grep 536
cat /var/log/syslog | grep -i '536ep|modem' (the bar is supposed to be working like a or, no linux machine to check syntax here)

[Added
On my PC
/lib/modules/2.6.8.1-10mdk/kernel/drivers/char/Intel536.ko

and S99_Intel536ep reads

Code:

#!/bin/sh
#**********************************************************************************
# Copyright (c) 1999-2004, Intel Corporation
#
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are met:
#
# 1. Redistributions of source code must retain the above copyright notice,
# this list of conditions and the following disclaimer.
#
# 2. Redistributions in binary form must reproduce the above copyright notice,
# this list of conditions and the following disclaimer in the documentation
# and/or other materials provided with the distribution.
#
# 3. Neither the name of Intel Corporation nor the names of its contributors
# may be used to endorse or promote products derived from this software
# without specific prior written permission.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS''
# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
# DISCLAIMED. IN NO EVENT SHALL CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
# EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
#***********************************************************************************
# 13-6-2002:  A few hacks by Diego Iastrubni <dgi_il@hotmail.com>

serial="Intel536"
devnode="/dev/536ep"
device="536ep"
registry="hamregistry"
group="root"
mode="664"


if [ -a /etc/SuSE-release ]; then
{
  group="dialout"
}
fi

case "$1" in
  start | b)
      if ! ( modprobe -f $serial 1>/dev/null 2>/dev/null ); then
      {
        if ! ( insmod -f $serial 1>/dev/null 2>/dev/null ); then
        {
          echo error loading $serial
          rmmod $serial
          exit 1
        }
      fi
      }
      fi
      major=`cat /proc/devices | awk "\\$2==\"$device\" {print \\$1}"`
      rm -f $devnode
      mknod $devnode c $major 1 2> /dev/null 1> /dev/null
      chgrp $group $devnode
      chmod $mode  $devnode
      ln -sf $devnode /dev/modem 1> /dev/null 2> /dev/null
      if ! ps -C $registry 1> /dev/null 2> /dev/null; then
      {
        if ! ( /usr/sbin/$registry  2> /dev/null 1> /dev/null & ); then
        {
            echo "Modem registry ($registry) could not start."
            echo "Please see international users secion in readme.txt for more info."
        }
        fi
      }
      fi
      exit 0
      ;;
  stop)
      rmmod $serial 1> /dev/null 2> /dev/null
      ;;
  restart | reload)
    /bin/bash "$0" stop
    /bin/bash "$0" start
    exit 0
    ;;
  status)
    if lsmod | grep "$serial " >/dev/null; then
    {
      lsmod | grep "$serial " > /dev/null
    }
    else
    {
      echo "$serial NOT loaded"
    }
    fi
   
    if  ps -C $registry 1> /dev/null 2> /dev/null; then
    {
        ps -C $registry
    }
    else
    {
        echo "$registry NOT running"
    }
    fi

    exit 0
    ;;
  *)
    echo unknown $serial script parameter
    exit 1
esac

exit 0


pcandpc 09-17-2005 03:14 PM

Hi Emmanuel_uk,

Thanks for your consistent help out on this issue.

Actually, the /etc/init.d/boot.d/S99_Intel536 is linked
to the /etc/init.d/Intel536.boot, which looks exactly
as your S99... file.

I tried lsmod command and received nothing as a result,
and received the following from dmesg command:

PID hash table entries: 4096 (order: 12, 65536 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
vesafb: framebuffer at 0xc8000000, mapped to 0xf8880000, using
6144k, total 65536k
TCP bind hash table entries: 65536 (order: 6, 262144 bytes)
TCP Hash tables configured (established 131072 bind 65536)

And, as with your the other cat command, I see the result of no
such file or directory.

Now, do you think you can help? :)

Emmanuel_uk 09-18-2005 04:59 AM

Lets go back one step

if lsmod | 536 gave nothing that means the driver is not loaded
(does lsmod on its own give a long list)

Have you located, after doing .config, install, make
the file Intel536.ko

pcandpc 09-18-2005 01:47 PM

Hi Emmanuel_uk,

Yes, I see /lib/modules/2.6.11.4-21.9-default/kernel/drivers/char/Intel536.ko.

So, the issue is that this is not loaded during each reboot, huh?

pcandpc 09-18-2005 10:53 PM

Hi all,

I found a solution to this issue as shown in the following link:

www.suseforums.net/index.php?showtopic=15652

Basically, one has to make sure the module Intel536 is listed
in the lsmod output first.

Please reinstall the driver if there's no Intel536 in the lsmod
output.

And, edit /etc/init.d/boot.local as root such that the following
is added to the file:

modprobe Intel536

Then, reboot.

I don't know if this is a temporary workaround but this works
nicely for now :)

Emmanuel_uk 09-19-2005 02:05 AM

PCandPC ,

I am glad this is sorted

Indeed the issue was that this
/lib/modules/2.6.11.4-21.9-default/kernel/drivers/char/Intel536.ko
was not loaded at boot

I did not know about the boot.local (possibly distro specific)
I was going to suggest to add
modprobe /lib/modules/2.6.11.4-21.9-default/kernel/drivers/char/Intel536.ko
into the rc.local

If you to fiddle to learn something by hand (and convince yourself of what
is going on I suggest these commands as root

lsmod | grep 536 (check the module is there)
modprobe -r Intel536.ko (remove it from memory)
lsmod | grep 536
modprobe /lib/modules/2.6.11.4-21.9-default/kernel/drivers/char/Intel536.ko
lsmod | grep 536
dmesg | grep -i taint
(the kernel is tainted, it is ok, because the driver is not an open source binary)

pcandpc 09-19-2005 12:00 PM

Hi Emmanuel_uk,

Just a quick comment.

I tried putting the following line in the boot.local file:

modprobe /lib/modules/2.6.11.4-21.9-default/kernel/drivers/char/Intel536.ko

But this didn't work when the system is already rebooted and
you don't have this Intel536 module available via the lsmod even
if you have the Intel536.ko available in the above path.

Thanks.

Emmanuel_uk 09-19-2005 03:08 PM

Not sure I understand. Your PC works ok now?

pcandpc 09-19-2005 03:23 PM

Hi Emmanuel_uk,

Yes, of course, my system works nicely
with the modem connection now :)

I was just commenting in my previous post
that even if one puts the following in the boot.local file,

modprobe /lib/modules/2.6.11.4-21.9-default/kernel/drivers/char/Intel536.ko

this will not work if one has rebooted a system and there's
no Intel536 listing under the lsmod command.

Instead, I just put modprobe Intel536 in the boot.local file
and this worked.

Again, thanks, Emmanuel_uk, for your consistency in paying
attention to this issue.

Emmanuel_uk 09-20-2005 01:51 AM

I am with you, my mistake, the instruction with modprobe must be without the ko at the end of Intel536ep,

it is a quirk of the system

Quote:

Again, thanks
You are welcome


All times are GMT -5. The time now is 12:02 PM.